Announcement

Collapse
No announcement yet.

M3-ATX no power

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • M3-ATX no power

    Just purchased a M3-ATX PSU and was having trouble getting power to it. For testing purposes I bought a 12V @ 6A AC/DC power adaptor to act as my power for my PSU while testing at my house (looks just like a laptop power adaptor).

    I broke out my 12v AC/DC and connected the positive to both the M3 positive and Ignition leads. Connected the 12v negative to the M3 negative. When I apply power to the adaptor nothing happens with the M3 and the 12v power adaptor's led pulses (it should be solid). There's definately something wrong here. Why is my M3 not powering on?

    Any suggestions?

    Thank you.

  • #2
    1.
    2.
    3.
    Slovenia, Europe
    best on-line radio

    Comment


    • #3
      still stuck

      I've read the manual multiple times but just for you miko I read all of them again to see if I was missing something.

      PWR-M3-ATX/PWR-M3-ATX-manual.pdf - Pg 2, Paragraph 1

      Power Input Connectors (right side)
      Red Battery + (positive unswitched battery)
      Black Battery - (negative)
      White Ignition (Can test be connecting it to Battery +)


      I have hooked my system up as stated above. I'm running my M3 in P0 configuration. My source is supplying 12.472volts. When applying power I see 0.75 volts across Red and Black. Is my M3 faulty or is it me??


      Thanks.

      Comment


      • #4
        Borrowed another M3 from a friend today. His works as expected. RMA this pos.


        thanks for the wonderful suggestions miko.

        Comment

        Working...
        X