No announcement yet.

I think my opus is dead. Help please

  • Filter
  • Time
  • Show
Clear All
new posts

  • I think my opus is dead. Help please

    I had some problem with the water pump failing on my car and had to be towed home at night with the lights on. So my battery went flat so i took it out for a full re-charge. When i put the battery back in and the car was fixed my car pc no longer powered up. When i checked the opus it had blown the fuse. So i put a new one in and now all i get when going to ignition is two flashes from the status light. The manual says this is one of the following.
    1. Power jumpers wrong way round (have not been moved) Tried them the other way round anyway with no joy.
    2. Bios power management settings, which i also checked by using a mains power supply. They were fine so i tried it in the car again with the same result. 3. possibly faulty dc-dc power supply.
    So what can i do? I doubt its in warranty cos its at least 2 years old, i noticed they dont even make the 90w one anymore. Will i just have to shell out for a new one?


  • #2


    • #3
      did you have it fused at the battery like you should? If not, this is what happens when you rely on the onboard fuse solely.

      You might be able to replace components here and there and hopefully get it working, but seems easier and cheaper to just buy a new one.
      Fusion Brain Version 6 Released!
      1.9in x 2.9in -- 47mm x 73mm
      30 Digital Outputs -- Directly drive a relay
      15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
      Buy now in the Store


      • #4
        Yeah i had it fused at the battery. Strangly this fuse did not blow and im pretty sure its the same rating as the one on the board. Ive had a look at the supply and i can see a possible dry joint so im going to try re-soldering it and having another go. No indication of any blown components though.