No announcement yet.

M2-ATX powerup & shutdown issue, probably fried

  • Filter
  • Time
  • Show
Clear All
new posts

  • M2-ATX powerup & shutdown issue, probably fried


    I searched the forum for hours but couldn't find the exact issue I'm having here.

    I'm new to this forum so I'll quickly introduce myself:

    My name is Erik, and I live in the Netherlands, in IJmuiden, not very far from Haarlem. I'm 25 years old and I'm driving a 1995 Citroen XM Exclusive. I work as a machine builder and general technician in a steel wire rope factory also in IJmuiden.

    2 weeks ago I bought my first carputer kit after I already fitted a touchscreen in the place where the 2 DIN slots used to be.

    The kit consists of:
    - VoomPC-2 case
    - Intel D945GCLF2 mobo+cpu (Atom N270 dual-core)
    - 1 GB DDR RAM
    - 80 GB Harddisk
    - M2-ATX power supply

    I built the system, tested it for a while, works, but had some trouble yesterday with connecting the amp control from the M2-ATX to my amps (I have 2, each 2x25 watts). I connected the RMT pin from J6 to the Remote wire of my amps, and the other directly to GND. *** not knowing there are negative-switched amps out there. ***
    I have connected my display to the 12V rail of the power supply. Then, when I turned on ignition, the display flickered briefly, and went off not to switch on again, the whole computer wouldn't power up. No fan spinning, nothing.
    So I quickly disconnected the whole system suspecting a short-circuit and disconnected the amp remote lead to check if the system would still work, and it did.
    Because of this I thought the manual is unclear and the J6 connector is acting as a relay, with an in and out wire, so I connected the GND lead of J6 to the ACC line of my car, and the RMT to my amps. I turned on ignition, and... WHOOOPS!! Big smoke cloud coming out of my carpc!

    Once again, quickly disconnected power from the system and disconnected the J6 lead completely. The PC then would power on once more but after that only the flickering of the display and then doing nothing.

    So I went back home with my carpc to open it and to look what's been fried.
    Luckily (I thought) it was the black wire of the lead going from the Molex connector of the VoomPC to J6 that was completely burned. I had a similar lead lying around, from an old Tower-PC, replaced the lead, and tested the system on a car battery charger. Phew, it still works!

    Back in the car, I wired up the carpc and works. Connected only the RMT wire from J6 to my amps, and wow! Everything works! But after about half an hour, when I tried to turn on the system again it wouldn't powerup: only the display flickering. My guess was that the car battery voltage was becoming low, I didn't have a voltmeter around at the time. So I started the car, and yes, the system works. I let the car run for 30 minutes to charge the battery, and then turned the car off to ACC. After another 15 minutes I was done and turned off the car completely, and then my carpc rebooted suddenly, like it had a power surge, to shut off completely after five seconds.

    I tried to turn on the system again and it wouldn't start. So today I checked the voltage going to the carpc with a voltmeter, and it's reading 12.1V, well above the 11.2V shutdown threshold. And it seems it's getting worse, when I started the car this evening the system still wouldn't power up until I disconnected and reconnected it while the engine was running.

    So, is my M2-ATX fried or is there something else going on? If it's fried then it's my bad of course, but can I fix the power supply myself or should I buy a new one?

    One final note: the system doesn't try to restart every 5 seconds as I've read in other topics. I HAVE seen this happening on this system when it isn't getting enough juice.

    Best regards,