Announcement

Collapse
No announcement yet.

GP83 160W Intelligent DC-DC PSU Won't power up my amp

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GP83 160W Intelligent DC-DC PSU Won't power up my amp

    I am having issues with this power supply turning on my amp. Everything to the amp is good but for some reason it won't kick on. I have tried starting up with the amp hooked to both pins (not at the same time) with no success.

    Please help me out. Thanks

    EDIT: Also, does anyone know the pin settings for the start up-shut down timings? I read the instructions 5 times and couldn't find it anywhere.

  • #2
    if the amp powers on using a normal acc line, then you might need to use a transistor-- like what is used on the m2 power supplies(you can find out more in the m2 area).
    My OLD 2001 Mitsubishi Eclipse GT:
    "The Project That Never Ended, until it did"


    next project? subaru brz
    carpc undecided

    Comment


    • #3
      I ended up just tying it in on the ACC line. Works fine now.

      Comment


      • #4
        I use the yellow and black line to power my touchscreen, I haven't tried the amp turn-on but You could just hook the yellow wire from the 4 pin connecter to the remote turn on to the amp and it should work the same.

        also google "gp83 psu info" and there is a PDF for the timers

        I'm having trouble with my gp83 not turning on/off the cpu when the ACC wire is is given power, it turns on/off then I short the 2 wires from the j8 to the cpu switch legs together but I cant get the dang PSU to control it.

        Comment

        Working...
        X