No announcement yet.

P2140 Keeps Shutting down Power to Device after 1 min

  • Filter
  • Time
  • Show
Clear All
new posts

  • P2140 Keeps Shutting down Power to Device after 1 min

    Hi Everyone, I'm working on installing a Mac Mini running Windows XP
    with a lilliput 7" Touch Screen into my 1998 S10 SS. I'm like 97% there!

    Heres my problem. I can start up my truck and the mini will turn on along with the display
    then either 1 or 2 things will happen, As its starting up once Windows is done booting it will immediately go through the cycle of shutting down or it will just loose power all together.

    I know this is a problem with the unit itself, since I am using a multimeter on the connections that go into the PSU and they have reading. Everything after the PSU has 0 Reading. I do see a red light blinking inside the unit like all the time. (Has something to do with USB not plugged in I think???, but dunno for sure) I did buy the MacPac with the unit so I'm hooked up with that, I also spliced in the monitor connections using an old transformer found at a thrift store.

    Generally after I loose power to the PSU, its gone. I can't seem to get it back. Eventually it will come back on its own though. Usually after turning the Truck off and On every 15 Mins. So I'm kinda lost on this. I tried also seeing if this was an ignition cable problem by hooking up a constant wire to a switch then running the switch to ground and to the Yellow Ignition Cable. But I couldn't get that to power up the machine either.

    Any help would be appreciated!

    Thank You

  • #2
    Use the USB program to make sure that all of the settings on the 2140 are the way you think they are. Especially ones associated with shutdown.

    Also, it sounds like your 2140 is in exact opposite sync with the car. In other words, it is executing the shutdown sequence when you start your car and the startup sequence when you shut the car off.

    Try completely disconnecting the 2140 from all power for at least one minute, then plug everything back in and see if it works properly.
    Originally posted by ghettocruzer
    I was gung ho on building a PC [until] just recently. However, between my new phone having internet and GPS and all...and this kit...Im starting to have trouble justfiying it haha.
    Want to:
    -Find out about the new iBug iPad install?
    -Find out about carPC's in just 5 minutes? View the Car PC 101 video


    • #3
      I had a similar problem to what you're describing. Although in my case my system had been running without issue for over a year at the time. The P2140 has a sequence that it follows, it has a lock out that keeps the PSU on for a minute regardless of power conditions which would cause a fault during normal operation. Once that minute lock out is past if the fault condition still exists it will attempt to shut down the PC or worst case just cut output power.

      As Bugbyte mentioned hooking the P2140 to a laptop via USB and then running the PSUMoni software is very handy to see what the P2140 is doing.

      I can think of a number of things that could cause the issue you're describing. The first thing I'd check is the input voltage of the line between the battery and the P2140. You could have a short or a bad connection. I'm not sure what you mean by an "old transformer" regarding your monitor connection. That may be an issue as well.


      • #4
        Hey Guys,

        Thanks for the Replies, Well after Hours of working on it I tried updating Firmware from 1.0 to 1.44 to 1.83. Now with 1.83 I can get the Mac Mini to run just about perfectly in the truck.

        Heres the next problem.

        I have a truck that when I shut off the ignition, power still goes to the radio till I open the doors. When I open the doors everything shuts off, If I don't open the doors within 10 Minutes, It also shuts off. So Right now whats going on is I have the car running, Everything works correctly, I shut off the ignition, mac is still running, but as soon as I open the door, All Power is lost to the device. How do I get it to just go into Standby Mode? I did hook up usb cable to the device and set all jumpers to proper settings.

        As soon as I figure out this last thing I'll be able to put everything back in my truck and get her all cleaned up.

        Thanks again

        P.S. Old transformer (You know how you get some device it comes with a power brick, Well I found one with the same connection as the one with my monitor so I chopped off the brick piece so I have a longer cable and just spliced in the power from the PSU) I have no issues with the monitor and everything is working fine there.

        One other thing I tried is putting it into standby mode when the car was still running, shut the car off and opened the doors and I noticed the led on the mini went out.



        • #5
          I didn't know that Carnetix was still shipping P2140's with old firmware. That explains a lot.

          As far as your power off issue, how do you have the power wired to the P2140? It sounds like you've spliced off internal wiring that goes to the radio. There's a few ways to accomplish what you want, you just need to wire an always on power line to the P2140. The red input wires need to be connected to a line in your vehicle that always has power. The ideal way (which avoids wire fires) is a separate line connected directly to the battery. And the the yellow input wire needs to be connected to a ignition wire that behaves in the manner that you want your PC controlled.


          • #6
            The way I have the wiring hooked up right now is:

            Red = Cig Lighter Wire which I checked is always on.
            Black = Ground on Lighter
            Yellow = Checked the wiring on the radio for which one is on when the door is closed and ignition is on and hooked up that wire to it.

            I also did try direct to battery yesterday and still had problems. I'm thinking its some kinda problem with the yellow ignition wire since whenever I open the door, the psu seems to just force shutdown the mac mini, I already corrupted my windows xp because of this so I have decided to wipe the whole drive and install snow leopard. Once I get that going I'll see if it will work. I did check other wires on the radio and only 1 has power to it when the door is shut and ignition is on. So don't have alot of options on to where I can hook that yellow one up to.



            • #7
              You can take the yellow wire back to the fuse box and tap off another fuse that's ignition fed with a fuse splitter like this:


              • #8
                You need to do what Machinehead says. Find a wire in your fuse box that is ignition controlled, NOT radio connected/controlled. Then, hook the yellow wire up as he suggests, using the fuse splitter device or a fuse tap.

                A test light or a multimeter is best for checking these types of circuits out. But, anything that turns off when the ignition is off (fans, maybe) will work to signal the 2140 to turn off.

                Force shutdown should not occur even with the way it is connected through your door circuit. Sounds like one of the 2140 settings is to hard shutdown when it loses power on the yellow accessory circuit. Again, check it via the USB cable and software to watch what the 2140 is doing when there are changes to the power inputs.
                Originally posted by ghettocruzer
                I was gung ho on building a PC [until] just recently. However, between my new phone having internet and GPS and all...and this kit...Im starting to have trouble justfiying it haha.
                Want to:
                -Find out about the new iBug iPad install?
                -Find out about carPC's in just 5 minutes? View the Car PC 101 video


                • #9
                  Okay, that makes sense, I'll be busy all day tomorrow but Wednesday after work I'll give it a shot and I'll post my results.

                  Thanks again for the help.


                  • #10
                    Hello guys,

                    Heres where I'm at now, Tried all day today using a fuse tap inside my fuse box on a few different places. I checked each one and made sure they were only on when the key was on, When I turned the key off I had no power on those circuits. I hooked everything up and plugged the PSU powered the Mac Mini and my screen for 1 minute and boom, PSU shut down. And it never came back up. For the longest time I would plug and unplug and then I got a Fast LED Flash, I would turn the car back on and hold the gas pedal in a bit to raise my voltage and then the PSU would Blink solid for 3 seconds, off for 3 seconds and so forth.

                    So I thought maybe if I changed the soft jumpers on the PSU I could get it to come on, The PSU isn't recognized anymore by windows??? I'm using XP and on 3 different machines PSUmoni doesn't see a device connected. I checked Device Manager and it doesn't see anything. The PSU flashes 5 times everytime I plug it in but still nothing...

                    I did get it to work before when I flashed Version 1.8.3 on there but since that I can't get it to connect. I'm thinking to send it back... Seems like its defective or isn't built right.

                    Any Suggestions on what to try next. I do believe its a PSU issue and not electrical issue with my truck since I tried everything, I ran wires from the battery to the device and still won't kick on. Ran ignition wire to several different spots and nothing.

                    any help greatly appreciated.