Announcement

Collapse
No announcement yet.

Quick question about Opus 150w PSU.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Quick question about Opus 150w PSU.

    Does the power supply come with the +12V Power Connector for P4 Motherboards? Thanks.

  • #2
    no, you will need to buy a molex adapter

    http://www.opussolutions.com/150watt.html
    (look under Output Power Connectors)
    [H]4 Life
    My next generation Front End is right on schedule.
    It will be done sometime in the next generation.
    I'm a lesbian too.
    I am for hire!

    Comment


    • #3
      Originally posted by frodobaggins
      no, you will need to buy a molex adapter

      http://www.opussolutions.com/150watt.html
      (look under Output Power Connectors)
      Actually, it does. I bought an Opus 150W from Kris 2 weeks ago and it came with the 4 pin ATX12V connector needed by most P4 motherboards. I think Opus added the connector recently and haven't updated the info on their website.

      Comment


      • #4
        Do anyone know this for sure. I'm about to order from LinITX.com and my motherboard can't run without the +12 power connector, so it would be relly nice 2 know ....

        Comment


        • #5
          Just got mine a month ago and it has one
          __________________
          -iBase MB870 mini-ITX/P4 1.8GHz/256MB/ATI Radeon 9100 IGB onboard video
          -Alpine MRV-F450 5 Channel Amplifier
          -Lilliput 7" VGA touchscreen

          Comment


          • #6
            I think originally they didn't, but now they do. So it may depend on how old the stock from LinITX.com is.

            Comment


            • #7
              I ordered & recieved one about a year ago; model SFX-12-15 and it came with the P4 power connector.

              HTH
              System:
              Epia M1000 w/512MB PC2100, Xenarc 700TS, ATI 7500 PCI, OPUS 150 PSU, 2.5 40GB 5400 HDD, 802.11g PCI, Slim Slot DVDR,
              Gyration RF Kybrd, OBDII adpt. + sftwr, XP pro, iGuidance/Royaltek GPS NAV, XMPCR, Kenwd KAC-8401 4 chnl amp, 10" pwd sub

              Comment


              • #8
                Got mine 3 months ago and it had one.
                AMD XP 2600+/512MB RAM/120GB hard drive
                Opus 150W/DVD/GPS/7" Lilliput TS/802.11g/Bluetooth
                Installed.


                -GPSSecure- - GPS Tracking
                -AltTabber2.2.2- - Handy touchscreen utility.

                Comment


                • #9
                  And have they fixed the problem with the Standby power being left on?
                  -Jesus- King of Kings Lord of Lords

                  Comment


                  • #10
                    got mine 2 months ago it's one for an shuttle and it has it

                    Comment


                    • #11
                      Originally posted by antimatter
                      And have they fixed the problem with the Standby power being left on?
                      Not yet the 220W will be fixed... Gotta wait untill then... It does come with the P4 (4PIN) connector...
                      I'll spout simplistic opinions for hours on end.
                      Ridicule anyone who disagrees with me,
                      and generally foster divisiveness,
                      cynicism and lower level of public dialog!

                      Comment


                      • #12
                        Great, then there's no problem's in ordering one ... Gonna get my to lilly's on monday ....

                        Comment

                        Working...
                        X