Announcement

Collapse
No announcement yet.

ITPS Startup Shutdown Controller Not Working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ITPS Startup Shutdown Controller Not Working

    I bought the ITPS from MP3Car.com a couple months ago to use solely as a startup/shutdown controller cannot get that to even work properly. The problem I am having is that the ITPS will turn on my computer when ignition is applied. I tested this in the car and on the bench. I connected an oscilloscope to see PWR_ON output (connects to motherboard power jumper) of the ITPS. As you can see from the capture the turn on pulse is only 344nS which is way to short for the motherboard to detect. Has anyone else had similar problems with their ITPS?

    Ch1: Input Voltage to ITPS
    CH2: ITPS Pwr_On Output 1
    CH3: ITPS Pwr_On Output 2
    Ch4: ITPS Ignition input
    Attached Files
    My Celica Carputer Install

  • #2
    1.10.6.7 Power On Connector
    This connector can be connected to a front panel power switch. The switch must pull the
    SW_ON# pin to ground for at least 50 ms to signal the power supply to switch on or off. (The
    time requirement is due to internal debounce circuitry on the motherboard.) At least two seconds
    must pass before the power supply will recognize another on/off signal.
    My Celica Carputer Install

    Comment


    • #3
      That dont look right.

      Yup for the motherboard to turn on/off the ITPS should be pulling it to the ground. Have you tried the ITPS without the motherboard at all? to see if the ground-pulling does actually work...you may need to use a 10K pullup resistor to see this working properly.

      Nice scope you got there...what is it?

      Comment


      • #4
        Originally posted by Ricky327
        That dont look right.

        Yup for the motherboard to turn on/off the ITPS should be pulling it to the ground. Have you tried the ITPS without the motherboard at all? to see if the ground-pulling does actually work...you may need to use a 10K pullup resistor to see this working properly.

        Nice scope you got there...what is it?
        The scope capture was taken without the motherboard. It probably does need a pullup reistor if it is an open drain output.

        The scope is a LeCroy Wavepro950
        My Celica Carputer Install

        Comment


        • #5
          LeCroy Wavepro950 priced at 22,500 USD?

          Do a search on ITPS...Im sure someone did had the same problem as yours before, cant remeber who.

          Comment

          Working...
          X