Announcement

Collapse
No announcement yet.

Rage!!!! Rage!! Rage!!!

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Rage!!!! Rage!! Rage!!!

    I am really ****ed,
    My 60W Morex P.S that came with my Morex case does not work after I plugged it in to the Carnetix! I hope its just the P.S and not the MOBO. I tried pluging the computer back into to the Brick P.S and NOT WORKING!! Even though it worked perfect BEFORE I messed with the Carnetix! I don't have anyway of testing the MOBO now because I need to order a NEW MINI ITX P.S!! Anyone ever have a problem like this? That Carnetix was working just as advertised after I hooked it all up correctly..perhaps it shorted the Morex P.S? Whatever happened I am really really really really ****ed off! And may just give this crap up and use my laptop.

  • #2
    BTW:
    I have the VIA M10000.

    Comment


    • #3
      there is a surface mount fuse on that mini itx psu. it may have blown, it's worth checking. It close to the connector for the input voltage on the psu's pcb board (not the case).

      ColdPhreze
      14" LCD, EPIA MII-10000, 256MB, Wireless LAN, GPS, CDRW/DVD, ELM Scan,
      200wRMS inverter (for the screen), CarPC Pro v2.4 Power Controller,
      2 12" Pioneer Premiers, Sony 6x9s, Sony Xplode Class D mono block, Pheonix Gold A/B amp for highs

      Comment


      • #4
        How do I replace this fuse Also I cant find it..
        Thanks

        Comment


        • #5
          Uconnputer,

          Do you have your motherboard connected to the Morex when it's "not working"? What are the symptoms? When you turn on the P1260 can you measure +12V at its output? Does you mobo/CarPC show any signs of life (ie HDD spinning, fans, LEDs etc)? What else is connected to the Morex?
          MikeH

          Comment


          • #6
            Hello,
            The P1260 give off a nice 12V DC current, but the MOREX P.S will not pump it back out to anything, (I have tried plugging the MOREX in to the wall and not the P1260 and still the same results, nothing..I even disconnected it from the MOBO and tried it, NOTHING, I tried to plug in only some fans and Hard Drive...NOTHING. I Used the voltmeter to test the current, it goes IN to the MOREX but nothing comes OUT. I have already purchased another MOREX P.S, I have praying that when the first MOREX blew, it did not fry the MOBO. Honest, perhaps I hooked up the CARNETIC wrong and that is why it fried the MOREX, hopefully it will not happen again.
            Eliad

            Comment


            • #7
              When you did your testing, did you pull the Morex PSON signal to ground? It's not going to come on otherwise.
              2004 4runner

              Comment


              • #8
                Rando - Do you know which pin on the Morex is PSON? I've tried to use that same PS to power our Dashpc, but I could never get the PS to turn on.

                I've heard that the Morex PS requires a power draw before it can turn on, but I'm not sure if that is truely the case.

                Our DashPC draws ~2 Watts (at 5v), so the Morex PS can clearly power it. It's definately overkill, but I'd just as soon play it very safe with our precious prototypes.

                Your thoughts?

                Kind regards,
                CB

                Comment

                Working...
                X