Announcement

Collapse
No announcement yet.

Opus Cold Weather Resolution

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Opus Cold Weather Resolution

    Opus asks all people who have a problem with their DCX3.1209 failing in cold weather to take a picture of the power supply (if possible in best quality, from the top) and send it to tech support. [email protected]
    I'll spout simplistic opinions for hours on end.
    Ridicule anyone who disagrees with me,
    and generally foster divisiveness,
    cynicism and lower level of public dialog!

  • #2
    Dont be shy now...
    I'll spout simplistic opinions for hours on end.
    Ridicule anyone who disagrees with me,
    and generally foster divisiveness,
    cynicism and lower level of public dialog!

    Comment


    • #3
      Spoke to them. Anyone who has a cold temp. problem can send it in and it will be fixed. All you have to do is call them up or use their form (on the website) and get an RMA#.
      I'll spout simplistic opinions for hours on end.
      Ridicule anyone who disagrees with me,
      and generally foster divisiveness,
      cynicism and lower level of public dialog!

      Comment


      • #4
        Any idea on the turnaround time?
        Carputer progress meter: [-----|]
        Carputer gadget meter: [--|---]

        Comment


        • #5
          what kind of cold weather problems are people having?

          Comment


          • #6
            It's affecting the OPUS 90watt.

            http://www.mp3car.com/vbulletin/showthread.php?t=34909

            Carputer progress meter: [-----|]
            Carputer gadget meter: [--|---]

            Comment


            • #7
              flipping sweet, no more warming the car up for 15 minutes before long trips so i have the pc...

              Comment


              • #8
                Hey Grinch...got any pics of your install? I would like to see. I have a grandam 03.
                Another Novice?
                Progress so far <-------*-> 88%
                Kenwood MPV5025 with Aux
                Via MII10000
                512MB Ram
                LG Slim DVD\CDRW
                Xenarc 700TS
                M1ATX
                Pharos GPS
                SYBA USB2.0 4-port Hub
                Bufalo 54Mbs Wirelessb/g PCMCIA card

                Comment


                • #9
                  Originally posted by The Grinch
                  Any idea on the turnaround time?
                  From what they say it gos out the same day they receive it. I presume it's not a hard fix then.
                  I'll spout simplistic opinions for hours on end.
                  Ridicule anyone who disagrees with me,
                  and generally foster divisiveness,
                  cynicism and lower level of public dialog!

                  Comment


                  • #10
                    Sorry to sound like a newb...but are people with the 150W having any problems? I have a 150W but have yet to get it hooked up and running...
                    Mazdaspeed Car Computer
                    gotta redo it all

                    Comment


                    • #11
                      OK here's the answer----but only because you have a Mazda though=====Otherwise it would have been

                      The cold problem is restricted to the OPUS 90....there is no problem with the 150.




                      Originally posted by Dexter
                      Sorry to sound like a newb...but are people with the 150W having any problems? I have a 150W but have yet to get it hooked up and running...

                      Comment


                      • #12
                        has anyone sent their opus back to opus w/out the receipt or proof of purchase??

                        Comment


                        • #13
                          Sent mine last week on Tuesday. Got word today that it is fixed and was shipped back to me. I was told that the 'cold weather' mystery has been solved and I shouldn't experience anymore problems.

                          As for sending it without proof of purchase, since they are the only ones that make them...
                          99 VW GTI VR6 SC
                          -The GTI-PC-

                          Comment


                          • #14
                            I was just going by what I read on their returns page, and it says that any unit that is sent it it need to have a proof of purchase b/c the warranty is only good to the original purchaser. Just wondering if anyone had recieved any flack or was denied a repair b/c of no receipt...

                            Comment


                            • #15
                              Hmm I see. Well you have to call them first anyway to setup a RMA number/account so I guess you could ask them then.
                              99 VW GTI VR6 SC
                              -The GTI-PC-

                              Comment

                              Working...
                              X