Announcement

Collapse
No announcement yet.

M2-ATX Reliability

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • M2-ATX Reliability

    Whatsup?

    I've been reading posts and I'm starting to get the feeling that the M2-ATX do not have the best reliability.... Those who have one, what is your verdict on reliability? Or is the Opus really the way to get despite the heafty price tag? Can we kind of make a more definitive verdict here?

    I will be powering a
    MicroATX Board with Turion MT (25W)
    1GB DDR-400
    7.2k RPM Maxtor HDD
    WLan Card
    1 USB Port
    GPS Receiver
    The load won't be that large. But non the less, I don't want a fried PSU and/or Mobo after a few minutes of usage as some have claimed. Thats my real worry.

    PS. The only reason why I'm going to be going from a AC-DC inverter sol'n (which has worked flawlessly 2+ yrs) is to conserve space in the installation
    22
    Flawless. No issues to date.
    72.73%
    16
    Some Issues. Minor problems.
    13.64%
    3
    Serious. RMA'd, Burnt Mobo, etc.
    13.64%
    3
    Mark

    Website: http://www.greenpowerenthusiast.com/

    Car'Puter Project
    - Xenarc 700TSV
    - MSI RS482M-IL Mobo + AMD Turion MT-32 (25W)
    - 1x 256MB Corsair XMMS DDR400
    - M2-ATX
    - Belkin 802.11G W-Nic
    - Garmin 15H GPS
    - WinXP SP2 (NLited)

  • #2
    i been using mine for a while now and have given it a right flogging without any dramas. it powers more stuff than my home pc and never misses a beat check my sig. for hardware.

    Comment


    • #3
      Perfect for me through bench testing and install. But I have not had the opportunity to test under direct lighting strike..

      Comment


      • #4
        no probs with mine

        Comment


        • #5
          my auto amp turn on jumper doesnt work.. but other than that its fine... O and I am still upset I didnt get a P4 cable with it.. lol

          CdR
          Follow me on Twitter

          http://www.FreeICE.co.uk

          Comment


          • #6
            It made me run over a basket of kittens...


            Nope, sorry, got 4 opii
            List of front-ends/usefull apps
            XTroniC | XTroniC Direct

            Comment


            • #7
              had 2 of them neither would work but the opus did.
              Visit my site V8 Scimitar

              SP13000, 300GB SATA HD, 1GB DDR. Opus 150, K301 screen, Cisco WIFI, AQmax GPS, RoadRunner and FreeDrive, Sony MEX-R5 head unit. 4 years installed and it just keeps running!

              Comment


              • #8
                how did they not work? what problems did you have?

                Comment


                • #9
                  Mine works absolutely perfectly for my Shuttle XPC.

                  SmellyGas

                  Comment


                  • #10
                    Always remember, electronics can't break itself. Its human error that kills it. This poll will answer notting for you.

                    Comment


                    • #11
                      Thanks for the info guys. Maybe its not as bad as I first thought!

                      Gonna give it a go. 'cept I'm gonna give it a burn in test on a older board I have laying around first, lol. And your definitely right about human error kickercivic1.
                      Mark

                      Website: http://www.greenpowerenthusiast.com/

                      Car'Puter Project
                      - Xenarc 700TSV
                      - MSI RS482M-IL Mobo + AMD Turion MT-32 (25W)
                      - 1x 256MB Corsair XMMS DDR400
                      - M2-ATX
                      - Belkin 802.11G W-Nic
                      - Garmin 15H GPS
                      - WinXP SP2 (NLited)

                      Comment

                      Working...
                      X