No announcement yet.

M1-ATX power switch not working

  • Filter
  • Time
  • Show
Clear All
new posts

  • M1-ATX power switch not working

    A couple of years ago I purchased an ITPS and PW-200M to power my MII-12k motherboard in my car. It was all working fine, but then things started to act unpredictably, so I purchased an M1-ATX a few months ago. I never got it working so its been sitting in my drawer for the last 6 months, and I have persisted with the ITPS/PW-200M combo. Except now it is getting worse, with symptoms mainly being random reboots, and often only getting halfway through the boot process before power cycling again.

    Anyway, the issue with the M1-ATX is that the power switch does not seem to work with the power switch on my MII-12k. If I short out the contacts manually, it starts up and shuts down with no problems. However connected J6 or J8 on the M1-ATX to the jumpers on the motherboard does nothing, regardless of which way I connect the cable. Even when the jumper settings are set to "dumb" mode.

    Simple scenario, as set up on my desk:
    Gnd and V+ are connected.
    J6 is connected to m/b
    ATX connector is plugged in
    Hit the switch to connect V+ to SW. Nothing happens.
    If I short out J8 momentarily, motherboard turns on.

    I've also tried the cable mentioned with respect to the DSATX at

    Have I missed anything else to try?

  • #2
    And further to the shorting out the power switch pins, I have also confirmed that the MB turns on by grounding the jumper. Ie, I plugged a jumper cable onto the motherboard power switch, checked the multimeter to identify one as GND and the other as +3v. If I short the +3V to ground, the motherboard starts up.