Announcement

Collapse
No announcement yet.

Inverter Died AGAIN!!! - Help

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Inverter Died AGAIN!!! - Help

    I have a 300watt (600watt peak) XO Vision inverter in my carputer setup. I have built the Ghetto SDC shutdown controller to use along with it.

    However, today for no reason what so ever, I came back to my car and the inverter completely died. The LED light on it goes green for 1 second and then it turns red. No power spits out of the outlets.... Can anyone point me in the direction for troubleshooting this issue?

    In my Trailblazer, there is a fuseblock in the back under the rear seats. There is a +12volt terminal there which is where I got my postive line from the inverter going. After my first one died, I ran a wire straight from the battery to the inverter. I thought that fixed it, however yet again I'm stuck with no carputer (which sucks because at the moment I'm out with friends on a Saturday night)

    Any help or advice would be greatly apreciate... Thanks in advance!
    Carputer Progress
    [||||||||||] 100%
    Finally Installed!!
    Everything is in the car and working.
    I painted the cilpboard mount and it looks good.
    Shutdown/Startup is working excellent!
    View My Progress Here

  • #2
    On first look this seems like a classic overload on the inverter. Then I looked in your worklog, and assuming this is all correct, the power supply calculators say between 200W and 220W. So a 600W inverter should be ok for 300W continuous out.

    My guess would be you are buying the crapiest of the crappiest inverters that are not meant for continuous use. Also heat may be a concern. I didn't look all the way through your worklog so I don't know where you put your inverter but it might be overheating and dieing.
    Fusion Brain Version 6 Released!
    1.9in x 2.9in -- 47mm x 73mm
    30 Digital Outputs -- Directly drive a relay
    15 Analogue Inputs -- Read sensors like temperature, light, distance, acceleration, and more
    Buy now in the MP3Car.com Store

    Comment


    • #3
      Thanks for the reply, I really apreciate it.

      As far as I know, I wouldnt think over-heating would be an issue because it never gets hot. I've driven for hours and nothing on the inverter seems even warm, let alone hot.... But I will admit its not in the best of places.... Its under the back seat in a type of compartment. Its not completely closed off, but theres no airflow.

      The brand of the inverter is XO Vision. I'm not sure if it is a name brand or not, but I do know it wasnt the most expensive one that I could have bought. I got mine from Frys and I do think it was the cheapest....

      But, even so, I wouldnt think that they would last for a few months and die? That just dont make any sense....
      Carputer Progress
      [||||||||||] 100%
      Finally Installed!!
      Everything is in the car and working.
      I painted the cilpboard mount and it looks good.
      Shutdown/Startup is working excellent!
      View My Progress Here

      Comment

      Working...
      X