No announcement yet.

P1900 intermittenly can't charge netbook battery

  • Filter
  • Time
  • Show
Clear All
new posts

  • P1900 intermittenly can't charge netbook battery

    I recently switched to a P1900 to power my Acer Aspire One netbook and USB hub. 1 out of every 10-15 times I start the car, the netbook battery won't charge (charge light flashes red). Usually I can just unplug the power cable going to the netbook a time or two and it'll start charging.

    Here's the setup:

    Battery -> Power Block ->
    1) 800w amp
    2) DC-DC USB -> 12v to 7" Lilliput screen and Linksys WRT54G
    3) P1900 -> 19v/30w to netbook, 5v/2A to USB hub

    Previously, I had the DC-DC USB powering the netbook and Linksys and screen on the ACC wire my radio was on. It worked fine every time, but I wanted to power the hub and move the screen to regulated power so I added the P1900. Since the 1900 is rated at 140W, even with the hub drawing it's max it still should be overkill, but I get these occasional problems. Using the AC adapter for the netbook works every time, and it worked on the DCDC so I'm pretty sure it's not a problem with it.

    I just wanted to check and see if anyone had seen this before I contacted Carnetix about it.