Announcement

Collapse
No announcement yet.

P1900 output issue (there is not power out)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • P1900 output issue (there is not power out)

    Hi all,

    It's been a while. I've enjoyed the P1900 since 2009, but mine recently died so I purchased a new one from mp3Car.

    I've set the dern thing up as I did before minus the 5v regulator add-on because I no longer use it. In spite of this, the power regulator does not function properly. I've checked the input voltages and they appear correct. The only response I get is a short series of flashes from the P1900. Before and after the flashes, the light is off.

    Any ideas?
    Sound System () 100%
    Power System () 100%
    MacMini Setup () 100%

  • #2
    There is an internal blade fuse on that supply, maybe check that, I've had mine blow once. Also I think the light sequence you see happening can be cross referenced to a diagnostics chart in the installation manual IIRC.
    My 2007 Ford F350 Work Log located HERE

    Comment


    • #3
      Hmm. The fuse is still intact. I had an old one blow on my first P1900.

      What diagnostic chart? And what IIRC manual?
      Sound System () 100%
      Power System () 100%
      MacMini Setup () 100%

      Comment


      • #4
        page 40 of the installation manual here: http://www.carnetix.com/installation...ManualV2_1.pdf

        IIRC= if I remember correctly
        My 2007 Ford F350 Work Log located HERE

        Comment


        • #5
          IIRC...got it.

          There is no flash sequence that corresponds to what mine is doing. I'll take a video this weekend and post that for help in the diagnosis.
          Sound System () 100%
          Power System () 100%
          MacMini Setup () 100%

          Comment

          Working...
          X