Announcement

Collapse
No announcement yet.

M2-ATX works on test bench but not in car (voltage drop caused by M2-ATX)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • M2-ATX works on test bench but not in car (voltage drop caused by M2-ATX)

    I have a very strange problem, when I am using my M2-ATX connected to the 12V rail on my normal PSU it works, but if I connect it to my car it doesn't work at all.
    I have tested with a multi meter and before I connect the M2-ATX it is at 12.4V but as soon as I connect the M2-ATX it drops to about 2.6V!

    An amp and sub are also connected which work perfectly when the M2-ATX isn't connected, I've also tried it with only the M2-ATX connect and still drops the voltage.
    A 4 gauge wire goes into a distribution block with 8 gauge wires going to the pc, amp and sub, it has been like this for about a year with no issues when last week it just stopped working.

    Thanks!

  • #2
    Are you testing the voltage on the 12v input terminals on the m2-atx or at output side? If your getting 12v+ on the input cables and then it drops to 2.6v when you connect it. It may strongly suggest you have a problem with your power source not the m2-atx psu.

    Comment


    • #3
      I have tried testing it on both the input terminals and the power distribution block, I didn't think it is was problem with the battery because my amp and sub work perfectlybut could it be the battery?
      I will try testing the battery terminals tomorrow.

      Comment


      • #4
        Depending on the size of your amp. Your carpc shouldnt draw much power or more power than your amp. Try running power cable directly from pc straight to battery so that you bypass the distribution block. If your car still starts easy enough then it wont be a battery problem. If the pc works after connecting straight to battery then i would be looking at the distribution block as the source of the problem.

        Comment


        • #5
          I have exactly the same problem! Replaced the m2 with a dc-dc psu thinking it was the m2 but problem still there!
          Did you resolve this by any chance?

          Comment


          • #6
            Hi djivesp I did fix it, all I did was leave the m2atx dissconnected for a week then I reconnected it and it suddendly started working! I don't know why that fixed it, maybe the battery needed a rest? or someother reason but it has been working flawlessly since.

            Comment

            Working...
            X