No announcement yet.

New M4-ATX worked once....

  • Filter
  • Time
  • Show
Clear All
new posts

  • New M4-ATX worked once....

    I received a new M4-ATX.
    I connected to the M4-ATX to my computer and to 12 V battery. Everything worked fine.
    Tried again and no power.

    Green led flashes twice about each 10 seconds.
    All dip switches are OFF
    No voltage coming to ATX output

    Why does it not work?

  • #2
    Couple things you can do, and a little more info doesn't hurt either...

    Can you bench test it, without it being in the car. Does the pc work with a normal desktop psu?

    Are you sure all dip switches should be off? If I remember right, one was up on mine to initiate the startup/shutdown pulse, again, if I remember right...

    If you have a spare desktop psu, you can also jump that psu to turn on without being hooked up, hook up the M4 into the correct molex pins to test. If you want info for this let me know, I'll let ya how I did.
    Current Worklog: TBA - '05 Rav4 (Mobo Dead). - Forums for Rav4 owners - Cooking website/forums
    -Basic forums live atm, come contribute!


    • #3
      Yes, this is a bench test. The pc works with a different power supply.
      About the dip switches, the manual says:

      P0: In this mode, the M4-ATX-HV behaves like a regular ATX power supply. If J6 is
      connected to the motherboard, M4-ATX-HV will also send a gratuitous “ON pulse”
      to the motherboard right after power is first applied.

      P1 (recommended): Sends ON pulse to motherboard when ignition is ON for more
      than 5 seconds, sends OFF pulse to motherboard 5 seconds after ignition is turned
      off. Waits another 60 seconds and then shuts down 5VSB to conserve battery. In
      this mode, the M4-ATX-HV consumes less than 0.5mA. This is our
      recommended setting.

      I want P0 mode so that the power supply operates without the ignition signal. I am sure all dip switches should be off for this. And, as I said, it was working before with these settings.

      As for testing a spare psu test. I am measuring voltage of the M4-ATX with a volt meter and zero volts are measured from all ATX outputs. There is no power coming from the M4-ATX.


      • #4
        Sorry didn't see this reply earlier, I messed with email filters, and it didn't work apparently lol.

        How are you powering the m4 from the bench? Is it from a ac->dc unit, or are you jumping from a desktop psu?
        Current Worklog: TBA - '05 Rav4 (Mobo Dead). - Forums for Rav4 owners - Cooking website/forums
        -Basic forums live atm, come contribute!


        • #5
          The M4 is powered by a 12V SLA battery.


          • #6
            Hi, had same problem with new m4-atx. Soon after testing and checking i realised had blown the on-board fuse on the atx. Got a tiny metal alligator clip and bridged both sides of fused and it worked. Still works to this day. I must have shorted the power cables by connecting postive terminal to negative pin on atx. Not saying that you did same thing may have just been faulty in the first place. The fuse is tiny and soldered onto board located roughly near the 12v input terminals. Good luck


            • #7
              Re fuse. Thanks but the fuse is good. I am going to return this crap and get a decent power supply.