No announcement yet.

M4-ATX issues resolved!

  • Filter
  • Time
  • Show
Clear All
new posts

  • M4-ATX issues resolved!

    I have been having ongoing problems using an M4-ATX with a particular motherboard.

    Swicth on has been random, sometimes it would work fine, other times it'd start to power up then switch off again.

    Lots of head scratching and setting changing ensued; I tried a couple of different M4-ATX's and a couple of motherboards, still no success.

    I then tried a brand new motherboard, identical to the previous ones BUT with an updated UEFI. It fixed all the problems!

    The old UEFI was Phoenix Securecore Tiano version 2.1 and this was flaky; version 2.2 works fine.

    I'd suggest anyone experiencing issues check to see if Phoenix UEFI 2.1 is installed (The version number is displayed on the Phoenix splash screen). It'd also be worth updating the motherboard BIOS if a later version is available.

    I can't say whether this will fix anyone else's problems but it worked in this case.

  • #2
    Didn't work for me, these power supplies still have way to many issues, and tech support won't reply no matter what. Avoid at all costs.