No announcement yet.

Unknown USB device (device descriptor request failed)

  • Filter
  • Time
  • Show
Clear All
new posts

  • Unknown USB device (device descriptor request failed)


    I'm getting to the end of my tether now. I've tried endlessly to coax this board into working over USB and it just refuses.

    At first it wouldn't work because D+ and D- were around the wrong way, now I've solved that issue, I just endlessly get "Device Descriptor Failure" under device manager. I've tried to install multiple drivers (all outdated) and nothing gets the M4-ATX to work.

    Is it broken?

    I really need some help here. Mini-box don't reply with conclusive information and this is the only forum any one seems to have talked about the M4-ATX on.

    I'm using Windows 8.1 with an ASUS Maximus VI Impact motherboard.


  • #2
    short answer..find another cable and another computer and test there...if it still has problems...its cooked and i feel for you....i hate cooked parts as ive baked a few myself.


    • #3
      ohh win 8 i see too....find a mates computer with win xp-7 and could be a win 8 thing if you lucky


      • #4
        Originally posted by camo.b View Post
        ohh win 8 i see too....find a mates computer with win xp-7 and could be a win 8 thing if you lucky
        Mmm I'll have to try the Windows 7 PC in the other room.

        Do you reckon the D+ and D- being the wrong way around could've done it if it is broken?

        Thanks so much for the reply, you're literally the only person I've had any response from anywhere yet.


        • #5
          Forums are quiet these days...ive hooked the d+/- around the wrong way before but had no its not power just data (i could be wrong) i would have thought it would be fine..if the pos + and earth were reversed that could cause problems


          • #6
            How did you go with the psu is it still o.k?


            • #7
              I haven't got any further yet, I found a broken joint on the custom cable I made. I've ordered a proper USB cable to see if it solves the problem (although the connections seemed fine before). Should be here around Friday.

              Mini-box did reply, mentioned the dip switches, that is no issue for me. They also suggested trying it with the PC off. I will do that when I get my USB cable ^^

              Stay tuned XD


              • #8

                I am experiencing the same problem with my 64bit Windows 8.1, it just recognize the device.

                If anyone hears of a solution, I would love to know about it.

                I have emailed Mini-Box. But I doubt I will get a response on this.


                • #9
                  Sorry for the uber late reply again.

                  Hurrah! Someone else who is actually using an M4-ATX on 8.1.

                  I've been doing a /lot/ of experimentation with drivers and trying to seek out solutions and I haven't got it working yet, but I feel that I'm slowly edging closer to a solution.

                  I'm trying to get in contact with the creator of the M4 API for Linux to see if they can help out, I've sent another e-mail to Mini Box and I now have a working USB cable. I've been messing about with standard drivers from Microchip to see if I can botch them to work, and am getting closer to success there.

                  The issue is basically either the driver or the PIC. The PIC is ancient and no one really uses the damned thing anymore, and I'm beginning to wonder if it can't be supported by Windows at a hardware level, which would suck. However, if it's driver, I may be able to fix it myself and post the solution here or get someone else to help me do it.

                  I now have "USB Input Device" in Windows, which is where Windows just decides to install the wrong driver for the device and refuses to do anything else. You can install the "Virtual Com Port" driver by downloading the Microchip libraries and choosing the "add legacy hardware" option in device manager and scrolling down to "COM/LPT", then choosing the Microchip driver. However, as you'll see, regardless of if you change the COM port, it still doesn't want to work.

                  Something I haven't tried yet is changing the baud rate, which I doubt will make a difference, but I have a suspicion the absence of a supported PID for my M4 ATX in the driver may be the issue. I have a VID of "04D8" or similar, which can be found in the driver under the device list, but the PID is "D001" which is /not/ in the device list. When I tried to manually add it, it didn't work, but I will try again once I have time.


                  • #10
                    Any update Razye?