No announcement yet.

Blu Ray problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • Blu Ray problems

    Ok, I decided to upgrade the RV-PC to a new MB. I added a Zotac NM10-B-E-ION MB with an M4-ATX power supply, an LG Blu-Ray player combo DVD burner and a 120gb SSD. I still am using the 17" Viewsonic LCD (4:3) that fits the dash properly. And here lies the problem. It seems to play a Blu-ray movie, you HAVE to have a digital monitor! VGA or even RCA will not work.

    I just spent most of the afternoon searching the internet, including Ebay and every manufacturers website I could find looking for a flip down monitor with either a DVI or HDMI input. I found only a couple with VGA connections but EVERY other one out there has RCA inputs that I could find. I would not mind using the HDMI output to go to a flip down if I could find one. Eonon has a 19" with a VGA but that was all I could find.

    Before I pull out the drive and put a DVD one back in the dash, anyone have any suggestions?

  • #2
    VGA will do 1920x1080 no problem as long as the monitor supports it. Have you tried using VGA? Some mainboards support digital over vga, but thats only good if you need to convert vga to hdmi. That's all I got SNO


    • #3
      VGA would display it, but it is not HDCP compliant for Blu-Ray. I have a monitor hooked up as VGA right now and I can do everything except play Blu-Ray movies. I get an error message regarding copy protection and HDCP. I need at least a DVI connector and preferably HDMI to play Blu-Ray movies. What surprises me is that there are no 12volt monitors for vehicle use that have a DVI or HDMI input. I have looked all over the place for a flip down monitor with an HDMI and they don't exist. I have written jensen, Pyle, Eonon and several others with all having negative (or no) responses on HDMI.


      • #4
        You could always use an adapter for your monitor from HDMI to VGA... There are MANY available for under $50..


        • #5
          I tried the adapter, but the software can still tell it is not HDCP and refuses to play. I was able to get AnyDVD HD to work, but that took over 3 minutes to load the Blu-Ray disc!