Announcement

Collapse
No announcement yet.

Hardware Review: Turtle Beach Roadie

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hardware Review: Turtle Beach Roadie

    I hated my SoundBlaster Live! USB soundcard, and decided to give the Audio Advantage Turtle Beach Roadie USB. Link
    I couldn't find a true review of it anywhere on here (pertaining specifically to CarPC use) so I figured I'd document my thoughts so far. For non-CarPC reviews check this out.

    First, my system specs are in my sig for reference.

    I am by no means an SQ competitor, but I am picky about my sound. I have high quality components and know what they should sound like. I also don't want/need surround sound. I want 4 speaker quadraphonic sound, like a standard deck outputs. So, take this review with that grain of salt.

    What it is/does: USB External Soundcard

    Reviewed by: PootsworthIII
    Manufacturer : Audio Advantage
    Model: Roadie USB
    Specs: 5.1 or 7.1 Output, Analog and Digital Outputs, Built-in Stereo Microphones, 10 Band EQ, Ambience Effects, Optical Digital Adapters
    Price: $79
    Rating: 8/10
    Manufacturer website: http://www.turtlebeach.com/site/prod...dioadv/roadie/
    Purchased at: CompUSA

    Pros:

    -Hibernates with no problems

    -There is no discernable "pop" when the computer finally engages the soundcard. (SoundBlaster’s was terrible)

    -The sound quality seems a lot more powerful than the SoundBlaster. I needed alot less gain on my amps with the unit at full volume to acheive the power I was looking for. And less gain is a good thing.

    - The Roadie, when in 4 speaker mode sends equal signal to all four speakers. There is no simulated surround sound. It seems to do less processing of the signal. I had a problem where the SoundBlaster made it's rear output muddy and clipped in the low range. This does not exist in the Roadie. You get 4 channels of the same signal and volume.

    -The size is significantly smaller than the SoundBlaster.

    -The control panel has, for the most part, all of the options contained in one application. The SoundBlaster had multiple application windows that would pop up.

    -"Per Speaker" equalizer and volume. I have the rear channel feeding my subwoofer, so this means I can change the EQ and volume of my sub indepenent of my front speakers.

    Cons:

    -The unit seems to be USB bandwidth hungry. I had random popping and clicking, like rice krispies in my music. After some reading, I figured out it was because the unit was starved for bandwidth. I added a PCI USB card and dedicated it the Roadie, problem solved. (Note: I switched motherboards at the same time I switched soundcards. The new motherboard could have USB bus management issues. )

    -Some of the sliders within the application are too small to change by hand using the touchscreen.

    -The sliders in "per speaker" EQ screen do not lock to each other for front and rear. I'm not sure of any application when you would want your front/left to have a different EQ than you front/right, so they should be able to be locked together. It's tedious to match them up manually.


    Overall, I would highly recommend the Roadie over the SoundBlaster Live! I have never tried a PCI soundcard b/c of space uses, nor have I used the Audigy, but you can read the woes people have had with that by searching.

    Hope this helps someone.
    in progress

  • #2
    No quadraphonic joy for me

    - The Roadie, when in 4 speaker mode sends equal signal to all four speakers.
    Actually, I'm not seeing this. In 4 speaker mode, the rear speakers have no bass, just the fronts. In 5.1 and 7.1 modes, no speakers have bass, except the sub channel. The speaker equalizer makes it look like you can control this crossover for each speaker, but boosting the bass on the rear channels has no effect. This may be OK for a car environment, but I would prefer getting full frequency response from each speaker.

    Also, WAV's (windows sounds) and synthesized voice play on the front channels only. This might be a nice feature, actually, but it would be nice to have control.

    Also, WinAmp 2.9.5 (the recommended one for RR) only plays music out the front channels, when in 4 speaker mode. Windows Media Player, iTunes, and the latest version of WinAmp make use of all 4 channels, but without bass to the rear.

    This is in contrast to my ALC650 AC97 onboard sound which does play full range out of each speaker. However, the onboard sound system has weak mic inbput. A powered mic would be needed. And this leads me to the reason why I'm still keeping the roadie... it has a +20db booster for the mic input, and passive mics work great.

    I'm also keeping it for the S/PDIF input for use with the Sirius tuner.

    Note the Roadie doesn't come with any kind of AC3 encoding software, so the S/PDIF output is only 2-channel.
    My setup: Hummer H3, iBase MB899, Intel Core Duo, RR, iGv3, DSATX, Mechatroniks chassis, 41Hz AMP3

    Comment


    • #3
      That's really strange b/c I have the rear channels hooked up to my sub only. I only run front components and a sub. The sub gets plenty of bass signal. I'll hafta check my settings and get back to you.
      in progress

      Comment


      • #4
        No love from optical in

        Just got my Sirius ALP1. Come to find out that the optical input of the Roadie can't be used with it. There does't seem to be a way to route the optical in to the analog outs. I was able to record from the optical in and playback, but not pass through in real time. There does seem to be a way to connect the optical in to the optical out, but I don't know if that's strictly it or if it lets you mix in playback from mp3's, voice synthesis, etc. I'm curious, but it would be a huge pain for me to test.
        My setup: Hummer H3, iBase MB899, Intel Core Duo, RR, iGv3, DSATX, Mechatroniks chassis, 41Hz AMP3

        Comment


        • #5
          Originally posted by jeffw View Post
          I'm curious, but it would be a huge pain for me to test.
          OK, I just tested it. The S/PDIF out selection in the Turtle Beach control panel has 4 choices: Off, 44.1 KHz, 48 KHz, and "In to Out". Setting "In to Out" does allow Sirius music to come in to the computer and out through the S/PDIF, but other sounds generated from the computer don't get mixed in. You can hear mp3's, and synthesized voice by setting it to 44.1 KHz. So the only way to make it usable would be for your front end to some how make this change to the device when you switch between music and radio... and also every time navigation needs to make an anouncement.
          My setup: Hummer H3, iBase MB899, Intel Core Duo, RR, iGv3, DSATX, Mechatroniks chassis, 41Hz AMP3

          Comment


          • #6
            I can't seem to get equal sound out of all four speakers either. no bass to rears
            [HL]Warning - NSFW [/HL]

            Comment


            • #7
              Weak Bass

              Originally posted by akwash79 View Post
              I can't seem to get equal sound out of all four speakers either. no bass to rears
              Same here. I get very little bass from the rear or front while in 5.1. The 4 speaker set up is better, but then I get no sub output.

              Anyone have advice on settings?
              2007 Mustang - RockCar Front End

              Comment


              • #8
                i found this card wouldn't do stereo fill in vista ... so everything played up front only. two back speakers only got used with 5.1 source or test modes.

                do yourself a favor and unsolder the mics from the board. the default is to have them on and inside the car you end up with MAJOR feedback loop at any moments notice. I think I've blown all 5 of my speakers because it progressively got louder and louder with the most horrible sound (with jiggawatts of juice behind them). Unsoldered them and now its never a problem. The driver seemed to turn the mic on automatically sometimes even if you had it off previously. . .

                Comment


                • #9
                  Mic

                  Originally posted by changeip View Post
                  The driver seemed to turn the mic on automatically sometimes even if you had it off previously. . .
                  That's unsettling that it might pop back on. I know when I first turned on the car after installing the speakers there was a loud siren like sound that was attributable to feedback from the mic. I muted the line-in and mic and that solved it. Hope it didn't damage the speakers.

                  Make sure these are off and the volume is down low before using your speakers the first time.
                  2007 Mustang - RockCar Front End

                  Comment


                  • #10
                    mic problem

                    I seem to have the same problem. But i followed your advice and now everything seems to be fine! Thx!

                    Comment


                    • #11
                      trust me, at some time in the future the mic mute will be turned off and your ears will bleed (if you have a LOUD system).

                      Comment


                      • #12
                        Originally posted by PootsworthIII View Post
                        Cons:

                        -The unit seems to be USB bandwidth hungry. I had random popping and clicking, like rice krispies in my music. After some reading, I figured out it was because the unit was starved for bandwidth. I added a PCI USB card and dedicated it the Roadie, problem solved. (Note: I switched motherboards at the same time I switched soundcards. The new motherboard could have USB bus management issues. )

                        hey PootsworthIII,

                        I'm having the same issue. I emailed turtle beach and they claim this wouldn't fix the issue. My sound is playing fine, but i have video latency issues obviously when the sound card is working. I'm almost 100% it is the sound card creating this, since on my old sould card I had no issues with video. You think taking the route of adding anothe cardbus will solve my problem.
                        http://www.mp3car.com/vbulletin/show...06-vw-gti.html

                        Snowperformance.net
                        vwvortex.com

                        Comment


                        • #13
                          I had bass working fine for a couple hours and then opened up the equalizer and now it's gone. 2 channel mode and 4 channel. Does anyone know if an E46 is powering the sub off front or rear channels?
                          My BMW E46 carpc
                          My iGuidance 4 skin
                          FS transflective 2008 lilliput

                          Comment


                          • #14
                            Originally posted by kelmk View Post
                            I had bass working fine for a couple hours and then opened up the equalizer and now it's gone. 2 channel mode and 4 channel. Does anyone know if an E46 is powering the sub off front or rear channels?
                            I have the issue on occasion, a reboot or a hibernate cycle seems to fix it.

                            Comment


                            • #15
                              Did anyone ever figure this out? I have 4.1 channel sound when playing music through freeice or wmp but anything else is front channel only. I can turn on surround mode and get some sound to the rear speakers but none of the surround modes are any good. There is no simple copy front to rear mode, only padded cell, concert hall, sewer pipe, etc garbage. Why would I want to pretend I was in a sewer pipe?

                              Originally posted by jeffw View Post
                              Actually, I'm not seeing this. In 4 speaker mode, the rear speakers have no bass, just the fronts. In 5.1 and 7.1 modes, no speakers have bass, except the sub channel. The speaker equalizer makes it look like you can control this crossover for each speaker, but boosting the bass on the rear channels has no effect. This may be OK for a car environment, but I would prefer getting full frequency response from each speaker.

                              Also, WAV's (windows sounds) and synthesized voice play on the front channels only. This might be a nice feature, actually, but it would be nice to have control.

                              Also, WinAmp 2.9.5 (the recommended one for RR) only plays music out the front channels, when in 4 speaker mode. Windows Media Player, iTunes, and the latest version of WinAmp make use of all 4 channels, but without bass to the rear.

                              This is in contrast to my ALC650 AC97 onboard sound which does play full range out of each speaker. However, the onboard sound system has weak mic inbput. A powered mic would be needed. And this leads me to the reason why I'm still keeping the roadie... it has a +20db booster for the mic input, and passive mics work great.

                              I'm also keeping it for the S/PDIF input for use with the Sirius tuner.

                              Note the Roadie doesn't come with any kind of AC3 encoding software, so the S/PDIF output is only 2-channel.
                              My BMW E46 carpc
                              My iGuidance 4 skin
                              FS transflective 2008 lilliput

                              Comment

                              Working...
                              X