Announcement

Collapse
No announcement yet.

HOWTO: Use gmail IMAP with Centrafuse

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • HOWTO: Use gmail IMAP with Centrafuse

    I've noticed a number of people having problems with using gmail in centrafuse. Well, I'm using it directly in the centrafuse email client. There are a few easy steps to getting up and running.

    1. enable IMAP in your gmail account. It's under 'settings'.
    2. Use the following settings in the centrafuse email client

    Email Name: Your Name
    Email address: [email protected]
    User name: [email protected]
    password: yourpasswordhere
    incoming server: imap.gmail.com
    outgoing server: smtp.gmail.com
    incoming port: 993
    outgoing port: 587
    server type: imap
    imap folder: Inbox
    incoming security: TLS/SSL Implicit
    outgoing security: TLS/SSL Explicit

    save your settings, and check your email! If it does not work, try restarting centrafuse and checking the incoming port setting again. For some reason, CF changed my incoming port the first time I did this and I needed to type it in and save it again.
    My car PC page, with pictures

  • #2
    just to add using gmail smtp sever wont be very universal many ISP's block smtp traffic to everything bar their own servers. For example if your connected to the net via Vodafone in the uk the gmail wont work you will have to use the Vodafone server.
    Visit my site V8 Scimitar

    SP13000, 300GB SATA HD, 1GB DDR. Opus 150, K301 screen, Cisco WIFI, AQmax GPS, RoadRunner and FreeDrive, Sony MEX-R5 head unit. 4 years installed and it just keeps running!

    Comment


    • #3
      of course, I cannot account for every ISP. This is how it works if your isp is nice
      My car PC page, with pictures

      Comment


      • #4
        Originally posted by coffeejolts View Post
        If it does not work, try restarting centrafuse and checking the incoming port setting again. For some reason, CF changed my incoming port the first time I did this and I needed to type it in and save it again.
        This is 'cause CF will force the default port numbers when you set the server type. So if you set the port numbers, then change the server type, your manual settings will be wiped.
        :: Mark

        Comment


        • #5
          Originally posted by midiwall View Post
          This is 'cause CF will force the default port numbers when you set the server type. So if you set the port numbers, then change the server type, your manual settings will be wiped.
          IMO- this is a bug. If you make all the changes at once, CF should accept all the changes. Or, it should change the port numbers in the GUI instantly, to reflect the fact that this is happening. Or, display some sort of message box. As it is, users are given no indication that the port numbers they specified have been reset to a default, unless they go back and recheck the settings.
          My car PC page, with pictures

          Comment


          • #6
            Originally posted by coffeejolts View Post
            IMO- this is a bug. If you make all the changes at once, CF should accept all the changes. Or, it should change the port numbers in the GUI instantly, to reflect the fact that this is happening. Or, display some sort of message box. As it is, users are given no indication that the port numbers they specified have been reset to a default, unless they go back and recheck the settings.
            Yeup. Agreed.
            :: Mark

            Comment


            • #7
              there are security settings on the last pages of Email settings that need to be set for gmail to work...

              incoming security and outgoing security...

              I think gmail works with explicit, but just try both... one does work, gmail was tested...

              david
              __________________
              CENTRAFUSE http://www.centrafuse.com
              01 Jeep Cherokee Sport 4x4 Installed
              M10000/512Mb/20GB, Lilliput 7", Holux GM-210

              Comment


              • #8
                Originally posted by veetid View Post
                there are security settings on the last pages of Email settings that need to be set for gmail to work...

                incoming security and outgoing security...
                You're a little late to the party David, but we're glad to see ya' back.

                The trick with GMail is Incoming is IMPLICIT, Outgoing is EXPLICIT. Beyond that, we're saying that CF resetting the port numbers after them being manually adjusted is a bug.
                :: Mark

                Comment


                • #9
                  manually resetting the port numbers? these should only be reset if you switch POP/IMAP setting...

                  david
                  __________________
                  CENTRAFUSE http://www.centrafuse.com
                  01 Jeep Cherokee Sport 4x4 Installed
                  M10000/512Mb/20GB, Lilliput 7", Holux GM-210

                  Comment


                  • #10
                    Originally posted by veetid View Post
                    manually resetting the port numbers? these should only be reset if you switch POP/IMAP setting...
                    Umm... Lemme do it this way:
                    • Intent is to set Email app for Gmail and IMAP
                    • Start with Settings / Email
                    • Working through the dialog top down, you set port numbers (as required for GMail)
                    • Set IMAP
                    • Email has overriden your manually entered port numbers with the defaults for IMAP which don't work for GMail
                    • User hits SAVE, leaving Email in a state that doesn't work
                    A couple of ideas on making this more user friendly:
                    1. Change order of the POP/IMAP selection so that it comes before port number
                    2. Plugin should be aware of a manual override of port numbers and not reset them
                    :: Mark

                    Comment


                    • #11
                      good point, I will look into it...

                      I reset the ports thinking that if you switch POP/IMAP, then they should start at the defaults for each protocol...

                      I think moving ahead in the list is a good idea...

                      david
                      __________________
                      CENTRAFUSE http://www.centrafuse.com
                      01 Jeep Cherokee Sport 4x4 Installed
                      M10000/512Mb/20GB, Lilliput 7", Holux GM-210

                      Comment


                      • #12
                        Originally posted by veetid View Post
                        I reset the ports thinking that if you switch POP/IMAP, then they should start at the defaults for each protocol...
                        Oh yeah, I totally agree... it's the right idea, just needs a small tweak.

                        Thanks David!
                        :: Mark

                        Comment


                        • #13
                          My GMail just hangs on "Receiving 1/7002". It looks like its connecting, but it won't receive the messages. Anyone else having this problem? Sending emails work fine.

                          Comment


                          • #14
                            Originally posted by hehaha View Post
                            My GMail just hangs on "Receiving 1/7002". It looks like its connecting, but it won't receive the messages. Anyone else having this problem? Sending emails work fine.
                            Are you set for IMAP or POP3? How many emails are actually in the inbox?
                            :: Mark

                            Comment


                            • #15
                              I had the exact same problem.
                              I bet you forgot to do this step:

                              1. enable IMAP in your gmail account. It's under 'settings'.

                              This solves it.

                              Comment

                              Working...
                              X