No announcement yet.


  • Filter
  • Time
  • Show
Clear All
new posts

  • CF and EEEPC

    Hi All,

    this is more of an information post than anything, to help out anyone else with an eeepc or anyone who has expirenced this issue with other machines

    I installed the trial of CF to try it out on my eeepc, and to use in the car, to help me decide if i want to do a full carpc installation.

    As i allready have a good head unit with an ipod interface, and a 30gb ipod, I was mostly interested in the Video, Nav and Reverse cam functions of CF

    Both the video and cam fuctions worked with no issue, but I could not get the GPS to work at all.

    I have a GlobalSat BT359 Bluetooth GPS (Brilliant GPS btw) a bluetooth dongle and the EEE PC

    No matter what i did, when I went to set up the navigation, no com ports would appear to choose for the GPS (even though the GPS was set to use the BT COM3)

    I then tried CF on my desktop PC (which has a BT dongle, and real serial ports) and discovered that if is no COM1 port, CF dosent detect any other COM ports, BT or otherwise.

    So at first, I tried to just reset the BT COM port for the GPS from COM3 to COM1 on the EEE PC

    This made me able to select the COM port in CF, but it would not actually connect to the GPS or read any data from it. (and also caused all sorts of issues with the BT setup and with CF itself)

    Alot of installs and reinstalls later, I worked out that if i set the GPS as its normal COM3 and then manualy went in and edited the CF configuration file it would work and read data from the GPS

    Here is how you do it.

    2. Navigate to C:\Program Files\Flux Media\Centrafuse\System

    (or wherever you installed CF to)

    3. Open the config.xml file in notepad (or your editor of choice)
    to do this, right click > open with and choose notepad

    4. Find the following line in the XML file


    5. Set the GPSCOMPORT value to whatever COM port your GPS uses (ie. 3 for COM3)

    6. Save the file and exit notepad.

    Open CF and check the navigation settings page, it should now be set to COM3.

    DO NOT click the COM3 to change it, this will cause a runtime error, and you to possibly lose your setting.

    Sorry for the massive first post, but hopefully this helps someone out, and maybe helps the CF dev. team to fix this bug...

  • #2
    so no COM1, the list does not populate with other COM ports?

    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210


    • #3
      Yep, if there is not COM1 port, the list does not populate at all.. It just says None and you cannot select anything

      and if the bluetooth device is set as COM1, CF will not read any data from it.