Announcement

Collapse
No announcement yet.

Bugs so far in 1.3 BETA

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Bugs so far in 1.3 BETA

    Bugs so far in 1.3 BETA

    ok i found 2 bugs so far

    1. pressed system info a loading screen came but centrafuse just froze had to exit via the task manager
    2. press the 'eye' twice and you get this error [image attached]

    Code:
    See the end of this message for details on invoking 
    just-in-time (JIT) debugging instead of this dialog box.
    
    ************** Exception Text **************
    System.NullReferenceException: Object reference not set to an instance of an object.
       at centrafuse.main.systemCommands(Int32 command)
       at centrafuse.main.visBtn_Click()
       at centrafuse.main.main_MouseUp(Object sender, MouseEventArgs e)
       at System.Windows.Forms.Control.OnMouseUp(MouseEventArgs e)
       at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
       at System.Windows.Forms.Control.WndProc(Message& m)
       at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
       at System.Windows.Forms.ContainerControl.WndProc(Message& m)
       at System.Windows.Forms.Form.WndProc(Message& m)
       at centrafuse.main.WndProc(Message& m)
       at System.Windows.Forms.ControlNativeWindow.OnMessage(Message& m)
       at System.Windows.Forms.ControlNativeWindow.WndProc(Message& m)
       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
    
    
    ************** Loaded Assemblies **************
    mscorlib
        Assembly Version: 1.0.5000.0
        Win32 Version: 1.1.4322.573
        CodeBase: file:///c:/windows/microsoft.net/framework/v1.1.4322/mscorlib.dll
    ----------------------------------------
    centrafuse
        Assembly Version: 1.3.2021.30940
        Win32 Version: 00001.00003.02021.30940
        CodeBase: file:///C:/Program%20Files/Flux%20Media/Centrafuse/centrafuse.exe
    ----------------------------------------
    System.Windows.Forms
        Assembly Version: 1.0.5000.0
        Win32 Version: 1.1.4322.573
        CodeBase: file:///c:/windows/assembly/gac/system.windows.forms/1.0.5000.0__b77a5c561934e089/system.windows.forms.dll
    ----------------------------------------
    System
        Assembly Version: 1.0.5000.0
        Win32 Version: 1.1.4322.573
        CodeBase: file:///c:/windows/assembly/gac/system/1.0.5000.0__b77a5c561934e089/system.dll
    ----------------------------------------
    System.Drawing
        Assembly Version: 1.0.5000.0
        Win32 Version: 1.1.4322.573
        CodeBase: file:///c:/windows/assembly/gac/system.drawing/1.0.5000.0__b03f5f7f11d50a3a/system.drawing.dll
    ----------------------------------------
    ReflectionCleaner
        Assembly Version: 1.0.0.0
        Win32 Version: 00001.00003.02021.30940
        CodeBase: file:///C:/Program%20Files/Flux%20Media/Centrafuse/centrafuse.exe
    ----------------------------------------
    System.Data
        Assembly Version: 1.0.5000.0
        Win32 Version: 1.1.4322.573
        CodeBase: file:///c:/windows/assembly/gac/system.data/1.0.5000.0__b77a5c561934e089/system.data.dll
    ----------------------------------------
    System.Xml
        Assembly Version: 1.0.5000.0
        Win32 Version: 1.1.4322.573
        CodeBase: file:///c:/windows/assembly/gac/system.xml/1.0.5000.0__b77a5c561934e089/system.xml.dll
    ----------------------------------------
    cfplayback
        Assembly Version: 2.1.0.5
        Win32 Version: 2.1.0.5
        CodeBase: file:///C:/Program%20Files/Flux%20Media/Centrafuse/cfplayback.DLL
    ----------------------------------------
    Xheo.Licensing
        Assembly Version: 2.1.5000.0
        Win32 Version: 2.1.5000.26c
        CodeBase: file:///c:/windows/assembly/gac/xheo.licensing/2.1.5000.0__798276055709c98a/xheo.licensing.dll
    ----------------------------------------
    System.Web
        Assembly Version: 1.0.5000.0
        Win32 Version: 1.1.4322.573
        CodeBase: file:///c:/windows/assembly/gac/system.web/1.0.5000.0__b03f5f7f11d50a3a/system.web.dll
    ----------------------------------------
    System.Web.Services
        Assembly Version: 1.0.5000.0
        Win32 Version: 1.1.4322.573
        CodeBase: file:///c:/windows/assembly/gac/system.web.services/1.0.5000.0__b03f5f7f11d50a3a/system.web.services.dll
    ----------------------------------------
    Microsoft.DirectX.AudioVideoPlayback
        Assembly Version: 1.0.2902.0
        Win32 Version: 5.04.00.2904
        CodeBase: file:///C:/Program%20Files/Flux%20Media/Centrafuse/Microsoft.DirectX.AudioVideoPlayback.DLL
    ----------------------------------------
    System.Management
        Assembly Version: 1.0.5000.0
        Win32 Version: 1.1.4322.573
        CodeBase: file:///c:/windows/assembly/gac/system.management/1.0.5000.0__b03f5f7f11d50a3a/system.management.dll
    ----------------------------------------
    Freedb
        Assembly Version: 1.0.0.1
        Win32 Version: 1.0.0.1
        CodeBase: file:///C:/Program%20Files/Flux%20Media/Centrafuse/Freedb.DLL
    ----------------------------------------
    
    ************** JIT Debugging **************
    To enable just in time (JIT) debugging, the config file for this
    application or machine (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.
    
    For example:
    
    <configuration>
        <system.windows.forms jitDebugging="true" />
    </configuration>
    
    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the machine
    rather than being handled by this dialog.
    Attached Files
    my destinator map resource down permanently

  • #2
    1. pressed system info a loading screen came but centrafuse just froze had to exit via the task manager
    Can you post your system specs maybe? Motherboard/chipset. Cause I just checked on my NForce2 based system and it worked fine. Maybe theres a different way of accessing? David? Required Mbm maybed?
    Mark

    Website: http://www.greenpowerenthusiast.com/

    Car'Puter Project
    - Xenarc 700TSV
    - MSI RS482M-IL Mobo + AMD Turion MT-32 (25W)
    - 1x 256MB Corsair XMMS DDR400
    - M2-ATX
    - Belkin 802.11G W-Nic
    - Garmin 15H GPS
    - WinXP SP2 (NLited)

    Comment


    • #3
      Now onto my Bugs.

      1. Minor - When internet connection active and accidentally clicking on the "Connected" symbol on the top right side of the screen, the text will turn green. Going to another screen will make the Connected text look normal again.

      2. Major - Embedded Apps. This one is a problem with iGuidance and can be worked around for now, but this may cause problem with other apps as well. Does not start application in its native root. Need a Work-In Directive in config possibly? So program can start in their own directory. Similarly like why Centrafuse 1.2 wouldn't start as shell.

      3. Minor - on my desktop where I am testing at right now, program continuously pings my Floppy.

      4. Music resume on start. Always starts at begining of song, not where last left off from. Anoying on long song. Granted, I only tested so far playing 2minutes into the song.

      Looking great other then that so far.
      Mark

      Website: http://www.greenpowerenthusiast.com/

      Car'Puter Project
      - Xenarc 700TSV
      - MSI RS482M-IL Mobo + AMD Turion MT-32 (25W)
      - 1x 256MB Corsair XMMS DDR400
      - M2-ATX
      - Belkin 802.11G W-Nic
      - Garmin 15H GPS
      - WinXP SP2 (NLited)

      Comment


      • #4
        I get the same error when clicking the Vis button twice, but this is only when there is no music playing. Of course the Vis button doesn't need to be pressed anyways until you're playing music.
        1.6GHz HP e-PC, 768MB RAM, 120GB WD HDD, Slim DVD-ROM, Onboard sound & video, 7" Lilliput, USB GPS Mouse, Audiovox FM Modulator, Vector 400 Watt Power Inverter, Windows XP Pro SP2, iGuidance 2, 15" Samsung LCD for the rear *Carputer not installed*

        Comment


        • #5
          There already is a Bugthread in the Bug-Reports section!

          http://www.mp3car.com/vbulletin/forumdisplay.php?f=69

          Comment


          • #6
            Originally posted by DaRacerz
            3. Minor - on my desktop where I am testing at right now, program continuously pings my Floppy.
            Same here even with the program not running. Seems to be every 10 seconds.
            1.6GHz HP e-PC, 768MB RAM, 120GB WD HDD, Slim DVD-ROM, Onboard sound & video, 7" Lilliput, USB GPS Mouse, Audiovox FM Modulator, Vector 400 Watt Power Inverter, Windows XP Pro SP2, iGuidance 2, 15" Samsung LCD for the rear *Carputer not installed*

            Comment


            • #7
              Originally posted by krog
              There already is a Bugthread in the Bug-Reports section!

              http://www.mp3car.com/vbulletin/forumdisplay.php?f=69
              hehe mine was here earlier but its better to go to one thread to we will post in the other thread!
              my destinator map resource down permanently

              Comment


              • #8
                Originally posted by GReeToZ
                hehe mine was here earlier but its better to go to one thread to we will post in the other thread!
                True, but his was in the right forum.
                2000 Sunfire build 100%, or is it ever really 100%?

                Comment


                • #9
                  Originally posted by CavityCr33p
                  True, but his was in the right forum.
                  thats why i said to go on in the other thread :P
                  my destinator map resource down permanently

                  Comment


                  • #10
                    When trying to select multiple directories in the directory list view, I got an unhandled exception "Font 'GE Drover' doesn't support style 'Bold'" using the default skin.

                    Code:
                    See the end of this message for details on invoking 
                    just-in-time (JIT) debugging instead of this dialog box.
                    
                    ************** Exception Text **************
                    System.ArgumentException: Font 'GE Drover' doesn't support style 'Bold'.
                       at System.Drawing.Font.Initialize(FontFamily family, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet, Boolean gdiVerticalFont)
                       at System.Drawing.Font.Initialize(String familyName, Single emSize, FontStyle style, GraphicsUnit unit)
                       at System.Drawing.Font..ctor(String familyName, Single emSize, FontStyle style, GraphicsUnit unit)
                       at centrafuse.zListbox.OnPaint(PaintEventArgs pe)
                       at System.Windows.Forms.Control.PaintWithErrorHandling(PaintEventArgs e, Int16 layer, Boolean disposeEventArgs)
                       at System.Windows.Forms.Control.WmPaint(Message& m)
                       at System.Windows.Forms.Control.WndProc(Message& m)
                       at System.Windows.Forms.Label.WndProc(Message& m)
                       at System.Windows.Forms.ControlNativeWindow.OnMessage(Message& m)
                       at System.Windows.Forms.ControlNativeWindow.WndProc(Message& m)
                       at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
                    
                    
                    ************** Loaded Assemblies **************
                    mscorlib
                        Assembly Version: 1.0.5000.0
                        Win32 Version: 1.1.4322.573
                        CodeBase: file:///c:/windows/microsoft.net/framework/v1.1.4322/mscorlib.dll
                    ----------------------------------------
                    System
                        Assembly Version: 1.0.5000.0
                        Win32 Version: 1.1.4322.573
                        CodeBase: file:///c:/windows/assembly/gac/system/1.0.5000.0__b77a5c561934e089/system.dll
                    ----------------------------------------
                    System.Drawing
                        Assembly Version: 1.0.5000.0
                        Win32 Version: 1.1.4322.573
                        CodeBase: file:///c:/windows/assembly/gac/system.drawing/1.0.5000.0__b03f5f7f11d50a3a/system.drawing.dll
                    ----------------------------------------
                    centrafuse
                        Assembly Version: 1.3.2021.30940
                        Win32 Version: 00001.00003.02021.30940
                        CodeBase: file:///C:/Program%20Files/Flux%20Media/Centrafuse/centrafuse.exe
                    ----------------------------------------
                    System.Windows.Forms
                        Assembly Version: 1.0.5000.0
                        Win32 Version: 1.1.4322.573
                        CodeBase: file:///c:/windows/assembly/gac/system.windows.forms/1.0.5000.0__b77a5c561934e089/system.windows.forms.dll
                    ----------------------------------------
                    ReflectionCleaner
                        Assembly Version: 1.0.0.0
                        Win32 Version: 00001.00003.02021.30940
                        CodeBase: file:///C:/Program%20Files/Flux%20Media/Centrafuse/centrafuse.exe
                    ----------------------------------------
                    System.Data
                        Assembly Version: 1.0.5000.0
                        Win32 Version: 1.1.4322.573
                        CodeBase: file:///c:/windows/assembly/gac/system.data/1.0.5000.0__b77a5c561934e089/system.data.dll
                    ----------------------------------------
                    System.Xml
                        Assembly Version: 1.0.5000.0
                        Win32 Version: 1.1.4322.573
                        CodeBase: file:///c:/windows/assembly/gac/system.xml/1.0.5000.0__b77a5c561934e089/system.xml.dll
                    ----------------------------------------
                    cfplayback
                        Assembly Version: 2.1.0.5
                        Win32 Version: 2.1.0.5
                        CodeBase: file:///C:/Program%20Files/Flux%20Media/Centrafuse/cfplayback.DLL
                    ----------------------------------------
                    Xheo.Licensing
                        Assembly Version: 2.1.5000.0
                        Win32 Version: 2.1.5000.26c
                        CodeBase: file:///c:/windows/assembly/gac/xheo.licensing/2.1.5000.0__798276055709c98a/xheo.licensing.dll
                    ----------------------------------------
                    System.Web
                        Assembly Version: 1.0.5000.0
                        Win32 Version: 1.1.4322.573
                        CodeBase: file:///c:/windows/assembly/gac/system.web/1.0.5000.0__b03f5f7f11d50a3a/system.web.dll
                    ----------------------------------------
                    System.Web.Services
                        Assembly Version: 1.0.5000.0
                        Win32 Version: 1.1.4322.573
                        CodeBase: file:///c:/windows/assembly/gac/system.web.services/1.0.5000.0__b03f5f7f11d50a3a/system.web.services.dll
                    ----------------------------------------
                    Microsoft.VisualBasic
                        Assembly Version: 7.0.5000.0
                        Win32 Version: 7.10.3052.4
                        CodeBase: file:///c:/windows/assembly/gac/microsoft.visualbasic/7.0.5000.0__b03f5f7f11d50a3a/microsoft.visualbasic.dll
                    ----------------------------------------
                    Microsoft.DirectX.AudioVideoPlayback
                        Assembly Version: 1.0.2902.0
                        Win32 Version: 5.04.00.2904
                        CodeBase: file:///C:/Program%20Files/Flux%20Media/Centrafuse/Microsoft.DirectX.AudioVideoPlayback.DLL
                    ----------------------------------------
                    System.Management
                        Assembly Version: 1.0.5000.0
                        Win32 Version: 1.1.4322.573
                        CodeBase: file:///c:/windows/assembly/gac/system.management/1.0.5000.0__b03f5f7f11d50a3a/system.management.dll
                    ----------------------------------------
                    Freedb
                        Assembly Version: 1.0.0.1
                        Win32 Version: 1.0.0.1
                        CodeBase: file:///C:/Program%20Files/Flux%20Media/Centrafuse/Freedb.DLL
                    ----------------------------------------
                    RegexAssembly1_0
                        Assembly Version: 0.0.0.0
                        Win32 Version: n/a
                        CodeBase: 
                    ----------------------------------------
                    
                    ************** JIT Debugging **************
                    To enable just in time (JIT) debugging, the config file for this
                    application or machine (machine.config) must have the
                    jitDebugging value set in the system.windows.forms section.
                    The application must also be compiled with debugging
                    enabled.
                    
                    For example:
                    
                    <configuration>
                        <system.windows.forms jitDebugging="true" />
                    </configuration>
                    
                    When JIT debugging is enabled, any unhandled exception
                    will be sent to the JIT debugger registered on the machine
                    rather than being handled by this dialog.
                    Edit: Also, the option to replace the system shell doesn't work. It still loaded Explorer after I rebooted

                    Edit2: Yes it does, I was just being stupid, however once in this mode the behaviour of the exit button is broken. It should either power down the system, or perhaps more usefully, fire up Windows Explorer, then exit. Currently if you hit this button then ctrl+alt+del is your only way out

                    Comment


                    • #11
                      1.) Slow startup as shell

                      It works as the shell but starts up very slowly, slower than explorer launching and double clicking on a centrafuse shortcut. I have cleaned up services and startup programs and it still starts slowly. Windows shows the welcom screen and then stays on "loading personal settings for a while" and then centrafuse pops right up and no explorer.

                      Interesting enough, I can hear the music playing 20 seconds before I can actually see the Centrafuse interface.

                      2.) Embedded Apps

                      I have set Centrafuse to launch Firefox, Thunderbird, and Netstumbler as external apps. After you close the window, it leaves a grey box in centrafuse and you have to click back into the media screen, then back into apps to launch another embedded app. It would be a cool feature to go back to the media screen automatically after launching and application or at least get rid of this grey box issue.

                      I will also try to find a work around for not being able to run my startup programs like my wireless client without having explorer as the shell.
                      Xenarc 7" USB Touch LCD / 3.06 GHz P4 / 512MB DDR / 250GB 7200RPM 16MB HD /
                      DS-ATX 220W / Centrafuse / GPS / XM / 802.11g: 6db / RF Keyboard

                      Comment


                      • #12
                        Anything you need to run on startup that was previously in your startup folder, just move to the registry here:

                        HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Run

                        That should work even with CF as the shell.

                        Comment

                        Working...
                        X