Announcement

Collapse
No announcement yet.

CF Won't Start

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • CF Won't Start

    Since 1.3 came out, I installed it, and it worked, and I changed the settings, and I guess I changed something that shouldn't have been changed. So it wouldn't start, and it kept giving me this exception message listed below. I uninstalled it and reinstalled it, and it still gave me the message. Then I uninstalled it, and deleted the folder, and reinstalled 1.4, and still. Here is part of the error message:

    Code:
    Exception message:
    Process performance counter is disabled, so the requested operation cannot be performed
    Exceptiontype name:
    System.Reflection.TargetInvocationException
    Exception Assembly name:
    mscorlib, version: 1.0.5000.0, culture=neutral
    Publickey Token = b77a5c561934e089
    Anyone know what the problem is? I'd like to run this beautiful piece of software.

  • #2
    windows detect some sort of problem and has disabled your performance counters, which I use in the first part of centrafuse load to determine if it is already loaded...

    I will change this to not use the performance counters anymore... For now you can reenable your counters by deleting...

    HKEY_LOCAL_MACHINE\SYSTEM\Curr*entControlSet\Servi ces\PerfProc\Performance\Disable

    if it exists...

    here is the reason it happens...

    http://msdn.microsoft.com/netframewo...aspx#Question2

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

    Comment


    • #3
      I tried deleting the Performance folder, and it still performs the same error. There is no disable key anywhere in that folder, nor is there a folder called Disable. Anything else I can do?

      Comment


      • #4
        I will take this code out so you will not have this problem anymore after the next update...

        Try to search on how to re-enable performance counters in XP...

        david
        __________________
        CENTRAFUSE http://www.centrafuse.com
        01 Jeep Cherokee Sport 4x4 Installed
        M10000/512Mb/20GB, Lilliput 7", Holux GM-210

        Comment


        • #5
          OK.. Do you know how much longer the next update will take? I got a pretty long road trip coming up tomorrow..

          Comment


          • #6
            won't have one out that quick... you need to either re-install XP or find out which service got it's performance counter disabled...

            http://www.microsoft.com/resources/d...ntry/94214.asp

            david
            __________________
            CENTRAFUSE http://www.centrafuse.com
            01 Jeep Cherokee Sport 4x4 Installed
            M10000/512Mb/20GB, Lilliput 7", Holux GM-210

            Comment


            • #7
              Problem with CentraFuse and XP Professionnal NLITEd

              For those which have the error message :
              «Performance counter is disabled…. »

              Download PerfProc.dll from here :

              http://www.dlldump.com/download-dll-.../download.html

              Place it in :
              C:/Windows/sytem32/PerfProc.dll


              Make a .reg file with the following text : (.txt file renamed in « blabla.reg » and double-click on it)

              Windows Registry Editor Version 5.00

              [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\PerfProc]

              [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servic es\PerfProc\Performance]
              "Close"="CloseSysProcessObject"
              "Collect"="CollectSysProcessObjectData"
              "Collect Timeout"=dword:00001f40
              "Library"="perfproc.dll"
              "Object List"="230 232 786 740 816 1408 1500 1548 1760"
              "Open"="OpenSysProcessObject"
              "Open Timeout"=dword:00002710
              "WbemAdapFileSignature"=hex:2b,c8,83,a7,35,21,fa,7 3,c0,54,99,3d,f3,7e,cf,d3
              "WbemAdapFileTime"=hex:00,e0,8c,f6,b8,2f,c1,01
              "WbemAdapFileSize"=dword:00008c00
              "WbemAdapStatus"=dword:00000000


              REBOOT system

              And after CF should work…It works for me

              Brice
              New prototype : 2DIN AUDI OEM-LIKE CARPC based on SYMPHONY II
              Motorized InDash Screen, Core 2 Duo 2.2Ghz, SSD

              Home Made In-Dash 7" Lilliput V1
              Home Made In-Dash 7" Lilliput V2 = LM-Lilliput Prototype

              First project in Peugeot 306

              Comment


              • #8
                Error Image

                I am getting the above error when starting CF.

                If this will not be an issue with the next release, then nevermind, otherwise, how do I make it work?!
                Jarrod - Holden VX S!

                Comment


                • #9
                  Originally posted by Jarrod
                  Error Image

                  I am getting the above error when starting CF.

                  If this will not be an issue with the next release, then nevermind, otherwise, how do I make it work?!
                  the post right above you explains how to fix it...

                  david
                  __________________
                  CENTRAFUSE http://www.centrafuse.com
                  01 Jeep Cherokee Sport 4x4 Installed
                  M10000/512Mb/20GB, Lilliput 7", Holux GM-210

                  Comment


                  • #10
                    I have a similar problem running CF on my vmwared xppro, the fix above didn't work
                    Peugeot 206 1.4 HDi

                    Intel Mini-ITX Mainboard
                    Celeron 1.2ghz
                    256mb DDR-2 533
                    80gig 3.5" SATA HDD
                    Sb Live 5.1 w/ KXProject Drivers
                    M2-ATX
                    8" Lilliput TS LCD

                    100% installed and working :D

                    Comment


                    • #11
                      Originally posted by Frankino
                      I have a similar problem running CF on my vmwared xppro, the fix above didn't work
                      Just to let you guys know,

                      I just got the error to. This is after i did a windows update 2 days ago

                      Comment


                      • #12
                        the upcoming release doesn't use performance counters...

                        david
                        __________________
                        CENTRAFUSE http://www.centrafuse.com
                        01 Jeep Cherokee Sport 4x4 Installed
                        M10000/512Mb/20GB, Lilliput 7", Holux GM-210

                        Comment


                        • #13
                          Sorry, forgot to mention I tried the above fix and it didnt work.

                          When will the upcoming release be available?
                          Jarrod - Holden VX S!

                          Comment

                          Working...
                          X