Announcement

Collapse
No announcement yet.

Centrafuse not reading MP3 tags

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Centrafuse not reading MP3 tags

    I have searched and not found an answer to this problem. On my recently formatted car pc running XP pro sp2, Centrafuse 4.2 would not install because of some error and 4.0 could not read the tags of any mp3. Every song (2600 of them) showed up under "Unknown Artist" and "Unknown Album".

    I formatted the hard drive, reinstalled windows (pro sp1), installed .net runtimes and centrafuse 4.2. Now Centrafuse reads one album correctly and put the rest under "Unknown Artist" "Unknown Album". The strangest thing is that all the artwork is loaded correctly.

    Any help would be appreciated. Thanks.
    Bruno Speech Recognition - Advanced Speech Recognition designed to control any program. Extra support for FrodoPlayer and Winamp.

  • #2
    Now after an arbitrary number of rebulids, it works. Weird.
    Bruno Speech Recognition - Advanced Speech Recognition designed to control any program. Extra support for FrodoPlayer and Winamp.

    Comment


    • #3
      i have a whole heap of songs but I still get songs with Unknown ARtist when I know that I've sorted my whole library properly and I've got the tags on ID3 v2.4. VERY strange. Is there still something that needs to be sorted out with the tags? Also, with the Genre names I have some appearing strange like eg. R&B would say "RAndB".

      Comment


      • #4
        Originally posted by ahew View Post
        i have a whole heap of songs but I still get songs with Unknown ARtist when I know that I've sorted my whole library properly and I've got the tags on ID3 v2.4. VERY strange. Is there still something that needs to be sorted out with the tags? Also, with the Genre names I have some appearing strange like eg. R&B would say "RAndB".
        just by chance check to see if the files are set to read only... It shouldn't cause a problem, but I'm curious... It did at one point...

        david
        __________________
        CENTRAFUSE http://www.centrafuse.com
        01 Jeep Cherokee Sport 4x4 Installed
        M10000/512Mb/20GB, Lilliput 7", Holux GM-210

        Comment


        • #5
          funkdamonkman, what error did you receive? i had an error after installing the latest build when i ran it for the first time it errored out, i was on my way to work so didn't get a chance to read through it or dig around any. just curious of your error.
          replicant
          Audi A4 (flickr pics)

          Comment


          • #6
            Do all of you use iTunes to organize you songs, because I found that after the iTunes 7 update I had this problem. Look here at this thread.

            http://www.mp3car.com/vbulletin/showthread.php?t=91360
            "Toilets scare the crap of of me..."

            Comment


            • #7
              My rebuilt library was all done in itunes 7.0.2. CF can't read the tags at all. I have done heaps of library rebuilds in CF and it doesn't change a thing. There are only about 12 files it does read.

              I did just before download and installed ID3-TagIT. Its based on .net framework 1.1 and it can't read the tags at all except for the same 12 files. I'm guessing that CF and ID3-TagIT are using the same code base?
              We are, will have and forever will be...
              But not tommorrow!

              Comment


              • #8
                I've downloaded a few different tag editors and I'll see what comes up. I actually have a lot of files appearing as Unknown Artist but the same files also read as the actual artist name. it's strange... plus CF seems to read more files than there actually are in the folders (when iTune reads the folder it states about 1600+ but CF says 1700+). I get the information from when I rebuild the database.

                Comment


                • #9
                  I know that iTunes can read ID3 format upto v2.4 but as far as writing, they have a propriatary format that they use on m4a's and it is very similar to ID3 but still not the same. You can convert the tags in iTunes over to ID3 version whatever if you right click on the items you want and go down to Convert ID3 tags, but I have done this and checked the info afterward and they did not change. So my finger still points to iTunes about this and I am going to get ahold of them next.
                  "Toilets scare the crap of of me..."

                  Comment


                  • #10
                    Thanks to Midiwall, who had a look at some of my iTunes encoded files he found the following.

                    Originally posted by midiwall
                    I'm pretty sure I know what's confusing CF. iTunes is using a different version of the ID3 tags than what David is looking for.

                    In the two tracks I pulled, they've been encoded with v2.3 tags and CF is looking for v2.4 tags. The difference can be seen in things like the flag for the Track Name. In v2.3, the tag is "TRK", in v2.4 the tag is "TRCK". Basically it's these tags that a program has to search for in order to find the text that's associated with the field. The change for David should be easy, he'll just need to search for both v2.4 and v2.3 tags.

                    fwiw, the v2.4 tag frames are defined here:

                    http://www.id3.org/id3v2.4.0-frames.txt
                    We are, will have and forever will be...
                    But not tommorrow!

                    Comment


                    • #11
                      Download a program called The GOdfather, and synch the ID3 tags to all versions....
                      2002 Honda CR-V
                      Carputer progress: 90% [▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ -]
                      Spent so far: $1105.90


                      Download the NEXUS Skin for Centrafuse
                      ...or even Listen to my music

                      Comment


                      • #12
                        Here is the problem...

                        http://www.mp3car.com/vbulletin/show...3&postcount=57

                        david
                        __________________
                        CENTRAFUSE http://www.centrafuse.com
                        01 Jeep Cherokee Sport 4x4 Installed
                        M10000/512Mb/20GB, Lilliput 7", Holux GM-210

                        Comment


                        • #13
                          My Solution

                          Even though this is an old thread I need to post my solution as I have been looking everywhere and did not find the solution I have.

                          I have a fresh install of Windows XP Professional SP3. I installed centrafuse 1.2, imported my music and all music showed under the category 'unknown artist'. I upgraded to v1.47 and then 3.5 and still the same issue. I could not work this thing out as centrafuse was displaying songs correctly on my laptop with Windows 7.

                          My music is organised off another PC with iTunes...

                          ********MY SOLUTION*************
                          Then it hit me, I don't have iTunes installed on the car pc. I installed iTunes, re-imported my music and all of the ID tags are displaying correctly. I guess iTunes needs to be installed to support the new ID tag version.

                          v1.2, 4.7 & 3.5 all work now!

                          Also, iTunes is only installed, I don't use this on the car PC, it is purely for support.

                          Comment

                          Working...
                          X