Announcement

Collapse
No announcement yet.

id3 tags not being recognized by centrafuse

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • id3 tags not being recognized by centrafuse

    Hi there,
    I have a few thousand songs I copied from my ipod, these songs were converted using itunes to id3 v2.3 (they were in v2.4 and more than half appeared as "unknown artist"...)
    All songs have full information (artist, album, song name, genre, year, album art and even lyrics...)

    For some reason for many albums the album art does not appear and 3 specific songs still appear under "unknown artist".

    All the information is readable by itunes (including the album art which is around 200x200 for most albums) and I made sure I have r+w on all files and directories,
    In addition - there are no jpg files running around to interfere with the embedded album art images.

    I have uploaded 2 mp3 files, 1 from the "unknown artist" list and 1 song from the many albums I have with no cover art.
    http://www.rockfour.com/cf.zip

    Thanks for the great work.

  • #2
    Originally posted by GibsonLP View Post
    Hi there,
    I have a few thousand songs I copied from my ipod, these songs were converted using itunes to id3 v2.3 (they were in v2.4 and more than half appeared as "unknown artist"...)
    All songs have full information (artist, album, song name, genre, year, album art and even lyrics...)

    For some reason for many albums the album art does not appear and 3 specific songs still appear under "unknown artist".

    All the information is readable by itunes (including the album art which is around 200x200 for most albums) and I made sure I have r+w on all files and directories,
    In addition - there are no jpg files running around to interfere with the embedded album art images.

    I have uploaded 2 mp3 files, 1 from the "unknown artist" list and 1 song from the many albums I have with no cover art.
    http://www.rockfour.com/cf.zip

    Thanks for the great work.
    I will look into it... Are you running RC5?

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

    Comment


    • #3
      Yeah, RC5.

      Thanks!

      Comment


      • #4
        Hi David,

        Did you find anything in the songs I sent?

        Thanks.

        Comment


        • #5
          Hey Gibson.. I downloaded your two songs and here is what I found..

          I use a program called The GodFather to do id3 tags for my mp3s. When I right click on the song and viewed the properties windows didn't show me anything. (Ie. Title, Artist, Album). When I updated the song in The GodFather, essentially syncing the ID3 v2.3 and ID3 v1.1 tags, then viewed properties through windows it showed up. I am thinking that somehow the tags on the mp3s got messed up and that is why CF shows them as Unknown.

          Comment


          • #6
            Hi there,
            Most of the songs I edited with itunes are unreadable by windows (right click/properties shows no id3 information).
            However - most of them are perfectly readable by CF and winamp. Actually - "noimage" sample I provided shows perfectly on CF in terms of artist/album, but the album cover doesn't show corretly.

            Again - these are normal mp3 I created using lame and then edited by itunes to add more id3 information.

            Comment


            • #7
              David, did you have the chance to look at it? did you find anything?
              Any input would be appreciated.

              Thanks.

              Comment


              • #8
                The two songs I received not only did not show tags in windows, they wouldn't even play in WMP...

                the files appeared bad to me... something was wrong with them...

                david
                __________________
                CENTRAFUSE http://www.centrafuse.com
                01 Jeep Cherokee Sport 4x4 Installed
                M10000/512Mb/20GB, Lilliput 7", Holux GM-210

                Comment


                • #9
                  Hi,

                  For some reason - most of the songs don't play in wmp.
                  Winamp and Centrafuse are capable of playing them perfectly though.

                  The only thing I did was:

                  1. Encode using lame (Linux)
                  2. Edit the id3 tags using itunes, adding almost all details (including lyrics and album art cover).

                  That's it...

                  I did notice something that might help you - the songs that don't have their album art appearing correctly were edited by an older version of itunes than the one having their album art appearing correctly...

                  I have no idea how come wmp doesn't play these mp3s anymore, it must be something itunes did, however - as I mentioned previously - they DO play with centrafuse.

                  EDIT: I checked it with GodFather - Everything looks great there (image, id3 tags) and the songs play great...

                  Comment


                  • #10
                    not sure, but if WMP can't play it most likely the files have bad headers of some kind, which is the same reason why Centrafuse doesn't read the tags...

                    david
                    __________________
                    CENTRAFUSE http://www.centrafuse.com
                    01 Jeep Cherokee Sport 4x4 Installed
                    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

                    Comment


                    • #11
                      Problem solved.

                      The only problem was that for some reason - all the files I had that were transformed to id3 v2.3 by an old itunes version (6.something) had a very odd comments field, all I did was to run a script on my linux box to remove the comments field completely (I don't really need it) and that's it!
                      Everything is now working fine with both WMP and centrafuse.

                      Comment

                      Working...
                      X