No announcement yet.

no audio control with XM plugin

  • Filter
  • Time
  • Show
Clear All
new posts

  • no audio control with XM plugin

    I'm trying to use the new XM plugin on 1.40 (and 1.30) and I cannot get it to control the audio line in. This is running on Vista Ultimate (UAC disabled). It will not unmute/mute the line-in on which the XMDirect is connected. If I go to the Sound CPL and flip the settings, I get XM sound, but Centrafuse just doesn't seem to want to control it. I've configured it to use the right line-in in the XM settings screen.

    I've also tried a different USB audio adapter with same results.

    Here's the beginning of the XM log file:

    26:03:18> startupRadio()
    26:03:25> satPowerUp(0)
    26:03:25> satPowerUp():  Opening COM10
    26:03:71> satPowerUp(30)
    26:03:71> satPowerUp():  Opening COM10
    26:03:73> RxThread Entering
    26:03:73> tuneChannel():  30
    26:03:73> satStationInfo()
    26:03:74> satStationInfo()
    26:04:26> doCommand():  Writing currentCMD = XM_UNMUTE
    26:05:06> doCommand():  Writing currentCMD = NO_COMMAND: 5A A5 00 04 25 08 1E 00 ED ED
    26:05:30> musicLst_DoubleClick():  musicLst.SelectedIndex = 26
    26:05:30> musicLst_DoubleClick():  newchannel = 30
    26:05:31> tuneChannel():  30
    26:05:31> satStationInfo()
    26:05:46> musicLst_DoubleClick():  musicLst.SelectedIndex = 26
    26:05:46> musicLst_DoubleClick():  newchannel = 30
    26:05:46> tuneChannel():  30
    26:05:46> satStationInfo()
    26:05:50> musicLst_DoubleClick():  musicLst.SelectedIndex = 26
    26:05:50> musicLst_DoubleClick():  newchannel = 30
    26:05:50> tuneChannel():  30
    26:05:50> satStationInfo()
    26:05:89> RxThread():  Bytes=00 1B 80,  satSize=28
    26:05:89> RxThread():  OpCode = 80, satState = PowerON
    26:05:99> RxThread(): Processing 28 bytes
    26:05:99> RxThread():  Calling ProcessSat(): Bytes=01 00 00 25 10 29 20 02 01 00 00 01 74 04 05 20 02 08 4A 52 5A 50 32 30 57 59 00 59
    26:06:02> ProcessSat():    %)   t JRZP20WY Y
    26:06:06> RxThread():  Bytes=00 4D A5,  satSize=78
    26:06:06> RxThread():  OpCode = A5, satState = StationInfo
    26:06:16> RxThread(): Processing 78 bytes
    Any suggestions? Other info I can provide to shed some light?

    Update: I've managed to get XM turn off properly when closing Centrafuse (XM audio goes away); however when starting Centrafuse again, it never starts up again with XM, it always starts Media. Switching to XM will start-up XM ok (XM audio starts up), but XM will continue to play when switching back to Media. Also, Centrafuse volume control has no affect on XM.


  • #2
    The volume control is most likely a Vista issue, the current mixer code does not fully function on Vista yet, on some sound devices... The issues are with muting, and selecting line devices...

    The not starting back in XM mode will be fixed in the XM plugin, as well as the buffer code will be added back which should give you audio control... Once you use the buffer it will not have to control the line device in the mixer...

    does your volume work at all in Centrafuse on Vista? If so it should be controlling the master volume, so if you hear XM and you can control master volume, it should be changing the volume...

    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210


    • #3
      CF volume control works properly for me only for regular media (eg MP3, video) and and CF sounds (button presses). Once XM is started, the CF volume control/mute has no affect on XM, but it works fine for the media and CF sounds. XM keeps playing at the same volume level until I exit CF.

      I've tried the built-in sound on the Intel D201GLY board and a USB iMic adapter. Is there a USB adapter that you know works well with Vista now?

      With the I can only control XM volume from the properties of the playback adapter in Vista's sound CPL:
      Attached Files


      • #4
        the master volume should also lower the line-in output...

        either way this will work for you with the update coming soon adding buffering...

        check the XM/Sirius log for the next update...

        01 Jeep Cherokee Sport 4x4 Installed
        M10000/512Mb/20GB, Lilliput 7", Holux GM-210


        • #5
          looking forward to the update! thanks