Announcement

Collapse
No announcement yet.

Centrafuse 1.40 Bugs

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Centrafuse 1.40 Bugs

    The aura skin the setting levels part of the skin the background is black behind the bass and treble controls.

    I have the autovolume plugin installed, every time a change to the volume is made the volume splash screen pops up.

    I have enabled the gestures, they do work but its now difficult to press a button, I guess I need to play around with the parameters to improve things. Some explanation of the parameters would be useful.

  • #2
    The main mixer screen was a bug, I fixed this and posted a new centrafuse.exe for CF 1.41 here:

    http://forums.fluxmedia.net/showpost...96&postcount=3

    I need to add a method in the SDK so the volume plugin can change the volume without firing the dialog to display, I will add this to my list...

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

    Comment


    • #3
      As I said, we had some issues with gestures and we mainly focused on the gestures on the list views...

      The gestures.xml has basic settings...

      ENABLEGESTURES = True/False - enables or disables gestures

      GESTUREOFFSET = This is in pixels and is how much change on the screen determines a gesture, so if click the mouse and you move this pixel amount, it registers as a gesture

      DETECTIONTIME = This is the amount of time in ms to look for the pixel change in the offset above, so the on mouse down it starts to wait the detection time, checks how much you moved and compares to the offset. If the offset amount has changed, then it's a gesture, otherwise continue with a normal button press

      GESTUREDISTANCEX = This is the amount of pixels before firing the gesture when moving left/right

      GESTUREDISTANCEY = This is the amount of pixels before firing the gesture when moving up/down

      GESTURE1-4 = These are the actions you can set, GESTURE1 is moving UP, GESTURE2 is moving to the RIGHT, GESTURE3 is moving DOWN, and GESTURE4 is moving to the LEFT

      david
      __________________
      CENTRAFUSE http://www.centrafuse.com
      01 Jeep Cherokee Sport 4x4 Installed
      M10000/512Mb/20GB, Lilliput 7", Holux GM-210

      Comment


      • #4
        Thanks for the info when, my car is stationary pressing the buttons is not a problem, when moving I guess theres a movement greater than 3 pixels. Going to try differnt values. I will report my findings.

        Comment


        • #5
          Using a gestureoffset = 10 and Detectiontime = 250 works fine for me.

          Comment


          • #6
            Originally posted by clarkie View Post
            Using a gestureoffset = 10 and Detectiontime = 250 works fine for me.
            does having the detection time as high as 250 not make it seem like it lagged when clicking normal buttons?

            david
            __________________
            CENTRAFUSE http://www.centrafuse.com
            01 Jeep Cherokee Sport 4x4 Installed
            M10000/512Mb/20GB, Lilliput 7", Holux GM-210

            Comment


            • #7
              No seems pretty normal to me

              Comment


              • #8
                With experience in STOKEIT (gesture software), I think gesture should be applied "on click release" instead of "on click".
                New prototype : 2DIN AUDI OEM-LIKE CARPC based on SYMPHONY II
                Motorized InDash Screen, Core 2 Duo 2.2Ghz, SSD

                Home Made In-Dash 7" Lilliput V1
                Home Made In-Dash 7" Lilliput V2 = LM-Lilliput Prototype

                First project in Peugeot 306

                Comment


                • #9
                  The skin bug around the PLAY/PAUSE button is still present (like an offset of 1 pixel up + 1 pixel left make appear a blue line)

                  This bug is highlightened with the new Aura skin.
                  New prototype : 2DIN AUDI OEM-LIKE CARPC based on SYMPHONY II
                  Motorized InDash Screen, Core 2 Duo 2.2Ghz, SSD

                  Home Made In-Dash 7" Lilliput V1
                  Home Made In-Dash 7" Lilliput V2 = LM-Lilliput Prototype

                  First project in Peugeot 306

                  Comment


                  • #10
                    Volume bug

                    This was present since 1.2.
                    When you are in fullscreen mode playing a video, you can't let the volume button push in order to increase volume continuously.
                    When playing MP3, you can.
                    New prototype : 2DIN AUDI OEM-LIKE CARPC based on SYMPHONY II
                    Motorized InDash Screen, Core 2 Duo 2.2Ghz, SSD

                    Home Made In-Dash 7" Lilliput V1
                    Home Made In-Dash 7" Lilliput V2 = LM-Lilliput Prototype

                    First project in Peugeot 306

                    Comment


                    • #11
                      I will get the volume issue fixed, as well as look into the play/pause issue... it is more highlighted in different resolutions in the new skin...

                      the issue with the gestures is something I am working on, this is why it is only 4 basic gestures now until I get the framework out, then I can plug the coordinates into the gesture engine to add more complex gestures...

                      the issue with doing it on release is Centrafuse triggers quite a lot on mouse down, such as button highlights, and starting threads for switching modes, skins, fastforwarding, rewinding, saving presets, changing volume, etc...

                      this was just an attempt to allow all that to work and still get gestures to work...

                      still looking into the best method...

                      david
                      __________________
                      CENTRAFUSE http://www.centrafuse.com
                      01 Jeep Cherokee Sport 4x4 Installed
                      M10000/512Mb/20GB, Lilliput 7", Holux GM-210

                      Comment


                      • #12
                        David - just some comments on 1.4 for you after I spending my day in the car with it...

                        Throw scrolling also is also a REALLY welcome addition. However, I found that with a long list (1000+) the list continues to scroll for a while (like a number of seconds) after you remove your finger from the screen. Even when you move your finger very fast, the list doesn't seem to scroll all that fast. What I did find really confusing though was the direction that the list scrolls - with the 'alphabet' scroll, moving your finger downward on the screen causes the list to scroll from A-Z, i.e. from top to bottom of the list. However, with the throw scrolling moving your finger downward on the screen scrolls from the bottom to the top of the list. Would it be possible to change this?

                        My other gripe from today's trip relates to the Destinator Nav voice - as it is, when the Nav announces a turn, the music pauses, the nav voice tells you your turn, and the music plays again. I would much rather that the music was muted as against paused - it sounds really weird when the music gets an extra beat or two (especially when you're singing along)! Would it be possible to give the user the option whether to pause or mute the music?

                        Keep up the great work - I've been using Centrafuse for over a year now and couldn't be happier with it. It's easier to use and more stable then ever, and the new features and skin are great

                        Comment


                        • #13
                          I just recently installed a HQCT and noticed that when you go back into media after playing the radio, it takes a few seconds to populate the media info and play the media (playlist count, track names, song titles, etc)

                          Also, I don't think you have the very most recent phonecontrol exe in this release either. The newest one that zorro posted in the other thread worked the best... I got a few "failed to load resources" dialogs with the current 1.40 release.

                          Edit: A ouple more radio issues using a HQCT... It seems that presets dont stick after closing and restarting CF. I assigned 6 or so presets in one of the 3 FM preset lists and came back to everything being assigned 87.00. I tried a few more times and it did the same thing. I also noticed occasionally that pressing and holding the preset buttong wouldn't always assign the current station to the preset you were pressing. Sometimes it would beep after 2 seconds or so and then switch to 87.00. Last thing I noticed was when I tried using the seek button, it would never lock on to a station. I could tune to numerous stations manually and it would be fine, but seeking wouldnt grab em. Initially it worked okay, and then it stopped seeking properly, and then later it came back and worked again... no explanation really.

                          Comment


                          • #14
                            Originally posted by kftqq View Post
                            David - just some comments on 1.4 for you after I spending my day in the car with it...

                            Throw scrolling also is also a REALLY welcome addition. However, I found that with a long list (1000+) the list continues to scroll for a while (like a number of seconds) after you remove your finger from the screen. Even when you move your finger very fast, the list doesn't seem to scroll all that fast. What I did find really confusing though was the direction that the list scrolls - with the 'alphabet' scroll, moving your finger downward on the screen causes the list to scroll from A-Z, i.e. from top to bottom of the list. However, with the throw scrolling moving your finger downward on the screen scrolls from the bottom to the top of the list. Would it be possible to change this?

                            My other gripe from today's trip relates to the Destinator Nav voice - as it is, when the Nav announces a turn, the music pauses, the nav voice tells you your turn, and the music plays again. I would much rather that the music was muted as against paused - it sounds really weird when the music gets an extra beat or two (especially when you're singing along)! Would it be possible to give the user the option whether to pause or mute the music?

                            Keep up the great work - I've been using Centrafuse for over a year now and couldn't be happier with it. It's easier to use and more stable then ever, and the new features and skin are great
                            It is a known issue with the logic with the scrolling, should be fixed in the next update... it is with large lists... I chose the direction based other devices with similiar functionality, I could switch the old feature to match but then some users have gotten use to it... not sure what I should do about this...

                            I have it on my features to go to ATT instead of mute...

                            david
                            __________________
                            CENTRAFUSE http://www.centrafuse.com
                            01 Jeep Cherokee Sport 4x4 Installed
                            M10000/512Mb/20GB, Lilliput 7", Holux GM-210

                            Comment


                            • #15
                              Originally posted by sivart321 View Post
                              I just recently installed a HQCT and noticed that when you go back into media after playing the radio, it takes a few seconds to populate the media info and play the media (playlist count, track names, song titles, etc)

                              Also, I don't think you have the very most recent phonecontrol exe in this release either. The newest one that zorro posted in the other thread worked the best... I got a few "failed to load resources" dialogs with the current 1.40 release.

                              Edit: A ouple more radio issues using a HQCT... It seems that presets dont stick after closing and restarting CF. I assigned 6 or so presets in one of the 3 FM preset lists and came back to everything being assigned 87.00. I tried a few more times and it did the same thing. I also noticed occasionally that pressing and holding the preset buttong wouldn't always assign the current station to the preset you were pressing. Sometimes it would beep after 2 seconds or so and then switch to 87.00. Last thing I noticed was when I tried using the seek button, it would never lock on to a station. I could tune to numerous stations manually and it would be fine, but seeking wouldnt grab em. Initially it worked okay, and then it stopped seeking properly, and then later it came back and worked again... no explanation really.

                              not sure about the phone, I will check with Zoran... It should not hesitate switching to media...

                              anyone else have issue saving presets? check your System\radio.xml file and make sure it is still valid XML...

                              david
                              __________________
                              CENTRAFUSE http://www.centrafuse.com
                              01 Jeep Cherokee Sport 4x4 Installed
                              M10000/512Mb/20GB, Lilliput 7", Holux GM-210

                              Comment

                              Working...
                              X