Announcement

Collapse
No announcement yet.

No radio audio if buffer is turned off

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • No radio audio if buffer is turned off

    1.) Turn off the radio buffer.

    Bug: No radio audio (if radio was already playing, it will immediately stop).


    I'm using the Infill G4 with an external USB soundcard, if it matters. Radio audio was not working at all in RC3. I have the playback/record radio settings both set to Realtek Line In (Realtek is the onboard sound card; my external USB soundcard is an Audio Advantage Roadie).


    (This is for CF 2.0 RC4.)
    Attached Files

  • #2
    what device do you use for audio output? realteak? I noticed another audio device on your system...
    http://www.fluxmedia.net/

    Comment


    • #3
      I use my "Audio Advantage Roadie" USB soundcard for all audio output (full description in original post).

      Comment


      • #4
        hmm, i am not so sure non-buffer mode will work when your output card is different from your input card. Non-buffer mode is "pass-through" audio, its like just unmuting the deviceline in windows mixer, i think it will only pass through to it's own card's output. Try this: Go into radio, it will not work in non-buffer mode, then check windows mixer, if the line its plugged in to is definitely unnmuted, then yep, this will not work, nothing we can do, just nature of your setup. If the line is still muted, its a bug, then, manually unmute it, see if audio comes on...
        http://www.fluxmedia.net/

        Comment


        • #5
          Yes, when I turn off the radio buffer, the Realtek Line In output option in the Windows Mixer is unmuted.

          It's not a huge deal since I'd much rather use the buffer. And very soon I will be switching to an HD Radio, since the internal G4 radio only lasts anywhere from 2 seconds to 15 minutes before dying (turning to static) for some random amount of time (or maybe I'm just one of the lucky ones who got a defective unit from Korea).

          But I think it is possible to make it work, since it does work with Streetdeck (both buffered and unbuffered).

          Comment


          • #6
            not sure how streetdeck would make that work. opening a line for pass through audio doesnt require any code. unmuting that line in windows mixer should just automatically output the input signal to the speakers, if it doesn't do that, there is nothing cf can do, because it is just pass-through audio...
            http://www.fluxmedia.net/

            Comment

            Working...
            X