No announcement yet.

ElmScan ISO "NO Data"

  • Filter
  • Time
  • Show
Clear All
new posts

  • ElmScan ISO "NO Data"

    I just recieved my ElmScan ISO. It works good for like the first 4 to 6 commands.. It seems when the device get flooded with commands it responds with "NO DATA"... in order to fix this one must send the command "ATZ" to re-initialized the device.. Only problem is I dont have access to the OBDII plugin src

    It seems other people have been experiancing this problem also but with different software.

    It's the second post by CorollaULEV about the 99 maxima.

    David, would it be possible to make this plugin open source.. or, just add in an option so that when "NO DATA" is received send out an "ATZ" command to re-init the device.


  • #2

    Yes this sometimes happens on my ElmScan too. If you have trouble connecting to your OBDII device, click the red/green status light in OBD-II to reconnect. It will clear the buffer and re-init (send ATZ) the device.

    Formerly from Centrafuse


    • #3
      Yea it'd be cool if this happens sometimes. But it happens immediatly after it gets flooded with commands. (Approx. 4-5 sec into it).

      I tried developing a comm port gateway using eltima serial port drivers. But couldnt find any VB6 SDK for the elmscan. actually, while writing this found it:

      Anyway, I'll play with it tonight. Basically I will make CF connect to virtual port A. My VB App will connect to virtual port B and to the ElmScan. Then i'll just re-route the data from virtual port A to the elmscan, when I see that there is no data, send a "ATZ" command.


      • #4
        Alright, I am done coding my vb app. My app keeps the ElmScan Initialized and checks for "NO DATA" returns. It currently requires a 3rd party tool called "Eltima Serial Driver XP" to create a com port tunnel. My ElmScan ISO works perfectly now.

        If anyone would like the app just let me know. As of right now it is not user-friendly, I am not going to make it "user" friendly if "users" aren't going to be using it

        How it Works:

        Mirrored virtual ports are created with Eltima's software. Lets call them Port A and B. My ElmScan is connect to Physical Port C. Centrafuse OBDII is setup to use Port A. My app creates a bridge between Port B and Port C , and monitors all the data that goes through it, Ensuring that the OBDII is initialized and returning proper values.

        What was causing the "NO DATA" returns from ElmScan:
        Apparently the commands below were making my device render useless. After entering these commands the ElmScan would return "NO DATA" for every command after.

        either of these commands 010a , 010b , 011e , or 011f


        • #5

          I believe I know what the problem is. It's possible those commands are crashing the serial bus stream because they aren't support by the vehicle.

          There is a method to get the supported commands through the obdii interface, and it appears to be not functioning properly in the CF OBDII plugin.

          Will look into this.
          Thanks guys.

          Formerly from Centrafuse


          • #6
            Yep makes sense. After I filtered out those commands the device stopped crashing. Although my tunnel program does the job, it is also causing the update to be very slow. It would be cool if you guys could fix this If you want to beta test the new plugin just send it my way.

            Alberto S.