Announcement

Collapse
No announcement yet.

Centrafuse RC2 Bugs

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Centrafuse RC2 Bugs

    Post all the bugs found in RC2 here.

    Check to make your bug is not already known:
    http://www.mp3car.com/vbulletin/showthread.php?t=80817

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  • #2
    POIīs

    .

    Comment


    • #3
      In some dialogs the key 'enter' somehow seems to be double-accepted, i.e. if you enter a address in gps and you press enter after choosing the city the next screen is the selection of the number instead of the street, hitting the right arrow after entering the city brings up the street dialog correctly. Same thing seems to happen in some setup screens, i.e. when choosing a radio device hitting enter cause the device list to close for a split-second and reopen instantly as if you have pressed enter twice.
      Second thing I found is that the tab-index still doesn't work for the full-gps screen and the 'avoid turn' button is not keyboard selectable.
      Btw. I thing it would be useful to have the 'avoid turn' button always accessible, not just with having the turns displayed.

      Besides this RC2 is fantastic, much better controllable by hotkeys

      Comment


      • #4
        Originally posted by predator1 View Post
        In some dialogs the key 'enter' somehow seems to be double-accepted, i.e. if you enter a address in gps and you press enter after choosing the city the next screen is the selection of the number instead of the street, hitting the right arrow after entering the city brings up the street dialog correctly. Same thing seems to happen in some setup screens, i.e. when choosing a radio device hitting enter cause the device list to close for a split-second and reopen instantly as if you have pressed enter twice.
        Second thing I found is that the tab-index still doesn't work for the full-gps screen and the 'avoid turn' button is not keyboard selectable.
        Btw. I thing it would be useful to have the 'avoid turn' button always accessible, not just with having the turns displayed.

        Besides this RC2 is fantastic, much better controllable by hotkeys
        Still working on the best way to take control form GPS, Web, and External applications... It would need to be some key that those did not use... It is on my list of known issues to look into..

        david
        __________________
        CENTRAFUSE http://www.centrafuse.com
        01 Jeep Cherokee Sport 4x4 Installed
        M10000/512Mb/20GB, Lilliput 7", Holux GM-210

        Comment


        • #5
          Space key and OSK button still does 2 presses too

          Getting setup error now, cannot load resource
          My Nissan 200SX @ Silverstone
          NOW SADLY WRITTEN OFF!

          My Car's spec list + pics

          Stealth CarPC fab'ing...

          Comment


          • #6
            Single-click functionality when on an artist/genre

            I enabled single-click functionality, which I like a lot, by the way, and when I was in the library, I clicked on 'Artist' then on the first artist in the list. I was then looking at a list of all the albums for that artist. Clicking 'Play' on the left hand side here added the entire library to the playlist, instead of just what I was currently seeing (the three albums by this particular artist).

            Similarly if I click 'Genre' at the top level and then click 'Classic Rock', I see a list of artists in this genre. Hitting play here I would assume all the artists (all their songs from all their albums) in the selected genre would get put on the now-playing playlist, but again the entire library gets added.

            With single-click on, is there some other way to add one entire artist (or one specific genre) to the playlist? This may have been discussed in detail elsewhere, but what about adding small buttons to the right of each line-item, one for 'add to queue' and one for 'play this choice now'? So when viewing a list of artists, there's a plus icon and a play icon right-justified next to the artist's name, so I can single-click to play now or add them to the current queue.

            Edit: Playing with it a bit more, it seems even more like a bug because if I go to the top of the library, select 'Genre' then 'Classic Rock', then pick an artist (so now I'm looking at a list of their albums) clicking 'Play' at this point DOES only queue up these albums. Not so for browsing by 'Artist', selecting the same artist (again so I'm looking at their albums only) and pressing 'Play' queues up the entire library.

            Comment


            • #7
              Originally posted by HTLuke View Post
              I enabled single-click functionality, which I like a lot, by the way, and when I was in the library, I clicked on 'Artist' then on the first artist in the list. I was then looking at a list of all the albums for that artist. Clicking 'Play' on the left hand side here added the entire library to the playlist, instead of just what I was currently seeing (the three albums by this particular artist).

              Similarly if I click 'Genre' at the top level and then click 'Classic Rock', I see a list of artists in this genre. Hitting play here I would assume all the artists (all their songs from all their albums) in the selected genre would get put on the now-playing playlist, but again the entire library gets added.

              With single-click on, is there some other way to add one entire artist (or one specific genre) to the playlist? This may have been discussed in detail elsewhere, but what about adding small buttons to the right of each line-item, one for 'add to queue' and one for 'play this choice now'? So when viewing a list of artists, there's a plus icon and a play icon right-justified next to the artist's name, so I can single-click to play now or add them to the current queue.

              This is the way it's suppose to work, I will look into the play now button to see if I can find the problem... If you go into one album does it play all the albums, or just that album?

              david
              __________________
              CENTRAFUSE http://www.centrafuse.com
              01 Jeep Cherokee Sport 4x4 Installed
              M10000/512Mb/20GB, Lilliput 7", Holux GM-210

              Comment


              • #8
                Right I have tested this in the car and I have noticed the following.

                1) Speed still does not show correctly
                2) I used the same maps with RC1 and RC2 yet in RC2 I had some postcodes missing from the search
                3) Problem as discussed in the above post. This actually stops you using that kind of search for an address if there are more instances of the first part of the address
                4) Activating single click seems to behave like you are doubleclicking. Ie go to settings and click on the down arrow and instead of showing item 1/18 then 7/18, 13/18 and 18/18 it goes straight to 18/18. I even had it where it was double clicking on increase volume and even clicking on the eye icon in nav it then automatically clicked on shows turns.
                5) Orient North and orient forward seemed to be the wrong way round. Clicking on orient forward changed the map to show North at the top.
                6) Pausing the music for gps directions is too long for some voice prompts. Ie When it says "Turn Left in ....." Music will be paused for up to 3-4 secs more. I suggest instead of pausing the music but to lower the music volume like FD does, or even add it as an option to choose which you prefer.
                7) Street Name does not show anymore in the box which shows speed.

                Due to the following and more so with the gps not showing all postcodes like RC1 does I have had to uninstall and reinstall RC1. Also I have reproduced these errors/bugs on both my desktop and carpc.

                Comment


                • #9
                  I got an error dialog pop up after I went through the phone control wizard and enabled phone control...I didn't have this problem in RC1

                  8/11/2006 2:43:17 PM
                  No connection could be made because the target machine actively refused it
                  at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
                  at PhoneControl.PhoCoInterface.Init(Int32 pi_iPort, String pi_sHost)
                  at phone.phone.buildControls()
                  ----------------------------------------------------------------------------------------------------------
                  8/11/2006 2:43:44 PM
                  Object reference not set to an instance of an object.
                  at PhoneControl.PhoCoInterface.Deinit()
                  at phone.phone.closePhone()
                  ----------------------------------------------------------------------------------------------------------
                  1) Another bug some have mentioned...single click will double click many things such as the up and down arrows in the media library, among other things.

                  2) web browser wont go to anything other than the default homepage. I tried opening links in my favorites, as well as typing www.yahoo.com in the address bar to no avail.

                  3) music doesnt resume when exiting TV (not sure if it should, but it does in most every other app) - Actually, the X doesnt close the TV app at all... it still shows TV in the top bar. I have to go to media to get music playing again.

                  Comment


                  • #10
                    Originally posted by sivart321 View Post
                    I got an error dialog pop up after I went through the phone control wizard and enabled phone control...I didn't have this problem in RC1



                    1) Another bug some have mentioned...single click will double click many things such as the up and down arrows in the media library, among other things.

                    2) web browser wont go to anything other than the default homepage. I tried opening links in my favorites, as well as typing www.yahoo.com in the address bar to no avail.

                    3) music doesnt resume when exiting TV (not sure if it should, but it does in most every other app) - Actually, the X doesnt close the TV app at all... it still shows TV in the top bar. I have to go to media to get music playing again.
                    Number 3 was actually by design, but probably not how it should be... TV is treated like an audio section, so when you go to the TV and then leave, the TV audio should still be coming through until you load another audio section...

                    I will look into making it more like DVD...

                    Not sure about the web browser, did it create an error.log file?

                    Do you have firewall turned on? For some reason it would not connect to the local Phone service... Did you see Phone control load and go into the system tray?

                    Your #1 is on my list of known issues...

                    david
                    __________________
                    CENTRAFUSE http://www.centrafuse.com
                    01 Jeep Cherokee Sport 4x4 Installed
                    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

                    Comment


                    • #11
                      Phone control would never load... it popped up a big error dialog and never loaded the tray icon.

                      here is the error log for the web browser problem. Strangely, it seems to work now. Not sure what the error means, but it didn't work before! :-/

                      8/11/2006 3:27:22 PM
                      Trying to revoke a drop target that has not been registered
                      at SHDocVw.WebBrowserClass.ExecWB(OLECMDID cmdID, OLECMDEXECOPT cmdexecopt, Object& pvaIn, Object& pvaOut)
                      at AxSHDocVw.AxWebBrowser.ExecWB(OLECMDID cmdID, OLECMDEXECOPT cmdexecopt, Object& pvaIn, Object& pvaOut)
                      at web.web.setTextSize()
                      ----------------------------------------------------------------------------------------------------------

                      Comment


                      • #12
                        Originally posted by sivart321 View Post
                        Phone control would never load... it popped up a big error dialog and never loaded the tray icon.

                        here is the error log for the web browser problem. Strangely, it seems to work now. Not sure what the error means, but it didn't work before! :-/
                        That error is when I set the font size in the browser... I will look into it...

                        david
                        __________________
                        CENTRAFUSE http://www.centrafuse.com
                        01 Jeep Cherokee Sport 4x4 Installed
                        M10000/512Mb/20GB, Lilliput 7", Holux GM-210

                        Comment


                        • #13
                          here is that phone control error... I spent an hour or so getting the serial conection to work properly, and then continued through the wizard...I end up with this as soon as I enable phone control.



                          here is the newest error.log file

                          8/11/2006 5:18:41 PM
                          No connection could be made because the target machine actively refused it
                          at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
                          at PhoneControl.PhoCoInterface.Init(Int32 pi_iPort, String pi_sHost)
                          at phone.phone.buildControls()
                          ----------------------------------------------------------------------------------------------------------
                          8/11/2006 5:19:40 PM
                          Object reference not set to an instance of an object.
                          at PhoneControl.PhoCoInterface.Deinit()
                          at phone.phone.closePhone()
                          ----------------------------------------------------------------------------------------------------------
                          8/11/2006 5:19:44 PM
                          Object reference not set to an instance of an object.
                          at PhoneControl.PhoCoInterface.Deinit()
                          at phone.phone.closePhone()
                          ----------------------------------------------------------------------------------------------------------

                          Comment


                          • #14
                            I realize that this is probably another "uninstall the previous version prior to installation deal" but when attempting to install RC2 over RC1, I get "Unable to install because a newer version of this product is already installed."

                            Oviously RC1 is not newer than RC2, so the message should probably tell me to uninstall the old version as opposed to telling me that it's newer.
                            Dr. Ron Paul for President 2008

                            Hope for America - http://www.ronpaul2008.com

                            Who is Ron Paul? - Why do we need Ron Paul?

                            __________________
                            CarPC Newbs Start Here: All your questions answered, as if by E.S.P.

                            Comment


                            • #15
                              I am getting the web browser issues again... this time I put the yahoo movie page into full screen and it split the screen horizontally, the top 2/3 with the movie page, and the bottom third with yahoo.com. It was very strange. From there, it went back to not going to any address you enter.

                              I should note this is on my car computer now. The original problem was on my laptop. Both are fully updated.



                              Another bug: I have noticed the skip button gets 'stuck' sometimes using either the touchscreen OR a mouse on my other computer. I have to press a different button to get it to 'release'.

                              Comment

                              Working...
                              X