Announcement

Collapse
No announcement yet.

Centrafuse RC4.2 Bugs

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Centrafuse RC4.2 Bugs

    Post all bugs found in RC4.2 here.

    Read the release notes for all the changes and additions in RC4.2

    Release Notes
    http://www.mp3car.com/vbulletin/showthread.php?t=90478

    First check to make your bug is not already known.

    Centrafuse Known Issues
    http://www.mp3car.com/vbulletin/showthread.php?t=80817


    Request features and additions in the main forum, not this thread.
    Make sure that we are not already planning on adding your requested feature or addition.

    Centrafuse Future Features
    http://www.mp3car.com/vbulletin/showthread.php?t=82652

    david
    __________________
    CENTRAFUSE http://www.centrafuse.com
    01 Jeep Cherokee Sport 4x4 Installed
    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

  • #2
    I hate to be the first person to post a bug. But the issue i had with Cf not correctly reading the tag info is still present. Its still detecting one album (but only a third of it) and detecting the rest as "unknown album". David, i was thinking. Can you make a little app that uses the same code base for reading the mp3 tags that can open a mp3 file and display all the readable info including album art. I think it would be usefull for not only me, but other people who have had issues with CF not reading tags correctly to see if its there files or not and for you; because if the app can read the mp3 files fine, then you know the issue is somewhere else in your app (maybe).
    We are, will have and forever will be...
    But not tommorrow!

    Comment


    • #3
      Theres nothing in your features list about CF being a silent install. After agreeing to the licence and clicking ok to install, the window disappears and it continues to install silently.

      Also the playlist eject and counter no longer works (for me anyway).
      <EDIT> After a restart of CF, the eject / counter seems to work if you had a list loaded. When ejecting, the timer is still displayed and the song continues to play.

      Theres no error log either.
      We are, will have and forever will be...
      But not tommorrow!

      Comment


      • #4
        Can you PAHLEEEZE fix this:
        --------------------------------------------------------------------------------------------------
        Known Satellite Radio Issues
        --------------------------------------------------------------------------------------------------
        1. hibernate from XM favorites screen, on resume loading shows up and hangs application
        You've been promising "XM updates in the next release" for a while now, and this single bug is a serious PITA.
        :: Mark

        Comment


        • #5
          With sork tracks disabled and read tag info disabled, after inserting a USB flash drive into the computer it loads the data (very quickly) and begins automatically playing it (not sure how to disable that?). Anyway, after going back into the HDD playlist and then returning to the USB media again, it says "No USB device found". I click it again, same message. One more time and it loads the music again, and displays the same thing, however, it now shows a count of 2 in the USB device. It starts playing the music on the drive, but the message is still there saying no USB device found!!

          I tried reinserting it, and the message stayed. It finally dissapeared a minute or two later (while I was typing this) and continued to play. Very strange.

          Also, the problem of USB CD/DVD drives still be recognized as USB devices is forcing me wait for the next version to even bother trying to install it into the car. The USB drive bug I noted above was experienced on my desktop PC.

          Comment


          • #6
            This one got missed when I last reported it, so here goes again...

            If you use the CLIK-HOLD feature to search a Band Name by LETTER, it does not match the first occurence if band name begins with 'THE'.

            So, I have:

            The Cars
            Counting Crows
            The Cranberries
            ...


            If I click Hold, and select letter 'C', it will hilite Counting Crows, instead of The Cars.
            2002 Honda CR-V
            Carputer progress: 90% [▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓▓ -]
            Spent so far: $1105.90


            Download the NEXUS Skin for Centrafuse
            ...or even Listen to my music

            Comment


            • #7
              New fun/old reoccurring fun:
              • If "Taskbar Off" set to ON (so CF suppresses the taskbar) then taskbar does not come back when CF exits

              • XM Favorites not being saved. 100% repro. This was not an issue in RC 4.1

              • Add (music/video) folders dialog broken. (possibly only with single click enabled) e.g. I want to add "c:\data\music",
                • Select Add Music Folder
                • Click "c:\"
                • Click "data"
                • Click "music"
                • Click "save"
                • Nothing happens
                Was also an issue in RC 4.1

              • Previously Reported - XM list entries have confused data elements. e.g. Channels "41" & 48" both reporting as "Bone Yard" (they're not); "41" reporting as class = "Christian" (it's "Rock"); title of track on 48 showing on 41; etc. Will clear (i.e., display will be correct) after one or two refresh cycles.

              • Previously Reported - clean boot after install gives multiple error.log entries of:
                11/25/2006 5:16:45 PM
                Font 'Century Gothic' doesn't support style 'Regular'.
                at System.Drawing.Font.Initialize(FontFamily family, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet, Boolean gdiVerticalFont)
                at System.Drawing.Font..ctor(String familyName, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet)
                at centrafuse.Plugins.CFPlugin.setlabelskin(String whichlbl, MouseEventHandler clickEvent, MouseEventHandler downEvent)
                This is NOT a skin issue. Skin files are correct, switching to "blue" skins does NOT clean the problem.

              • new error.log participant:
                11/25/2006 5:16:50 PM
                Object reference not set to an instance of an object.
                at centrafuse.main.clearBuffer(Boolean play)
                at centrafuse.satradio.tuneChannel(Int32 channel)
              • new error.log participant:
                11/25/2006 5:17:31 PM
                Object reference not set to an instance of an object.
                at centrafuse.main.mainExit()
              :: Mark

              Comment


              • #8
                More error log entries during the install...
                (7 of these)
                11/25/2006 4:51:00 PM
                Index was out of range. Must be non-negative and less than the size of the collection.
                Parameter name: index
                at System.Collections.ArrayList.get_Item(Int32 index)
                at centrafuse.Plugins.CFPlugin.CF_getText(String labelName)


                (20 of these)
                11/25/2006 4:51:04 PM
                Object reference not set to an instance of an object.
                at centrafuse.main.CF_localskinsetup()


                (2 of these)
                11/25/2006 4:54:58 PM
                Object reference not set to an instance of an object.
                at centrafuse.main.clearBuffer(Boolean play)
                at centrafuse.satradio.tuneChannel(Int32 channel)
                :: Mark

                Comment


                • #9
                  Originally posted by justintime View Post
                  This one got missed when I last reported it, so here goes again...

                  If you use tyhe LCIK-HOLD feature to search a Band Name by LETTER, it does not match the first occurence if band name begins with 'THE'.

                  So, I have:

                  The Cars
                  Counting Crows
                  The Cranberries
                  ...


                  If I click Hold, and select letter 'C', it will hilite Counting Crows, instead of The Cars.
                  forgot about this one, not a problem...

                  david
                  __________________
                  CENTRAFUSE http://www.centrafuse.com
                  01 Jeep Cherokee Sport 4x4 Installed
                  M10000/512Mb/20GB, Lilliput 7", Holux GM-210

                  Comment


                  • #10
                    Originally posted by midiwall View Post
                    New fun/old reoccurring fun:
                    • If "Taskbar Off" set to ON (so CF suppresses the taskbar) then taskbar does not come back when CF exits

                    • XM Favorites not being saved. 100% repro. This was not an issue in RC 4.1

                    • Add (music/video) folders dialog broken. (possibly only with single click enabled) e.g. I want to add "c:\data\music",
                      • Select Add Music Folder
                      • Click "c:\"
                      • Click "data"
                      • Click "music"
                      • Click "save"
                      • Nothing happens
                      Was also an issue in RC 4.1

                    • Previously Reported - XM list entries have confused data elements. e.g. Channels "41" & 48" both reporting as "Bone Yard" (they're not); "41" reporting as class = "Christian" (it's "Rock"); title of track on 48 showing on 41; etc. Will clear (i.e., display will be correct) after one or two refresh cycles.

                    • Previously Reported - clean boot after install gives multiple error.log entries of:
                      11/25/2006 5:16:45 PM
                      Font 'Century Gothic' doesn't support style 'Regular'.
                      at System.Drawing.Font.Initialize(FontFamily family, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet, Boolean gdiVerticalFont)
                      at System.Drawing.Font..ctor(String familyName, Single emSize, FontStyle style, GraphicsUnit unit, Byte gdiCharSet)
                      at centrafuse.Plugins.CFPlugin.setlabelskin(String whichlbl, MouseEventHandler clickEvent, MouseEventHandler downEvent)
                      This is NOT a skin issue. Skin files are correct, switching to "blue" skins does NOT clean the problem.

                    • new error.log participant:
                      11/25/2006 5:16:50 PM
                      Object reference not set to an instance of an object.
                      at centrafuse.main.clearBuffer(Boolean play)
                      at centrafuse.satradio.tuneChannel(Int32 channel)
                    • new error.log participant:
                      11/25/2006 5:17:31 PM
                      Object reference not set to an instance of an object.
                      at centrafuse.main.mainExit()
                    The taskbar comes back on all my test systems, I cannot reproduce this nor has it been reported by anyone else...

                    This sounds like a single click issues, I will get it fixed...

                    There are known XM issues, I have not done any XM programming in ahwhile... Since XM is a US only section, I am focusing on all other bugs first, which hopefully will not be many...

                    All your font problems are unique to your system. Does a single other person have this problem? This has never been reported nor can I reproduce... I have tried on three test machines... Something wrong with the fonts on your system possibly, not sure... This is the cause for all the errors in your post below as well, setting up the skin, getting text...

                    The clearbuffer error is another XM error, again I have not worked on it in some time... I will get back to it as soon as I can...

                    david
                    __________________
                    CENTRAFUSE http://www.centrafuse.com
                    01 Jeep Cherokee Sport 4x4 Installed
                    M10000/512Mb/20GB, Lilliput 7", Holux GM-210

                    Comment


                    • #11
                      Originally posted by AlienEclipse View Post
                      I hate to be the first person to post a bug. But the issue i had with Cf not correctly reading the tag info is still present. Its still detecting one album (but only a third of it) and detecting the rest as "unknown album". David, i was thinking. Can you make a little app that uses the same code base for reading the mp3 tags that can open a mp3 file and display all the readable info including album art. I think it would be usefull for not only me, but other people who have had issues with CF not reading tags correctly to see if its there files or not and for you; because if the app can read the mp3 files fine, then you know the issue is somewhere else in your app (maybe).
                      email one of the files that the tag are not reading from to [email protected] so we can try and figure out why they don't read...

                      david
                      __________________
                      CENTRAFUSE http://www.centrafuse.com
                      01 Jeep Cherokee Sport 4x4 Installed
                      M10000/512Mb/20GB, Lilliput 7", Holux GM-210

                      Comment


                      • #12
                        Go to Previous Section HotKey Still Missing

                        Voluem Contorols are very messy this time

                        Front in CF ---> Controls MAster Volume in Windows
                        Pre in CF---> Controls Wave Volume in Windows
                        Wave in CF---> Not Functioning

                        Set Logarthimic to On % Use Pre as Master Voluem and EQ will go mad and everythign will messed up !!

                        Click and Hold volume should go Faster.

                        Change skin while in NAV by Holding Dimming button for 2 or 3 times will crash Nav top Bar Layer, and sometime Changing Skin dialoug dosent show Correctly

                        thats it for now
                        We Exist because there is no patch for human Stupidity !!

                        We need you ALL Here !!

                        Comment


                        • #13
                          Got three issues in an otherwise perfectly running CF :
                          1. my skin is able to cause an exception dialog whereas usually error go in the error.log. The error pops up when I hit the mute button I've created. It only pops up when going from not muted to mute.

                          The error:
                          Code:
                          See the end of this message for details on invoking 
                          just-in-time (JIT) debugging instead of this dialog box.
                          
                          ************** Exception Text **************
                          System.ArgumentOutOfRangeException: Index was out of range.  Must be non-negative and less than the size of the collection.
                          Parameter name: index
                             at System.Collections.ArrayList.get_Item(Int32 index)
                             at centrafuse.tvslider.mainTimer_Tick(Object sender, EventArgs e)
                             at System.Windows.Forms.Timer.OnTick(EventArgs e)
                             at System.Windows.Forms.Timer.Callback(IntPtr hWnd, Int32 msg, IntPtr idEvent, IntPtr dwTime)
                          (full error dump available)
                          The button definition:
                          Code:
                          <MUTE>
                          	<X>0</X>
                          	<Y>704</Y>
                          	<WIDTH>128</WIDTH>
                          	<HEIGHT>64</HEIGHT>
                          	<FONTNAME>Century Gothic</FONTNAME>
                          	<FONTSIZE>14</FONTSIZE>
                          	<FONTSTYLE>Bold</FONTSTYLE>
                          	<FONTCOLOR>#F2EFD1</FONTCOLOR>
                          	<SECONDCOLOR>#000000</SECONDCOLOR>
                          	<XOFFSET>0</XOFFSET>
                          	<YOFFSET>0</YOFFSET>
                          	<ENABLETEXT>False</ENABLETEXT>
                          	<ALIGN>Center</ALIGN>
                          	<TABINDEX>4</TABINDEX>
                          </MUTE>
                          Which is the same as for example my Random button (except for it's location of course )

                          NB: after reloading CF, I haven't been able to reproduce this error...

                          2. Another error I caused, but might be handy to look into to prevent strange behaviour though human error/substandard skinning
                          Code:
                          26-11-2006 19:55:12
                          Value cannot be null.
                          Parameter name: image
                             at System.Drawing.Graphics.DrawImage(Image image, Int32 x, Int32 y)
                             at System.Drawing.Graphics.DrawImageUnscaled(Image image, Rectangle rect)
                             at centrafuse.cfbase.OnPaint(PaintEventArgs e)
                          ----------------------------------------------------------------------------------------------------------
                          Occur quite a lot, mainly because I've "disabled" some buttons and such in the skin I'm building... just to get them out of the way I've given them a width and height of 0.
                          Of course, that's something I've caused, but might be handy to build in a small check before just drawing these things?

                          3. Just a small one: when loading a list of mp3s with random mode on, it always starts at the first song in the list.
                          CarPC: "Carma" (Car Audio & Route Management) (about 70% ready)
                          P4 1.8GHz / 512MB / 4GB CF
                          Asus TVFM + B/W camera
                          15" touchscreen 1024x768
                          BU303
                          2x 100Ah
                          reinstalling

                          And all this in a Dutch 1972 CitroŽn HY van called "MurpHY".

                          Comment


                          • #14
                            Originally posted by bishooman View Post
                            Go to Previous Section HotKey Still Missing

                            Voluem Contorols are very messy this time

                            Front in CF ---> Controls MAster Volume in Windows
                            Pre in CF---> Controls Wave Volume in Windows
                            Wave in CF---> Not Functioning

                            Set Logarthimic to On % Use Pre as Master Voluem and EQ will go mad and everythign will messed up !!

                            Click and Hold volume should go Faster.

                            Change skin while in NAV by Holding Dimming button for 2 or 3 times will crash Nav top Bar Layer, and sometime Changing Skin dialoug dosent show Correctly

                            thats it for now
                            open hotkeys.xml, I added the hotkey just forgot to add it to the list in the GUI settings... you can use and change it from there and I will get it fixed...

                            looking into your mixer issues...

                            I agree, I will increase the volume speed as you hold it...

                            the NAV skin issue is listed under known issues... I keep having trouble reproducing it exactly, but I know about it....

                            david
                            __________________
                            CENTRAFUSE http://www.centrafuse.com
                            01 Jeep Cherokee Sport 4x4 Installed
                            M10000/512Mb/20GB, Lilliput 7", Holux GM-210

                            Comment


                            • #15
                              Originally posted by LEiPiE View Post
                              Got three issues in an otherwise perfectly running CF :
                              1. my skin is able to cause an exception dialog whereas usually error go in the error.log. The error pops up when I hit the mute button I've created. It only pops up when going from not muted to mute.

                              The error:
                              Code:
                              See the end of this message for details on invoking 
                              just-in-time (JIT) debugging instead of this dialog box.
                              
                              ************** Exception Text **************
                              System.ArgumentOutOfRangeException: Index was out of range.  Must be non-negative and less than the size of the collection.
                              Parameter name: index
                                 at System.Collections.ArrayList.get_Item(Int32 index)
                                 at centrafuse.tvslider.mainTimer_Tick(Object sender, EventArgs e)
                                 at System.Windows.Forms.Timer.OnTick(EventArgs e)
                                 at System.Windows.Forms.Timer.Callback(IntPtr hWnd, Int32 msg, IntPtr idEvent, IntPtr dwTime)
                              (full error dump available)
                              The button definition:
                              Code:
                              <MUTE>
                              	<X>0</X>
                              	<Y>704</Y>
                              	<WIDTH>128</WIDTH>
                              	<HEIGHT>64</HEIGHT>
                              	<FONTNAME>Century Gothic</FONTNAME>
                              	<FONTSIZE>14</FONTSIZE>
                              	<FONTSTYLE>Bold</FONTSTYLE>
                              	<FONTCOLOR>#F2EFD1</FONTCOLOR>
                              	<SECONDCOLOR>#000000</SECONDCOLOR>
                              	<XOFFSET>0</XOFFSET>
                              	<YOFFSET>0</YOFFSET>
                              	<ENABLETEXT>False</ENABLETEXT>
                              	<ALIGN>Center</ALIGN>
                              	<TABINDEX>4</TABINDEX>
                              </MUTE>
                              Which is the same as for example my Random button (except for it's location of course )

                              NB: after reloading CF, I haven't been able to reproduce this error...

                              2. Another error I caused, but might be handy to look into to prevent strange behaviour though human error/substandard skinning
                              Code:
                              26-11-2006 19:55:12
                              Value cannot be null.
                              Parameter name: image
                                 at System.Drawing.Graphics.DrawImage(Image image, Int32 x, Int32 y)
                                 at System.Drawing.Graphics.DrawImageUnscaled(Image image, Rectangle rect)
                                 at centrafuse.cfbase.OnPaint(PaintEventArgs e)
                              ----------------------------------------------------------------------------------------------------------
                              Occur quite a lot, mainly because I've "disabled" some buttons and such in the skin I'm building... just to get them out of the way I've given them a width and height of 0.
                              Of course, that's something I've caused, but might be handy to build in a small check before just drawing these things?

                              3. Just a small one: when loading a list of mp3s with random mode on, it always starts at the first song in the list.
                              I will get some error handling in their for these...

                              david
                              __________________
                              CENTRAFUSE http://www.centrafuse.com
                              01 Jeep Cherokee Sport 4x4 Installed
                              M10000/512Mb/20GB, Lilliput 7", Holux GM-210

                              Comment

                              Working...
                              X