Announcement

Collapse
No announcement yet.

Multi-Cam Sources

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Multi-Cam Sources

    I seem to have a problem having 3 different capture devices. When choosing the camera icon, a small box pops up and goes to background. If I minimize DL I see a blank box that is to choose a capture device (this is a microsoft box) when I pick my camera it error's out of DL. I will try and screen capture the error box and see if anything is in the error log. If I only have the camera plugged in it's no problem. It only happens if I have more than one device. 1 microsoft life cam, roxio video capture unit w/audio and a 4 in 1 dvr stick all have correct drivers and all function in windows. It takes the camera in settings in DL no problem and saves it. Hope you can figure this one out. SNO

  • #2
    You have a conflict between the webcams but where ? I suppose that each webcam use the same Id and it's not very good !!!

    Comment


    • #3
      Only 1 webcam so it's not a naming problem, and all products work together in a straight windows enviroment. It's only in DL is where the problem is. It seems to only expect 1 device. SNO

      Comment


      • #4
        Seems there was a posting about this sort of thing elsewhere. That DL and some other FE's are hard coded to run 1 camera. I don't know that the makers of the plugins figure there could be more than one camera hooked up and this may require some code changes to the plugin.

        Comment


        • #5
          I'm not using dashcam only camera app. In setup I choose the lifecam and it accepts it. It's something to do with windows and DL as it's a windows box that pop's up and ask's for me to choose my device, which all 3 are there when i select lifecam it hards out of DL. SNO

          Comment


          • #6
            I should add this is the only problem I am having. TPMS/OBD2/Weather/Phidgets, ect are all working flawlessly. And if I unplug the 4 in 1 dvr and the roxio capture device, the lifecam works flawlessly as well using the camera app. SNO

            Comment


            • #7
              DriveLine uses some very old windows API to connect to the video-capture device(s). Whether it's a webcam or tuner, they are all abstracted through the windows avicap32 API.

              Now, if I wanted to do things right, I'd probably use DirectX. It's just a lot more complication that I haven't taken the time to learn. Now that there's a need, I will look into it. I've been meaning to do this anyway. There's also a windows component called WIA (Windows Image Acquisition) that I will look at.

              Unfortunately, I don't see any easy temporary fix on my end. I'll look into it a bit this weekend.

              Comment


              • #8
                Coming soon to next release Driveline now supports upto 5 cameras and they can be the same make and model, very nice! SNO
                Click image for larger version

Name:	cameras_sm.jpg
Views:	1
Size:	41.5 KB
ID:	2285596
                sorry for the crappy image, just using built-in cam on tablet. I will post another using the lifecam HD shortly.

                Comment


                • #9
                  Hi guys, I want to connect a front camera in the lower grill next to the license plate, so I can see tall curbs when parking.



                  As you can see the grill slots are about an inch apart, and I know I can find camera's that fit, however I want to use them in Driveline, so I can just press the camera button on the main page real quick, and don't know the best way to go.

                  Should I use a webcam, or a backup camera and some kind of video capture device, and if so what would you recommend?

                  I scratched my splitter by going in to a parking spot too far, so I want to use a camera instead of proximity beepers.

                  Thank,
                  Robert

                  Comment


                  • #10
                    This is what I use with Driveline works fine. http://www.roxio.com/enu/products/ea.../overview.html I only use it for 1 camera with rca type plug the other cams I use are usb but all work fine in Driveline together. It's a little expensive but it is quality driver and capture chip. You might find a deal on it somewhere. On a side note I also have a cheap 4 rca in to 1 usb capture device and driveline see's it but only for 1 camera and no way to cycle through, basically don't waste your time with that. SNO

                    Comment


                    • #11
                      That's what I was thinking was go with a composite to USB capture and use a backup camera case thy are waterproof, where a webcam would be too big and not built for the exterior of a car.

                      Is there any frame rate issues or does the Roxio seem to stream smooth?

                      Comment


                      • #12
                        Very smooth, I can switch around from lifecam on usb to roxio cam and no slowdown at all in driveline. Just make sure you get a front facing non mirrored camera. Using the roxio or another capture device you really have no control over mirroring or any other camera controls. You might also try and find the earlier version of that product, same dongle just older version of the software thats not needed really. It might be cheaper or in a bargin bin. SNO

                        Comment


                        • #13
                          I tried one of those cheap EZ-cap devices, and although it works great with it's own software, the driver it installel wont work with Dirveline. It calls the device "oemcapture" and when you select that in the Driveline settings screen, any audio playing starts to dropout until you select no device again.

                          Trying to get a Roxio off ebay for cheap, but no luck so far.

                          Comment


                          • #14
                            I'm not familiar with that particular capture device, but googling a little bit turns up very little, other than some bad reviews and some Chinese websites. If the "dashcam" setting in DriveLine is turned on, try disabling it and see if that helps. That will help determine if the issue is with the camera's video, or with the dashcam functions that grab still images.

                            Comment


                            • #15
                              I'll check it out thanks. I'll look for dashcam settings. I have a really nice forward facing camera mounted lo so I can see curbs when parking, but it is composite video, so I am forced to use a capture device, and the EZCap is $8 but Roxio come in at $50-70 range so I had to try it.

                              Sent from my SCH-I535 using Tapatalk

                              Comment

                              Working...
                              X