Announcement

Collapse
No announcement yet.

Startup/shutdown question

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Startup/shutdown question

    Can someone tell me how to stop driveline muting/dropping my desktop volume level to its lowest level when starting up, as it doesnt return to the proper level when you close driveline again and you have to manually adjust it back by opening the volume icon on the desktop taskbar

  • #2
    I could change the program so it checks the volume settings when it starts, and then restores those settings when the program closes.

    However, before I change anything, I want to understand the problem a little better, since I don't think I've heard of this happening before.

    What OS are you on?
    Can you open up the settings file DriveLine_Settings.XML, search for WAVEOUTVOLUMEMUTE, and let me know if it's set to True or False. It sounds like maybe this somehow got set to TRUE. Like, if you muted the wave-out volume through the Pandora screen this could possibly happen.

    edit: one more question -- you are referring to the Speakers volume, right?
    Last edited by ClockWorK; 07-06-2013, 06:06 PM.

    Comment


    • #3
      I was playing with the newest version today, and noticed my volume starts low and goes up over several seconds by itself. I actually like that feature because I listen loud, and get shocked every morning when I get blasted. Now i have some response time.

      Comment


      • #4
        rray, that new feature was added as a solution to your suggestion for not blowing the wife's eardrums out when the music starts.

        That shouldn't have any affect on the Windows volume though.

        Comment


        • #5
          OK, so I checked the settings XML before and after opening driveline. The waveoutvolumemute is always set to false.

          And yes, I am referring to the windows speaker volume controlled by the little speaker icon on the desktop taskbar

          PS. I am using windows XP

          Comment


          • #6
            OK, so I checked the driveline settings XML before and after opening driveline. The waveoutvolumemute is always set to false.

            And yes, I am referring to the main windows speaker volume controlled by the little speaker icon in the corner of the windows desktop taskbar.

            PS. I am using windows XP

            Comment


            • #7
              Is the volume actually being muted, or set to zero, or somewhere in the middle (like 50%) ?

              EDIT:
              Here's a thought. DriveLine does set audio source for Radios to zero on exit. So, go into the DriveLine settings screen, scroll down to Radios, and for each radio type, check the "PC Audio Input Line" to make sure none of them are set to your speakers / output line.
              Last edited by ClockWorK; 07-07-2013, 05:23 PM.

              Comment


              • #8
                The volume is being set to zero. I will check the radio settings and let you know

                Comment


                • #9
                  Ahh, I just thought of something to check. You might check the windows "playback device" and see if you have more than one. When you boot back up, right click on the windows speaker icon with the red X and look for the playback devices, then right click "Disable" all but the playback device you want, just in case it is picking something else a default upon re-boot.

                  On my system, in the beginning it did this trying to use the onboard speaker out, but I had installed a USB Audio DAC connected to my audio system, so I had to disable the onboard before it would default to DAC. Just something to check.

                  Comment


                  • #10
                    OK, so I checked the radio settings and this is what I have:

                    - <RADIO_XM>
                    <PortCOMM>0</PortCOMM>
                    <PortBaud>0</PortBaud>
                    <AudioInput />
                    <AudioMute>True</AudioMute>
                    <AudioVolume>66</AudioVolume>
                    <StationNum>0</StationNum>
                    <Preset1>0</Preset1>
                    <Preset2>0</Preset2>
                    <Preset3>0</Preset3>
                    <Preset4>0</Preset4>
                    <Preset5>0</Preset5>
                    <Preset6>0</Preset6>
                    </RADIO_XM>
                    - <RADIO_HD>
                    <PortCOMM>0</PortCOMM>
                    <PortBaud>0</PortBaud>
                    <AudioInput />
                    <AudioMute>True</AudioMute>
                    <AudioVolume>66</AudioVolume>
                    <StationNum>0</StationNum>
                    <StationBand />
                    <Preset1>0</Preset1>
                    <Preset2>0</Preset2>
                    <Preset3>0</Preset3>
                    <Preset4>0</Preset4>
                    <Preset5>0</Preset5>
                    <Preset6>0</Preset6>
                    </RADIO_HD>
                    - <RADIO_DAB>
                    <PortCOMM>0</PortCOMM>
                    <AudioInput />
                    <AudioMute>True</AudioMute>
                    <AudioVolume>66</AudioVolume>
                    <StationNum>101.1</StationNum>
                    <Preset1>0</Preset1>
                    <Preset2>0</Preset2>
                    <Preset3>0</Preset3>
                    <Preset4>0</Preset4>
                    <Preset5>0</Preset5>
                    <Preset6>0</Preset6>
                    </RADIO_DAB>

                    Comment


                    • #11
                      I'm out of town on vacation for a couple of days, but I will try to figure out what might be causing your issue.

                      Comment


                      • #12
                        SNO, are you able to reproduce this issue on your WinXP box? i wont be able to test until Thursday.

                        Comment


                        • #13
                          I can try and reproduce volume zero'ing out. I think this happened to me awhile ago, gotta think what I did SNO

                          Comment


                          • #14
                            Well I have tried and I can't seem to get it to zero out. I am at a loss for what to do next. Do you have any radio's installed? On board sound card or USB? SNO

                            Comment


                            • #15
                              No radios installed. I am using an onboard soundcard. There are no additional soundcards installed in the pc.

                              Comment

                              Working...
                              X