No announcement yet.

Still can't keep Freeway running..

  • Filter
  • Time
  • Show
Clear All
new posts

  • Still can't keep Freeway running..

    Im still experiencing that pesky error, freeway ultra (latest build) just seems to crash for no reason. Am I the only one with this problem? Ive tried with a load of different hardware configs, os installations etc. Win XP Pro (English) sp2, .net 2.0, all fonts installed and latest mplayer.
    I downloaded the windows debugging tools today, and attached it to the process. Maybe this can help you out.

    ## Attatching the debugger to the process..

    *** wait with pending attach
    Symbol search path is: *** Invalid ***
    ************************************************** **************************
    * Symbol loading may be unreliable without a symbol search path. *
    * Use .symfix to have the debugger choose a symbol path. *
    * After setting your symbol path, use .reload to refresh symbol locations. *
    ************************************************** **************************
    Executable search path is:
    ModLoad: 00400000 0041a000 D:\free\FreewayUltra.exe
    ModLoad: 7c900000 7c9b0000 C:\WINDOWS\system32\ntdll.dll
    ModLoad: 79000000 79045000 C:\WINDOWS\system32\mscoree.dll
    ModLoad: 7c800000 7c8f4000 C:\WINDOWS\system32\KERNEL32.dll
    ModLoad: 77dd0000 77e6b000 C:\WINDOWS\system32\ADVAPI32.dll
    ModLoad: 77e70000 77f01000 C:\WINDOWS\system32\RPCRT4.dll
    ModLoad: 77f60000 77fd6000 C:\WINDOWS\system32\SHLWAPI.dll
    ModLoad: 77c10000 77c68000 C:\WINDOWS\system32\msvcrt.dll
    ModLoad: 77f10000 77f56000 C:\WINDOWS\system32\GDI32.dll
    ModLoad: 77d40000 77dd0000 C:\WINDOWS\system32\USER32.dll
    ModLoad: 79e70000 7a3d1000 C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\msco rwks.dll
    ModLoad: 78130000 781cb000 C:\WINDOWS\WinSxS\x86_Microsoft.VC80.CRT_1fc8b3b9a 1e18e3b_8.0.50727.42_x-ww_0de06acd\MSVCR80.dll
    ModLoad: 7c9c0000 7d1d4000 C:\WINDOWS\system32\shell32.dll
    ModLoad: 773d0000 774d2000 C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.2180_x-ww_a84f1ff9\comctl32.dll
    ModLoad: 5d090000 5d127000 C:\WINDOWS\system32\comctl32.dll
    ModLoad: 790c0000 79ba6000 C:\WINDOWS\assembly\NativeImages_v2.0.50727_32\msc orlib\5823b68a72536347a0701b4e92920e26\ .dll
    ModLoad: 774e0000 7761c000 C:\WINDOWS\system32\ole32.dll
    ModLoad: 7a440000 7abfe000 C:\WINDOWS\assembly\NativeImages_v2.0.50727_32\Sys tem\a91863e469f1ec4c80ae3bdf286934ae\
    ModLoad: 7ade0000 7af74000 C:\WINDOWS\assembly\NativeImages_v2.0.50727_32\Sys tem.Drawing\39592d8cac48a441bbbf32f5e95ee2f8\Syste
    ModLoad: 7afd0000 7bc56000 C:\WINDOWS\assembly\NativeImages_v2.0.50727_32\Sys tem.Windows.Forms\8cbbf5e9cfccb14db7a8a5b74aa545cd \
    ModLoad: 79060000 790b3000 C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\msco rjit.dll
    ModLoad: 77b40000 77b62000 C:\WINDOWS\system32\Apphelp.dll
    ModLoad: 69be0000 6a148000 C:\WINDOWS\assembly\NativeImages_v2.0.50727_32\Sys tem.Xml\b9ef2e5aa9ea5745af12629edcb32870\System.Xm
    ModLoad: 01100000 0110a000 D:\free\AxInterop.ShockwaveFlashObjects.dll
    ModLoad: 4ec50000 4edf3000 C:\WINDOWS\WinSxS\x86_Microsoft.Windows.GdiPlus_65 95b64144ccf1df_1.0.2600.2180_x-ww_522f9f82\gdiplus.dll
    ModLoad: 73bc0000 73bc6000 C:\WINDOWS\system32\dciman32.dll
    ModLoad: 64890000 6497e000 C:\WINDOWS\assembly\NativeImages_v2.0.50727_32\Sys tem.Configuration\01b6948007c1dd47babd1abe6dbe6dd0 \
    (328.344): Break instruction exception - code 80000003 (first chance)
    eax=7ffdc000 ebx=00000001 ecx=00000002 edx=00000003 esi=00000004 edi=00000005
    eip=7c901230 esp=0344ffcc ebp=0344fff4 iopl=0 nv up ei pl zr na pe nc
    cs=001b ss=0023 ds=0023 es=0023 fs=0038 gs=0000 efl=00000246
    *** ERROR: Symbol file could not be found. Defaulted to export symbols for C:\WINDOWS\system32\ntdll.dll -
    7c901230 cc int 3

    ## Debugger attached. Up till this point, freeway has just loaded, no buttons have been pushed.
    ## Debugger has paused freeway. I need to press go..
    0:009> g
    (328.2c4): CLR exception - code e0434f4d (first chance)

    ## now, I go to music -> library, pick the song and it starts loading it..
    ModLoad: 771b0000 77256000 C:\WINDOWS\system32\wininet.dll
    ModLoad: 77a80000 77b14000 C:\WINDOWS\system32\CRYPT32.dll
    ModLoad: 77b20000 77b32000 C:\WINDOWS\system32\MSASN1.dll
    ModLoad: 77120000 771ac000 C:\WINDOWS\system32\OLEAUT32.dll
    ModLoad: 77fe0000 77ff1000 C:\WINDOWS\system32\Secur32.dll
    ModLoad: 77260000 772fc000 C:\WINDOWS\system32\urlmon.dll
    ModLoad: 77c00000 77c08000 C:\WINDOWS\system32\VERSION.dll
    ModLoad: 76ee0000 76f1c000 C:\WINDOWS\system32\RASAPI32.DLL
    ModLoad: 76e90000 76ea2000 C:\WINDOWS\system32\rasman.dll
    ModLoad: 71ab0000 71ac7000 C:\WINDOWS\system32\WS2_32.dll
    ModLoad: 71aa0000 71aa8000 C:\WINDOWS\system32\WS2HELP.dll
    ModLoad: 5b860000 5b8b4000 C:\WINDOWS\system32\NETAPI32.dll
    ModLoad: 76eb0000 76edf000 C:\WINDOWS\system32\TAPI32.dll
    ModLoad: 76e80000 76e8e000 C:\WINDOWS\system32\rtutils.dll
    ModLoad: 76b40000 76b6d000 C:\WINDOWS\system32\WINMM.dll
    ModLoad: 769c0000 76a73000 C:\WINDOWS\system32\USERENV.dll
    ModLoad: 71a50000 71a8f000 C:\WINDOWS\system32\mswsock.dll
    ModLoad: 662b0000 66308000 C:\WINDOWS\system32\hnetcfg.dll
    ModLoad: 71a90000 71a98000 C:\WINDOWS\System32\wshtcpip.dll
    ModLoad: 4d4f0000 4d548000 C:\WINDOWS\system32\winhttp.dll
    ModLoad: 76d60000 76d79000 C:\WINDOWS\system32\IPHLPAPI.DLL
    ModLoad: 76d80000 76d9e000 C:\WINDOWS\system32\DHCPCSVC.DLL
    ModLoad: 76f20000 76f47000 C:\WINDOWS\system32\DNSAPI.dll
    ModLoad: 76fb0000 76fb8000 C:\WINDOWS\System32\winrnr.dll
    ModLoad: 76f60000 76f8c000 C:\WINDOWS\system32\WLDAP32.dl

    ## Music started playing. And it continues so for a little while..
    ## This is approx. 14 seconds after mplayer started playing the mp3
    ## for no apparent reason, it throws this
    (328.304): CLR exception - code e0434f4d (first chance)
    (328.304): CLR exception - code e0434f4d (first chance)
    (328.304): CLR exception - code e0434f4d (!!! second chance !!!)
    eax=097df528 ebx=00185cf8 ecx=00000000 edx=00000025 esi=097df5b4 edi=e0434f4d
    eip=7c81eb33 esp=097df524 ebp=097df578 iopl=0 nv up ei pl nz na po nc
    cs=001b ss=0023 ds=0023 es=0023 fs=003b gs=0000 efl=00000202
    *** ERROR: Symbol file could not be found. Defaulted to export symbols for C:\WINDOWS\system32\KERNEL32.dll -
    7c81eb33 5e pop esi

    Please.. any idea what happens? the time (14 seconds) seems semi-random. on this song, it crashes after 14-20 seconds.
    on another song, it crashes instantly. on a third song, it may take 10 seconds..


  • #2
    (I'm sure Oeri can answer better than me, but I'll try)

    The only errors I have been getting lately are when the program closes, so no big deal. I have had crashes before dealing with album art, could that be? I know freeway behaves differently if there is a good connection vs. no connection vs. good connection but freeway is blocked by a firewall. Don't know if that is at all related to your problem...
    GoogleMapsGuidance Beta1 is out!


    • #3
      Unfortuneately, that is all "good". 100Mbit cabled lan, no firewalls active. I must be missing something really basic here. please confirm my set-up:

      windows xp, fresh install + hardware drivers
      .net 2.0
      mplayerc in freeway subdir
      freeway fonts -> windows subdir
      add directories to the ini file (music, video, pictures)

      anything..? should the .net package be the SDK? does the filesystem need to be FAT? should i just go watch paint dry instead?



      • #4
        it sounds like everything should be working fine, very odd. if you want, zip the freeway directory and send it to me or upload it here ( and send me the link. ill look at it on one of my systems that dont have freeway or .net and see if i can reproduce similar errors
        FocusPC Stat:
        [~~~~~~~~~-] 95% Done
        FreeICE | FreeWay | iGuidance | Paper and pencil

        FreeWay Skins


        • #5
          Thanks a lot

          uploaded it here:

          i've tried with .net 1, 2 and 3, installed in all sorts of different orders, media players from 6.4-11 installed and uninstalled, with and without winamp, filetype associations and whatnot.. running out of ideas here.

          Hope you can think of something i've missed!



          • #6
            i tested your file and everything works fine, no crashing. i installed XP and installed .net framework 2.0. is freeway only crashing while trying to play music or is it crashing during other operations? if its just during music playback, it could be the mp3 tags, sometimes when they have symbols or irregular characters in them they cause freeway to crash. hopefully thats the problem because i cant think of anything else, and oeri hasnt been around in awhile so idk when we'll get a response from him
            FocusPC Stat:
            [~~~~~~~~~-] 95% Done
            FreeICE | FreeWay | iGuidance | Paper and pencil

            FreeWay Skins


            • #7
              ok.. well im sure oeri has enough on his plate. isnt he going to college?

              anyways, no its not just mp3's.. video crashes almost immediately. sometimes it lasts for about 5 seconds. and i've tried different tags in the mp3's (no tags, id3v1, v2, english charaters only and so on..)

              thanks for trying it for me though. just wish i knew why this is happening...

              just a thought.. you think input locale or keyboard type could have anything to do with it? location setting? seems weird, but..

              i think it might have something to do with internet connectivity. is there any way to disable all internet-related calls?


              • #8
                i disconnected my machine from the internet and tried again. everything worked fine but the only thing different that happened was a 2 second pause before the load of each song but played fine. which is expected to happen because the program is going through and checking for an internet connection to download album art.

                had no problems with the video(with or without internet connection)

                the keyboard type should not matter seeing the program was built to run on a touchscreen, im actually running it in my car without a keyboard

                there might be some settings in WinXP that could be causing the issue but id have no clue where to even start there

                yah last i heard oeri was going to college, it should only be another month or two and classes should be done until the fall though
                FocusPC Stat:
                [~~~~~~~~~-] 95% Done
                FreeICE | FreeWay | iGuidance | Paper and pencil

                FreeWay Skins


                • #9
                  i found the problem!!

                  try going to "regional and language options" under control panel, and select Norwegian (bokmal) from the standards and formats drop-down list.

                  now run freeway.....

                  Oeri: when (if) you read this, it's worth writing in some readme-file, so other foreigners like myself wont have to spend weeks figuring this out..

                  Thanks a bunch for all your time and comments MadDash


                  • #10
                    yah i tried changing the language and freeway crashed after a couple seconds.
                    wow thats all it was the whole time, glad you figured it out
                    FocusPC Stat:
                    [~~~~~~~~~-] 95% Done
                    FreeICE | FreeWay | iGuidance | Paper and pencil

                    FreeWay Skins