Announcement

Collapse
No announcement yet.

still having problems with mplayer

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • still having problems with mplayer

    Hi oeri, and kudos for nice frontend
    however, im still having the same problem as i had in alpha 0.1.. whenever i try to play an mp3, it seems to have problems loading or something, plays up to 2 seconds (no sound, just the counter increasing.)

    when i play a video, freeway crashes, every time. well, atleast, windows claims it does, although its fully funtional behind the error msg.
    does not integrate at first. full-screening the video, then down again, then it integrates.

    it appears after browsing the forum that i am the only one with theese problems.. cant figure out why though, as i get the same results on all the computers ive tried, xp pro, english and norwegian..

    hope you have some clues for me as to what is wrong

  • #2
    You'r not alone... I've been having it all the time! Been writing about it a few times? Afaik other have this issue also...
    My carputer

    Old one

    Comment


    • #3
      Can you play files with mplayer standalone?

      You guys know any C#?
      Offical Freeway Subforum
      Official Freeway Website

      Comment


      • #4
        ive actually never had the audio problem or the crashing while trying to play a video but i have noticed with build 219 that the video screen does not integrate at first like PipPip said.
        FocusPC Stat:
        [~~~~~~~~~-] 95% Done
        FreeICE | FreeWay | iGuidance | Paper and pencil

        FocusPC
        FreeWay Skins

        Comment


        • #5
          launched mplayer from dos prompt with filename as only parameter, plays smooth as a babys behind.

          i dont know much, if any, c# but i have some experience with vb, java, (+script) so i think i could get the hang of it pretty quickly if i tried...

          EDIT: just tried it on a second comp, fresh windows install. here freeway just closes down when i try to play video/music. seems to count to two seconds like on my carpc before it disappears though.
          mplayer remains open and has to be terminated via task manager.

          EDIT 2: This has something to do with file assosiations. errors as described above when winamp is set to handle .mp3.
          when i remove all assosiations for .mp3, the song plays, but freeway crashes in the same fashion as when i play videos.
          when i assosiate .mp3 with mplayer, i get 2 sec counter, then the following error from .net 2.0:
          System.InvalidOperationException: Object is currently in use elsewhere.

          Hope this helps!

          Comment


          • #6
            Post the detailed error logs.
            Offical Freeway Subforum
            Official Freeway Website

            Comment


            • #7
              now it appears i get the error from .net 2.0 even if filetype is assosiated with winamp. maybe thats a step forward..

              anyways, first i get error from windows (see screenshot) then if i leave it playing (it actually plays music now, please dont ask me why) the this come from JIT:
              ************** Exception Text **************
              System.InvalidOperationException: Object is currently in use elsewhere.
              at System.Drawing.Graphics.CheckErrorStatus(Int32 status)
              at System.Drawing.Graphics.DrawString(String s, Font font, Brush brush, RectangleF layoutRectangle, StringFormat format)
              at System.Drawing.Graphics.DrawString(String s, Font font, Brush brush, Single x, Single y)
              at FreewayUltra.frmSkin.PrintLabel(ObjectInfo lbl, Int32 offset, Boolean eraseLabel, Boolean wrap)
              at FreewayUltra.frmSkin.PrintLabel(ObjectInfo lbl, Int32 offset, Boolean wrap)
              at FreewayUltra.frmSkin.PrintLabel(String lblType, String name, String what, Int32 offset, Boolean wrap)
              at FreewayUltra.frmSkin.PrintLabel(String lblType, String name, String what)
              at FreewayUltra.frmSkin.timer1_Tick(Object sender, EventArgs e)
              at System.Windows.Forms.Timer.OnTick(EventArgs e)
              at System.Windows.Forms.Timer.TimerNativeWindow.WndPr oc(Message& m)
              at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


              ************** Loaded Assemblies **************
              mscorlib
              Assembly Version: 2.0.0.0
              Win32 Version: 2.0.50727.42 (RTM.050727-4200)
              CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
              ----------------------------------------
              FreewayUltra
              Assembly Version: 1.0.0.0
              Win32 Version: 1.0.0.0
              CodeBase: file:///C:/Documents%20and%20Settings/Bruker/Skrivebord/freeway/FreewayUltra.exe
              ----------------------------------------
              System.Windows.Forms
              Assembly Version: 2.0.0.0
              Win32 Version: 2.0.50727.42 (RTM.050727-4200)
              CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
              ----------------------------------------
              System
              Assembly Version: 2.0.0.0
              Win32 Version: 2.0.50727.42 (RTM.050727-4200)
              CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
              ----------------------------------------
              System.Drawing
              Assembly Version: 2.0.0.0
              Win32 Version: 2.0.50727.42 (RTM.050727-4200)
              CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
              ----------------------------------------
              System.Xml
              Assembly Version: 2.0.0.0
              Win32 Version: 2.0.50727.42 (RTM.050727-4200)
              CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
              ----------------------------------------
              AxInterop.ShockwaveFlashObjects
              Assembly Version: 1.0.0.0
              Win32 Version: 1.0.0.0
              CodeBase: file:///C:/Documents%20and%20Settings/Bruker/Skrivebord/freeway/AxInterop.ShockwaveFlashObjects.DLL
              ----------------------------------------
              System.Configuration
              Assembly Version: 2.0.0.0
              Win32 Version: 2.0.50727.42 (RTM.050727-4200)
              CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
              ----------------------------------------

              ************** JIT Debugging **************
              To enable just-in-time (JIT) debugging, the .config file for this
              application or computer (machine.config) must have the
              jitDebugging value set in the system.windows.forms section.
              The application must also be compiled with debugging
              enabled.

              For example:

              <configuration>
              <system.windows.forms jitDebugging="true" />
              </configuration>

              When JIT debugging is enabled, any unhandled exception
              will be sent to the JIT debugger registered on the computer
              rather than be handled by this dialog box.
              Attached Files

              Comment


              • #8
                absolutely no idea why this happens, oeri?

                Comment

                Working...
                X