Announcement

Collapse
No announcement yet.

PLEA: to allow radio mute to set volume to 0 instead

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PLEA: to allow radio mute to set volume to 0 instead

    Hi peeps,

    just having a TERRIBLE time tying to get frodoplaya going with my new soundcard .

    I LOVE frodoplay... (props to you mate.. amazing and selfless work )

    the problem I have is that my soundcard is considered professional.. and therefore the MUTE on windows mixer does not actually mute the input..(the card has a special sound control panel - not the windows one ), so when FP mutes the linein... nothing happens on the card

    My plea is therefore to have frodo player be able to set the "Mic" volume to ZERO when FM radio is off, and turn it back up (to about 85.. or something I can set) when the radio comes back on...

    [It doesnt recognise LINEIN at all.. only MIC :S]

    Otherwise I get all this noise from the FM tuner on the line in.. cause the mute doesnt work.

    Hopefully frodo reads this, or anyone else who could point me in the right direction..(Id rather help myself.. but I've spend countless hours.. and have come to the conclusion that the terrible card drivers simply wont let me solve this without Frodo's help)

    Thanks for your time, and for reading this.
    Ice

    EDIT: I know this method works, because I used Frodo's 'SetVolume' and 'GetVolume' to test it. I just need a way of making it 'set' automatically on FM startup/shutdown.

    EDIT2: Perhaps the easiest method is by adding a "run command on startup:" and "run command on shutdown:" field with tick boxes to the FM settings page, and then I can just put in "setvolume.exe -mic 90" and "setvolume.exe -mic 0"

  • #2
    look for Matchvol.exe someone updated Frodo's code so that you can match line-in and mic-in as well as wave etc as you wish

    so basically you can link up line-in and mic-in and then when you turn line-in down to zero... mic-in will also be at zero...
    Pentium 4m 1.5GHz|MB896|Roadie Extreme|XM-Direct|Rikaline 6010|T-View 7"|Streetdeck|160gb Western Digital|1Gb DDR2-533 Ram

    Comment


    • #3
      Thanks for the tip.. But unfortunately because FP MUTES the line (rather than reducing volume to 0) it still will not work .

      The trouble is that whilst the volume sliders are linked between each control panel (windows mixer, and the Audiotrak prodigy), the MUTE buttons themselves dont seem to link... only the special drivers control panel mute button works.

      Comment


      • #4
        well that kinda sucks...

        ask whoever updated the code to make it link the mute as well
        Pentium 4m 1.5GHz|MB896|Roadie Extreme|XM-Direct|Rikaline 6010|T-View 7"|Streetdeck|160gb Western Digital|1Gb DDR2-533 Ram

        Comment


        • #5
          I wish!...

          I've contacted the company, but looking on their (tiny and useless) forum, it seems that ignoring customer feedback/request/complaints is commonplace
          .

          Its a simple thing to do, and it would fix HEAPS of problems, but if they CBF doing it... thats another question...I can't see ANY reasons not to fix this. Its not like there are ANY detremental effects, just the results of some lazy conceptualization when they wrote the code, and forgot to link the MUTE's.

          Comment


          • #6
            I actually meant whoever updated the matchvol.exe program... I figured there would be no way you could get a updated driver from the 'man'
            Pentium 4m 1.5GHz|MB896|Roadie Extreme|XM-Direct|Rikaline 6010|T-View 7"|Streetdeck|160gb Western Digital|1Gb DDR2-533 Ram

            Comment


            • #7
              ahh.. gotcha.. ill look into that.. thanks

              Comment

              Working...
              X