Announcement

Collapse
No announcement yet.

LAUNCH_ no sound hardware Prevents System Shutdown

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • LAUNCH_ no sound hardware Prevents System Shutdown

    I've recently been having intermittent problems with my USB devices where once or twice a week XP fails to detect any of them at boot. I use USB sound and touch screen so this means I have no sound and no input devices when this happens. When FP starts up, it will pop up a dialogue (with a German error message -- something about the mixer control) to complain about the missing sound hardware. I have an ignition override switch that I can throw to force my Opus/Windows to shutdown.

    The problem is that Windows can't shutdown because FP will not exit while the error dialogue is being displayed. Since none of my USB devices are working, I have no way to dismiss it. This forces me to either wait for the Opus to detect a failed shutdown (seemlingly this can take 15 or more minute) or stop the car and pull the fuse on the system.

    Knowing the monkey's temperment, I'm sure he won't consider this a bug. IMHO, FP should never prevent system shutdown -- regardless of unexpected system configuration issues etc (missing hardware in this case).
    2004 4runner

  • #2
    What XP are you using?
    Renault Megane...the OEM look

    The Lost in Europe Ford Escort

    Comment


    • #3
      XP Pro SP2.
      2004 4runner

      Comment


      • #4
        Originally posted by rando
        XP Pro SP2.

        I'm using that too, but never had a problem of this kind. Did you try to reinstall it?
        Renault Megane...the OEM look

        The Lost in Europe Ford Escort

        Comment


        • #5
          Originally posted by rando
          Knowing the monkey's temperment, I'm sure he won't consider this a bug. IMHO, FP should never prevent system shutdown -- regardless of unexpected system configuration issues etc (missing hardware in this case).
          Now that's not very nice.
          Especially as it's not my dialog.
          It's not a bug, per se, but I'm sure I can find a workaround.

          I will look.

          Frodo
          [H]4 Life
          My next generation Front End is right on schedule.
          It will be done sometime in the next generation.
          I'm a lesbian too.
          I am for hire!

          Comment


          • #6
            Haha, I am the puppet...er uh...monkey master. :}

            it's not my dialog
            I bet you find yourself saying that alot while doing VB6 work. Ah I remember those days well. One of the most frustrating parts of dealing with component based developments is working around other peoples bugs or undocumented features.

            In any case, I was planning to put a startup script that verified that all my hardware exists before it launches FP. Of course if you patch FP to avoid the dialogue, that would work too. Ultimately, I need to fix my stupid USB problem -- but that's another issue all together.

            Thanks for considering this one monkey boy. I hope you feel better soon from your ordeal.
            2004 4runner

            Comment


            • #7
              Originally posted by Cris
              I'm using that too, but never had a problem of this kind. Did you try to reinstall it?
              I have no idea what you're getting at here? I don't think the USB problem is software related. It's intermittent and thus I'm guessing it's got something to do with my hardware setup, USB cabling, USB topology (hubs, etc), power or grounding. If you're referring specifically to the bug I mentioned, try removing all of your sound hardware (and drivers) and then launch FP. I suspect you'll get the same error message. You won't be able to shut down windows unless you can dismiss the dialogue.
              2004 4runner

              Comment


              • #8
                Originally posted by rando
                I have no idea what you're getting at here? I don't think the USB problem is software related. It's intermittent and thus I'm guessing it's got something to do with my hardware setup, USB cabling, USB topology (hubs, etc), power or grounding. If you're referring specifically to the bug I mentioned, try removing all of your sound hardware (and drivers) and then launch FP. I suspect you'll get the same error message. You won't be able to shut down windows unless you can dismiss the dialogue.

                Hey, I thought your connectioncs were OK, and your problem is strictly software...I know I didn't help much, but I had problems with windows (not yours), and after reinstalling they were gone...
                Renault Megane...the OEM look

                The Lost in Europe Ford Escort

                Comment


                • #9
                  That is one of the reason in my install I try to put the tiny USB hub as close to my reach as possible. If the USB TS or USB mouse fail, I just unplug and plug back in hope that either one of those 2 will work so I can control the system again.
                  2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
                  89 Supra Turbo P3 [email protected]/Abit BE6 II, Alpine M-BUS Car2PC.
                  Y2K Accord Dell GX150
                  RoadRunner is the best FE PERIOD
                  EmoRebellion is a SCAMMER

                  Comment


                  • #10
                    Yah, the hub is burried in my system to keep things looking stealth. Ultimately, my power switch should be sufficient to work-around this kind of problem -- if only FP (<cough> I mean the mixer control component embedded in FP) would let the system shut down.
                    2004 4runner

                    Comment


                    • #11
                      So i'm getting the same error.. This is after installing an audigy nx. What can i do to fix this?

                      Comment


                      • #12
                        I just went through and got rid of all message boxes for the mixer.
                        Should fix it for take 4.
                        [H]4 Life
                        My next generation Front End is right on schedule.
                        It will be done sometime in the next generation.
                        I'm a lesbian too.
                        I am for hire!

                        Comment


                        • #13
                          Coolness ... thanks!
                          2004 4runner

                          Comment

                          Working...
                          X