Announcement

Collapse
No announcement yet.

LinuxICE Beta3

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • LinuxICE Beta3

    LinuxICE Beta3 is ready for download.

    grab the torrent here:

    http://nghost-project.com/LinuxICE-Beta3-4.torrent

    The update here is quite a few bug fixes and stability issues addressed. In addition, nGhost (now 2.0.1) and icepanel have been updated to the very latest.
    See: http://wiki.openice.org/index.php/Th...t#Get_LinuxICE for additional information


    cheers,
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

  • #2
    faulty installation

    Hi Kev

    First let me say that you are a legend. I have been monitoring this carPC progress for years now. Partly due to funds, and partly sue to maturity. I have decided to download the beta 3 version of openice. I have tried to install it and seem to get as far as a busybox terminal screen.

    I am trying to install on a Dell Latitude D630. This is just a test system as i am waiting for my hardware to arrive.

    Do you have any pointers for me?

    I have now installed Ubuntu 8.04. I will download nGhost and see if i can get it all up and running.

    TIA

    Terry

    Comment


    • #3
      Hey Kev, some reason I cannot connect to DL the torrent file. Something up there?
      Tidder

      Try RevFE
      The best resurrected frontend I've ever used, period.


      I Wish I could ban people

      Comment


      • #4
        Originally posted by 0utlawza View Post
        Hi Kev

        First let me say that you are a legend. I have been monitoring this carPC progress for years now. Partly due to funds, and partly sue to maturity. I have decided to download the beta 3 version of openice. I have tried to install it and seem to get as far as a busybox terminal screen.

        I am trying to install on a Dell Latitude D630. This is just a test system as i am waiting for my hardware to arrive.

        Do you have any pointers for me?

        I have now installed Ubuntu 8.04. I will download nGhost and see if i can get it all up and running.

        TIA

        Terry
        I think I have the exact same problem on my laptop at work of the same model. I have no idea why. I wonder if by removing some laptop tools I inadvertently broke the ability to boot on a laptop....

        edit: my laptop at work is actually a Dell D830. but still, same issue.

        Tidder, the server that the torrent was sitting on moved (with me) to a new home. I've got the torrent uploaded to the forum in the mean time: http://forums.openice.org/download/file.php?id=266

        This also means that you won't be able to get LinuxICE updates until comcast get's my internet hooked back up.
        Former author of LinuxICE, nghost, nobdy.
        Current author of Automotive Message Broker (AMB).
        Works on Tizen IVI. Does not represent anyone or anything but himself.

        Comment


        • #5
          If it's the "can't access tty: job control turned off" problem, then I came across the same problem, it's a know *buntu problem. Everyone has another cause though. For me it was the fact that there is a compact flash card with windows XP on it. Just removing the card was enough to get the party started... minor detail: I planned on installing on that exact CF card...

          Didn't really like what I saw though
          Navit doesn't start, USB sticks aren't recognized directly and icetouch won't start so I can't calibrate my touchscreen. Oh and it takes a lot longer to start than Xp Judging from the websites and screenshots I had expected at least some working parts
          On the upside: it does look good, so I'm hoping for a working beta4
          CarPC: "Carma" (Car Audio & Route Management) (about 70% ready)
          P4 1.8GHz / 512MB / 4GB CF
          Asus TVFM + B/W camera
          15" touchscreen 1024x768
          BU303
          2x 100Ah
          reinstalling

          And all this in a Dutch 1972 CitroŽn HY van called "MurpHY".

          Comment


          • #6
            Originally posted by LEiPiE View Post
            If it's the "can't access tty: job control turned off" problem, then I came across the same problem, it's a know *buntu problem. Everyone has another cause though. For me it was the fact that there is a compact flash card with windows XP on it. Just removing the card was enough to get the party started... minor detail: I planned on installing on that exact CF card...

            Didn't really like what I saw though
            Navit doesn't start, USB sticks aren't recognized directly and icetouch won't start so I can't calibrate my touchscreen. Oh and it takes a lot longer to start than Xp Judging from the websites and screenshots I had expected at least some working parts
            On the upside: it does look good, so I'm hoping for a working beta4
            Your pain is felt. I've added a bug for the problems you are experiencing: http://bugs.openice.org/bug.php?op=show&bugid=20 .

            I'll get fixes for those as soon as I can.

            Thanks for the report.
            Former author of LinuxICE, nghost, nobdy.
            Current author of Automotive Message Broker (AMB).
            Works on Tizen IVI. Does not represent anyone or anything but himself.

            Comment


            • #7
              Hi Kev,

              I am working on getting my Sony UX UMPC up and running as a car PC, suitable for multiple cars. Without going into too much detail (theres more detail here, if you're interested; http://www.mp3car.com/vbulletin/linu...tu-car-pc.html) I also want it to be a fully functional PC when not docked in the car.

              I fired up the live CD of your distro and it looks really good. There are lots of nice touches that I would like to replicate in my setup (I am not looking to make a distro). I also notice that your distribution is Ubuntu derived and wondered if you had any package repositories I could point my sources.list at in order to add elements of your distro' to my setup?

              Also - do you have any details as to how to get Maemo apps running on x86 PC's. I have an N800, but would be very interested in CarMan and Canola. Any pointers would be very much appreciated.

              Thanks

              Dan

              Comment


              • #8
                yes, there is a linuxice package repo:

                deb http://nghost-project.com/nghost/downloads main unstable testing
                i don't recommend testing, unless you want to help out with the testing effort

                as for maemo apps, I usually just grab the source and compile it myself. If it's written in python (like carman and canola are), then it should work out of the box.

                see ya!
                Former author of LinuxICE, nghost, nobdy.
                Current author of Automotive Message Broker (AMB).
                Works on Tizen IVI. Does not represent anyone or anything but himself.

                Comment


                • #9
                  Originally posted by kev000 View Post
                  yes, there is a linuxice package repo:



                  i don't recommend testing, unless you want to help out with the testing effort

                  as for maemo apps, I usually just grab the source and compile it myself. If it's written in python (like carman and canola are), then it should work out of the box.

                  see ya!
                  Thanks Kev, much appreciated and I'd be happy to help with the testing.

                  Comment


                  • #10
                    Originally posted by kev000 View Post
                    as for maemo apps, I usually just grab the source and compile it myself. If it's written in python (like carman and canola are), then it should work out of the box.

                    see ya!
                    I have now installed Carman - when I launch carman-gtk it presents the window from which I can create a new profile. If I select new, software simulator, then forward... it will go no further. The same thing happens with carman-sdl-launcher or carman-profile-manager

                    Code:
                    [email protected]:/$ carman-profile-manager 
                    Traceback (most recent call last):
                      File "/usr/share/carman/carman-gtk/carman_gtk/ProfileDialogController.py", line 334, in cb_profile_dialog_view_init_bt_device
                        BannerDialog.destroy()
                      File "/usr/share/carman/carman-gtk/carman_gtk/BannerDialog.py", line 55, in destroy
                        hildon.gtk_banner_close(cls._parent)
                    AttributeError: 'module' object has no attribute 'gtk_banner_close'
                    Error in sys.excepthook:
                    Traceback (most recent call last):
                      File "/usr/lib/python2.5/site-packages/apport_python_hook.py", line 38, in apport_excepthook
                        from apport.packaging_impl import impl as packaging
                      File "/usr/lib/python2.5/site-packages/apport/__init__.py", line 1, in <module>
                        from apport.report import Report
                      File "/usr/lib/python2.5/site-packages/apport/report.py", line 17, in <module>
                        import xml.dom, xml.dom.minidom
                      File "/usr/lib/python2.5/site-packages/PIL/__init__.py", line 220, in <module>
                        
                    ImportError: cannot import name DOMImplementation
                    
                    Original exception was:
                    Traceback (most recent call last):
                      File "/usr/share/carman/carman-gtk/carman_gtk/ProfileDialogController.py", line 334, in cb_profile_dialog_view_init_bt_device
                        BannerDialog.destroy()
                      File "/usr/share/carman/carman-gtk/carman_gtk/BannerDialog.py", line 55, in destroy
                        hildon.gtk_banner_close(cls._parent)
                    AttributeError: 'module' object has no attribute 'gtk_banner_close'
                    Traceback (most recent call last):
                      File "/usr/share/carman/carman-gtk/carman_gtk/WizardDialog.py", line 223, in __cb_response
                        if self.validate_page(page):
                      File "/usr/share/carman/carman-gtk/carman_gtk/WizardDialog.py", line 200, in validate_page
                        self.show_validation_error(page)
                      File "/usr/share/carman/carman-gtk/carman_gtk/WizardDialog.py", line 186, in show_validation_error
                        hildon.gtk_infoprint(self, page.validate_message)
                    AttributeError: 'module' object has no attribute 'gtk_infoprint'
                    Error in sys.excepthook:
                    Traceback (most recent call last):
                      File "/usr/lib/python2.5/site-packages/apport_python_hook.py", line 38, in apport_excepthook
                        from apport.packaging_impl import impl as packaging
                      File "/usr/lib/python2.5/site-packages/apport/__init__.py", line 1, in <module>
                        from apport.report import Report
                      File "/usr/lib/python2.5/site-packages/apport/report.py", line 17, in <module>
                        import xml.dom, xml.dom.minidom
                      File "/usr/lib/python2.5/site-packages/PIL/__init__.py", line 220, in <module>
                        
                    ImportError: cannot import name DOMImplementation
                    
                    Original exception was:
                    Traceback (most recent call last):
                      File "/usr/share/carman/carman-gtk/carman_gtk/WizardDialog.py", line 223, in __cb_response
                        if self.validate_page(page):
                      File "/usr/share/carman/carman-gtk/carman_gtk/WizardDialog.py", line 200, in validate_page
                        self.show_validation_error(page)
                      File "/usr/share/carman/carman-gtk/carman_gtk/WizardDialog.py", line 186, in show_validation_error
                        hildon.gtk_infoprint(self, page.validate_message)
                    AttributeError: 'module' object has no attribute 'gtk_infoprint'
                    [email protected]:/$
                    Is this an error you have come across at all?

                    Thanks

                    Dan

                    Comment


                    • #11
                      did you install from the linuxice package, or from the maemo one? I almost always get a software device simulation going in carman. I haven't gotten much further... but I can blame that on the lack of hardware (a obdII scantool, bluetooth dongle).
                      Former author of LinuxICE, nghost, nobdy.
                      Current author of Automotive Message Broker (AMB).
                      Works on Tizen IVI. Does not represent anyone or anything but himself.

                      Comment


                      • #12
                        Originally posted by kev000 View Post
                        did you install from the linuxice package, or from the maemo one? I almost always get a software device simulation going in carman. I haven't gotten much further... but I can blame that on the lack of hardware (a obdII scantool, bluetooth dongle).
                        I have tried both the LinuxICE version and the Maemo version; and I get the same results either way around?

                        I do have a bluetooth ELM 327 which works fine with CarMan on my N800. Incidentally I found that BT/ELM on ebay extremely cheaply (approx 18$ US +P&P); it was shipped from China, but works flawlessly with CarMan and various other things in both the Saab and the Audi. If you would like the sellers ID to see if they ship to the States (I am in the UK) then I would be happy to let you know. Seems a lot cheaper than the circa $200 ones I've seen around.

                        Dan

                        Comment


                        • #13
                          install over network or HD

                          I downloaded LinuxICE Beta3, and i will install it on Sony vaio-pcg-v505p.
                          this laptop boots only from CD/DVD or HD ( no USB boot ) the CD/DVD is not woking now, i tried InstallationFromLinux as described on ubuntu help: https://help.ubuntu.com/community/In...tion/FromLinux
                          but it not works !!
                          did any one intsalled the LinuxICE Beta3 via network boot?
                          Thanks in advance.

                          Comment

                          Working...
                          X