Announcement

Collapse
No announcement yet.

No reaction to powerbtn press

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • No reaction to powerbtn press

    Howdy,

    For some reason I am having trouble getting linuxice to shutdown when it receives a powerbtn event. Using xev, I noted that keycode 124 (XF86Poweroff) is being seen - yet nghost doesn't start to shutdown. Where should I be looking to troubleshoot this?

    Eventually, I would like to get tuxonice working -- so if that plays apart (I have updated to the kernel specified in another thread) please keep that in mind. Thanks in advance,

    Nasa

  • #2
    Originally posted by nasa View Post
    Howdy,

    For some reason I am having trouble getting linuxice to shutdown when it receives a powerbtn event. Using xev, I noted that keycode 124 (XF86Poweroff) is being seen - yet nghost doesn't start to shutdown. Where should I be looking to troubleshoot this?

    Eventually, I would like to get tuxonice working -- so if that plays apart (I have updated to the kernel specified in another thread) please keep that in mind. Thanks in advance,

    Nasa
    take a look in /etc/acpi/powerbtn.sh. This script maps the powerbtn event to hibernate by default. You can modify this to just do a shutdown if desired. Is it even trying to hibernate? I suppose if you aren't using a tuxonice kernel it'd just do nothing...
    Former author of LinuxICE, nghost, nobdy.
    Current author of Automotive Message Broker (AMB).
    Works on Tizen IVI. Does not represent anyone or anything but himself.

    Comment


    • #3
      Thanks for the reply tripzero,

      After it gets the button press (which I verified happens -- after changing the BIOS setting to S3, instead of S1) the hibernate command *hibernates* and then resumes seconds later. ie: the system never shuts down. I could post the output from running the command from the command line if that would be helpful.

      Nasa

      Comment


      • #4
        Originally posted by nasa View Post
        Thanks for the reply tripzero,

        After it gets the button press (which I verified happens -- after changing the BIOS setting to S3, instead of S1) the hibernate command *hibernates* and then resumes seconds later. ie: the system never shuts down. I could post the output from running the command from the command line if that would be helpful.

        Nasa
        hibernate may be failing partway? any output or logs may be useful.
        Former author of LinuxICE, nghost, nobdy.
        Current author of Automotive Message Broker (AMB).
        Works on Tizen IVI. Does not represent anyone or anything but himself.

        Comment


        • #5
          Please see attached log...

          Nasa
          Attached Files

          Comment


          • #6
            s2disk: Could not stat the resume device file. Reason: No such file or directory
            do you have swap?
            Former author of LinuxICE, nghost, nobdy.
            Current author of Automotive Message Broker (AMB).
            Works on Tizen IVI. Does not represent anyone or anything but himself.

            Comment


            • #7
              Initially I didn't, but with my troubleshooting I added it....

              /mnt/1Gb.swap is the swapfile and it's been added to my /etc/fstab and /boot/grub/menu.1st files.

              Nasa

              edit: it looks like I had to reconfigure uswsusp.... Things are looking better (although splashy doesn't work)
              edit 2: spoke to soon, image fails to start X... "X: cannont stat /tmp/.x11-unix (no such file or directoy), along with errors about a read-only file system.
              edit 3: df -h gives me "cannot read table of mounted fie systems: no such file or directory" -- what gives

              Comment

              Working...
              X