Announcement

Collapse
No announcement yet.

Onscreen keyboard

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Onscreen keyboard

    Hi quick question.


    Im building a car pc that will use a touch screen display for input, basically will the onscreen keyboard build into the destinator front end work?

    At the moment until I receive my screen, im just messing about with the software on my pc. Should I be able to click on the buttons on the onscreen keyboard to enter addresses in the search box? As when I try this nothing happens.


    Many Thanks

    Trev

  • #2
    This seems to be a bug that I'm not, under any circumstances, able to recreate

    Can you (and anyone else having this problem) answer the following?

    1. Operating System / Service Pack
    2. Does the problem happen all the time? Is it random?
    3. Does it make a difference if you use another skin?
    4. Does it make a difference if you start with the /SETUP parameter?
    5. Where are you launching the frontend from? (e.g. a Shortcut)

    I'd really like to get this fixed!
    Destinator 3 For PC! - http://www.map-monkey.co.uk/

    Comment


    • #3
      OSK problem

      I'm having the same problem...

      to answer your questions

      I'm Running Win XP SP1
      Happens all the time when starting from short cut on desktop. I have a desktop Shortcut for configuration and application, happens on both.
      When starting the app from the c:\destinatorApps\Frontend_prev or the c:\DestinatorApps directory I don't have the problem.
      the above is the same for either skin...

      I haven't read all the new posts yet, any resolution for the voice feedback issue?

      Great job BTW
      DJester

      Comment


      • #4
        Additional info...

        I just tried to start Destinator from the Apps menu in Frodo player, keyboard works from here.

        thanks
        DJester

        Comment


        • #5
          The OSK doesn't work ONLY if launched D3 with the utility of Configuration.

          Embedded with Mediacard or directly launched by D3 link it works correctly.

          Mauri

          Comment


          • #6
            Originally posted by mauri
            The OSK doesn't work ONLY if launched D3 with the utility of Configuration.

            Embedded with Mediacard or directly launched by D3 link it works correctly.

            Mauri
            Wrong....the behaviour is eratic and happens no matter how you start it embedded or not...at least for me

            Comment


            • #7
              "1. Operating System / Service Pack"
              Im running windows xp sp2 (same issue on my other pc that running xp sp1)
              "2. Does the problem happen all the time? Is it random?" All the time
              All the time
              "3. Does it make a difference if you use another skin?"
              No
              "4. Does it make a difference if you start with the /SETUP parameter?"No
              "5. Where are you launching the frontend from? (e.g. a Shortcut)"
              Ive tryed running both shortcuts, and also running it throught mediacar


              Just to confirm and to ensure your time is not wasted by my own missunderstanding. I should be able to use the mouse to select buttons on the on-screen keyboard yes?

              Ninja Monkey If there are any apps,dll or stuff you want me to try just give me a shout.

              Trev

              Comment


              • #8
                Originally posted by gti
                "1. Operating System / Service Pack"
                Im running windows xp sp2 (same issue on my other pc that running xp sp1)
                "2. Does the problem happen all the time? Is it random?" All the time
                All the time
                "3. Does it make a difference if you use another skin?"
                No
                "4. Does it make a difference if you start with the /SETUP parameter?"No
                "5. Where are you launching the frontend from? (e.g. a Shortcut)"
                Ive tryed running both shortcuts, and also running it throught mediacar


                Just to confirm and to ensure your time is not wasted by my own missunderstanding. I should be able to use the mouse to select buttons on the on-screen keyboard yes?

                Ninja Monkey If there are any apps,dll or stuff you want me to try just give me a shout.

                Trev
                I'm at a loss. Are you running the app in fullscreen mode? If you are, can you try unchecking "set size & position at startup" and see if it helps?

                Edit: Yes, you should be able to use the mouse to click the keys
                Destinator 3 For PC! - http://www.map-monkey.co.uk/

                Comment


                • #9
                  Originally posted by Seth
                  Wrong....the behaviour is eratic and happens no matter how you start it embedded or not...at least for me
                  Are you saying for you it'll sometimes actually work?
                  Destinator 3 For PC! - http://www.map-monkey.co.uk/

                  Comment


                  • #10
                    Originally posted by Ninja Monkey
                    Are you saying for you it'll sometimes actually work?
                    Yes...but without any obvious reason why

                    Comment


                    • #11
                      Originally posted by Ninja Monkey
                      I'm at a loss. Are you running the app in fullscreen mode? If you are, can you try unchecking "set size & position at startup" and see if it helps?

                      Edit: Yes, you should be able to use the mouse to click the keys
                      Hi im running it in a window at the mo, on the config screen i can not see where you can uncheck the "set size & position at startup" option, unless its in one of the INI files.

                      Ive also tried setting the rez of the monitor at different rezes and still no luck

                      Trev

                      Comment


                      • #12
                        Originally posted by gti
                        Hi im running it in a window at the mo, on the config screen i can not see where you can uncheck the "set size & position at startup" option, unless its in one of the INI files.

                        Ive also tried setting the rez of the monitor at different rezes and still no luck

                        Trev
                        It's on the "size & position" tab

                        Can you try something else - using explorer, go to C:\DestinatorApps\Frontend_PREV and run Destinator3.exe directly and tell me what happens.
                        Destinator 3 For PC! - http://www.map-monkey.co.uk/

                        Comment


                        • #13
                          Originally posted by Ninja Monkey
                          It's on the "size & position" tab

                          Can you try something else - using explorer, go to C:\DestinatorApps\Frontend_PREV and run Destinator3.exe directly and tell me what happens.

                          Hi Ninja Monkey,

                          Erm ive looked around and still cant find that tab also when you asked me to enter the DestinatorApps dir, there is no Frontend_PREV folder, just a Frontend folder. Well i ran the exe in that folder and it still does not work.

                          P.S. (im running 1.1.2) would you like me to try the beta 1.1.3??

                          Trev

                          Comment


                          • #14
                            Originally posted by gti
                            Hi Ninja Monkey,

                            Erm ive looked around and still cant find that tab also when you asked me to enter the DestinatorApps dir, there is no Frontend_PREV folder, just a Frontend folder. Well i ran the exe in that folder and it still does not work.

                            P.S. (im running 1.1.2) would you like me to try the beta 1.1.3??

                            Trev
                            Ahh, ok... I can't remember if there were issues in 1.1.2 that I fixed for the beta.

                            I know seth is having random OSK problems with 1.1.3 but can you give it a try anyway?
                            Destinator 3 For PC! - http://www.map-monkey.co.uk/

                            Comment


                            • #15
                              Right ive just repeated all the previous tests that i did with 1.1.2 with 1.1.3

                              Ie loading the app through media car, loading the exe direct ect.


                              As before no luck, but i have noticed this. When i click in the textbox control and then click a button on the OSK, the button goes down like a normal windows button and there is a beep through the speakers but no chr appears in the text control. if i then click another button there is a beep through the speakers, but the button does not go down and pop back up like before.

                              Hope this helps

                              Trev

                              Comment

                              Working...
                              X