Announcement

Collapse
No announcement yet.

COM port busy

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • COM port busy

    I know this has nothing to do with D3 but i do ask the question though..
    I tried to duplicate my COM port with Xport.

    Here is how i tried to install/setup this..
    My GPS runs @ COM3
    startup xport and checked COM3 as input and COM 7/8/9 as output..

    But now D3 wont find my GPS.it wil show my current position but freezes as it shows the first screen
    So i go to GPS setup and select COM3, then it works again, but gat a message port busy. When set the addon (camera/speed) i get an error: port busy.

    does this meens my gps doen't alow to duplicate the com port or do i miss something? Maybe i have to use another program? I tried to @ xport but that didn't make me any

    Also tried to but that that didn't help also

    please help me out here..

  • #2
    Originally posted by TheKingPlaza
    I tried to @ xport but that didn't make me any
    It didn't make you any (huge bouncing boobs)?
    ....Yes, I know it has a stupid name, those crazy Japanese!

    Comment


    • #3
      same problem wwith a friend of mine !
      ThE ScReW's CarPuter :-)

      Comment


      • #4
        Advanced GPS mode takes control of the COM port away from D3 - so going into D3's own COM port setup screen isn't going to do anything anyway.

        Are you sure you went back into the D3 Frontend configuration and changed the com port there?
        Destinator 3 For PC! - http://www.map-monkey.co.uk/

        Comment


        • #5
          Try XPort2. Uninstall xport first. Install xport2. Start the compass, set it to COM3. Start D3 and set it to one of the xport2 output ports. You might have to HEX edit the destinator.ini file to set the COM port though.

          Comment


          • #6
            This thread might be connected to my problem... this is the info as i've posted in another thread but with a different title.

            Also if anyone is using Rayming TN-200 USB GPS MOUSE with d3 please share info.

            ==================================================

            Thanks for the info, the OS in the carputer is win me.. (i did the testing in my home comp)...

            and it does work on windows ME (the D3 FE 1.3 P2) .. but i have 2 errors coming when i close the program , or while using it...

            1)"~Vtsoundmachine->soundthread is not closed" - this error is a message box with "ok" button which doesnt disappear and due to it i cant close the app (i shut down windows and get rid of it).

            2) i got a TripNav GPS mouse, which uses a virtual com port. now when i installed it, it took com port 3 , as the USB->serial port. and D3 recognized only com port 1, and 2 and there was no 3 (its a combobox with only recognized ports).
            So i've set in my computer (its driver has an option) its port to 1, removed com port 1 (its virtual) and restarted, when the comp got back up, it was 1 alright (the USB -> serial), what was com port 1 became com port 5. i've ran d3 and it recognized ports 1,2 and 5 (yes!) BUT .. it didnt detected the GPS. my question is this: if the gps isnt locked , it wont detect it? (cant be...)
            or maybe someone with such knowledge can enlighten me.

            3) when i open the Hebrew map, the fonts werent in hebrew (gibbrish... unknown) , how do i change them... couldnt find an option doing so. I've changed the map to the English one meanwhile.



            Thanks again ,going one step at a time...
            NM rock..
            __________________
            Cheers, yours, X. The link: http://xmen4u.tripod.com/ Click below
            XMen's CarPC Website


            XMen
            View Public Profile
            Send a private message to XMen
            Find More Posts by XMen
            Add XMen to Your Buddy List

            Today, 12:06 AM #7
            XMen
            Newbie


            Join Date: Dec 2003
            Posts: 23 more about the gps problem

            --------------------------------------------------------------------------------

            well using GPS info (a program which scans the com ports that came with the GPS (and can be downloaded from the rayming website) , and allows you to use the GPS to get coordinates , WAS/EGONS , COLD START... ) it detects the gps on the right com port1, and gets the coordinates, and all.

            but D3 F.E doesnt find it on com1... though its there. (in the right baud rate, and i've even tried playing with it)..
            I get all the time "GPS thread isnt not created" , more over, i tried in the configuration setting the com port to 1... also it didnt help.
            tried setting it to Sirf and not to nmea..

            please , help is needed
            Cheers, yours, X. The link: http://xmen4u.tripod.com/ Click below
            XMen's CarPC Website

            Comment


            • #7
              Here ya go ... Xports and other problem solve.
              http://www.mp3car.com/vbulletin/showthread.php?t=38246
              I can use D3, but can't use the advance mode.... didn't have time to play with it yet... the MPH display showing "NOT IMPLEMENT" but if I disable the Advance Mode, D3 work fine with Xport2 virtual COM port.
              2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
              89 Supra Turbo P3 [email protected]/Abit BE6 II, Alpine M-BUS Car2PC.
              Y2K Accord Dell GX150
              RoadRunner is the best FE PERIOD
              EmoRebellion is a SCAMMER

              Comment


              • #8
                I try it but D3 still having problem in advance mode (fine in standard mode).
                If no Xport2/Compass, D3 fine.
                With gpsGate, D3 fine. But routis not working 100%
                With Xport2/Compass, Routis is fine, but D3 having problem in Advance mode.
                Dam ...
                2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
                89 Supra Turbo P3 [email protected]/Abit BE6 II, Alpine M-BUS Car2PC.
                Y2K Accord Dell GX150
                RoadRunner is the best FE PERIOD
                EmoRebellion is a SCAMMER

                Comment


                • #9
                  ok..

                  Hi ,

                  Thanks again for your info... though i got several questions and idid a search and found the link to xport http://curioustech.home.insightbb.com/xport.html
                  though it doesnt work for me... more over couldnt understand whats the difference between xport and xport2, gpsgate and what is the main idea behind replicating the com port.

                  BTW, does your gps is a rayming tn-200 alike?thanks again, awaiting, X
                  Cheers, yours, X. The link: http://xmen4u.tripod.com/ Click below
                  XMen's CarPC Website

                  Comment


                  • #10
                    Originally posted by XMen
                    Hi ,

                    Thanks again for your info... though i got several questions and idid a search and found the link to xport http://curioustech.home.insightbb.com/xport.html
                    though it doesnt work for me... more over couldnt understand whats the difference between xport and xport2, gpsgate and what is the main idea behind replicating the com port.

                    BTW, does your gps is a rayming tn-200 alike?thanks again, awaiting, X
                    Hey XMen, if you follow the thread from the link I post earlier, you will get some idea.
                    Can you connect to the GPS COM port by using Hyper Terminal? Try that to see if you can see the data stream.
                    - Xport is the first version. It doesn't work with Hibernation. You have to shutdown all connection to Xport's virtual COM port before going hibernation. It can connect to the GPS COM port via a helper application (Hyper Terminal or Street and Trips/Street Atlas via COM port...). At the beginning we use Xport as a gateway to make Routis working with Delorme Earthmate because the old Earthmate USB to Serial driver doesn't work with Routis.
                    - Xport2 fixed the Hibernation problem, but Xport2 doesn't work by itself. You need a helper application as well. That helper application is Compass also found at Xport2 download page. Per Curiousity the author of the program, you can use hyper terminal (not exactly) as a helper application instead of Compass.

                    The idea behide replicating comport is that you can run 2 or more GPS applications at the same time without having to by 1 GPS for each application. In my case, I want D3 feature especially in Advance mode and Routis for Voice Navigation and Routing, Street Atlass for POI, Compass for little compass spinning around ... ...
                    2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
                    89 Supra Turbo P3 [email protected]/Abit BE6 II, Alpine M-BUS Car2PC.
                    Y2K Accord Dell GX150
                    RoadRunner is the best FE PERIOD
                    EmoRebellion is a SCAMMER

                    Comment


                    • #11
                      Sorry to hijack

                      I have install xport2 and compass - working perfect emulating for the oziezplorer software

                      However the destinator software only allows me to use normal ports, the emulated ports are not there, and the xport software doesnt allow you to emulate on normal ports

                      any help apprechiated, btw all these programs are the best,,, keep up the good work

                      i only found out about them at lunch time today, and they are all workng great exept for the little issue above

                      thanks

                      dave

                      Comment


                      • #12
                        With a Hex Editor you can edit Destinator.ini and change the comport.
                        Laidback


                        The ultimate CarPC - Wow!

                        Comment


                        • #13
                          Please remember guys, if you're using advanced mode it doesn't matter what port you have destinator set to, because it won't use it!

                          You need to specify what port you are using in SETTINGS.INI (or Frontend config) and not through destinator...This is probably where most of you are going wrong.
                          Destinator 3 For PC! - http://www.map-monkey.co.uk/

                          Comment


                          • #14
                            Hey Ninja Monkey I will give you the detail error later when I run the app again.
                            Here is the basic what happen.
                            I didn't use D3 to set the COM port (in D3 it is currently on COM1)...
                            I use Front End configure tool to set COM port. It is set to use COM6 (created by Xports/gpsGate).
                            When your front end is launch, it give an error about ActiveX something and said to send you a message.... can remember exact error. ...
                            With gpsGate it work fine same connecting method as Xport2.
                            2004 Matrix XR A7N8X-VM/400 AMD XP-M 2500+, DS-ATX
                            89 Supra Turbo P3 [email protected]/Abit BE6 II, Alpine M-BUS Car2PC.
                            Y2K Accord Dell GX150
                            RoadRunner is the best FE PERIOD
                            EmoRebellion is a SCAMMER

                            Comment


                            • #15
                              It possibly is something to do with destinator - before advanced mode is activated, for a split second destinator will try and connect to its configured com port...try changing destinators com port away from 1 if it's not already
                              Destinator 3 For PC! - http://www.map-monkey.co.uk/

                              Comment

                              Working...
                              X