No announcement yet.

About Installing D3 on PC ...?

  • Filter
  • Time
  • Show
Clear All
new posts

  • About Installing D3 on PC ...?

    Hi all,

    i'm not a newbie but haven't been here for a while, i tried searching the forum for installing instructions (i dont think its only "run the .exe and follow the steps" and if so i'm doing something wrong..). I just got D3 - israel... and i have several questions:

    a) what steps do i need to take in order to install the D3 F.E on pc... (copy the maps, run the exe, register.bat ... what???)

    b) the maps are approximatley 12MB, do i need to cut them anyway?!?!

    i tried running the EXE, copying the maps and then running register.bat and afterwards running the F.E (after boot ofcourse)... and i got errors...

    maybe im doing something wrong..

    P.S. Huge Huge Huge thanks goes to NM for his great coding skill, time and effort. peace and good luck to us all.
    Cheers, yours, X. The link: Click below
    XMen's CarPC Website

  • #2
    What errors did you get?

    Just incase you haven't, you MUST install to your C drive. So your isreal map should be placed in the following location


    Then inside the Isreal folder should be files such as WCE_A.MAP etc.
    Destinator 3 For PC! -


    • #3
      Ok i've did exactly like this:

      First lemme thank you for your fast response.

      couple of notes:
      Im using win 98 SE .
      D3 F.E 1.1.3 P2

      in Israel maps there are 2 version (IsraelH and IsraelE , H- hebrew, E- English)
      I've copied IsraelH (also tried afterwards with the English version).
      installed the F.E. on C (just like before), ran the register.bat from c:\windows\system (it regged em).
      copied the map to: C:\DestinatorApps\Destinator\IsraelE (for e.g).
      ran the conf, it started loading and crashed: error:

      DESTINATOR3 caused an invalid page fault in
      module MSIMG32.DLL at 017f:01d048c7.
      EAX=81ee3fd4 CS=017f EIP=01d048c7 EFLGS=00010282
      EBX=00000003 SS=0187 ESP=0075e3f0 EBP=0075e418
      ECX=0075e560 DS=0187 ESI=0075e464 FS=4a5f
      EDX=040f7584 ES=0187 EDI=81ee3fd4 GS=0000
      Bytes at CS:EIP:
      66 8b 00 83 fb 03 89 5d e8 75 0c 8b 5e 50 81 7b
      Stack dump:
      00002822 0075e560 0053f0c0 0000025e 00000003 00000037 0000025e 8f06bf50 8f06bf50 81ee3fd6 0075e444 01d04c44 0075e5a8 0075e4d8 0000ffff 00000001

      thanks again.
      Cheers, yours, X. The link: Click below
      XMen's CarPC Website


      • #4
        i've just saw a thread about win98 and D3

        and mauri wrote it works only with XP...

        so i guess that is it. DAMN!

        thanks anyway
        Cheers, yours, X. The link: Click below
        XMen's CarPC Website


        • #5
          I've heard reports it runs on WinME too, if that's an option?
          Destinator 3 For PC! -


          • #6

            Thanks for the info, the OS in the carputer is win me.. (i did the testing in my home comp)...

            and it does work on windows ME (the D3 FE 1.3 P2) .. but i have 2 errors coming when i close the program , or while using it...

            1)"~Vtsoundmachine->soundthread is not closed" - this error is a message box with "ok" button which doesnt disappear and due to it i cant close the app (i shut down windows and get rid of it).

            2) i got a TripNav GPS mouse, which uses a virtual com port. now when i installed it, it took com port 3 , as the USB->serial port. and D3 recognized only com port 1, and 2 and there was no 3 (its a combobox with only recognized ports).
            So i've set in my computer (its driver has an option) its port to 1, removed com port 1 (its virtual) and restarted, when the comp got back up, it was 1 alright (the USB -> serial), what was com port 1 became com port 5. i've ran d3 and it recognized ports 1,2 and 5 (yes!) BUT .. it didnt detected the GPS. my question is this: if the gps isnt locked , it wont detect it? (cant be...)
            or maybe someone with such knowledge can enlighten me.

            3) when i open the Hebrew map, the fonts werent in hebrew (gibbrish... unknown) , how do i change them... couldnt find an option doing so. I've changed the map to the English one meanwhile.

            Thanks again ,going one step at a time...
            NM rock..
            Cheers, yours, X. The link: Click below
            XMen's CarPC Website


            • #7
              more about the gps problem

              well using GPS info (a program which scans the com ports that came with the GPS (and can be downloaded from the rayming website) , and allows you to use the GPS to get coordinates , WAS/EGONS , COLD START... ) it detects the gps on the right com port1, and gets the coordinates, and all.

              but D3 F.E doesnt find it on com1... though its there. (in the right baud rate, and i've even tried playing with it)..
              I get all the time "GPS thread isnt not created" , more over, i tried in the configuration setting the com port to 1... also it didnt help.
              tried setting it to Sirf and not to nmea..

              please , help is needed
              Cheers, yours, X. The link: Click below
              XMen's CarPC Website


              • #8
                Hi Xmen,
                I have same errors on my installation, do you have solved that issue?


                • #9
                  are u using the settings within destinator or the MMconfig that is seperate? If you are using the "advanced GPS" in MM, the settings within destinator dont do anything.

                  look in the same dir as MM and there is a config prog that you run to set your gps and other settings.


                  • #10
                    yes i have

                    I've installed win2k, MM v.3.1 , played with the config...
                    and in the GPS config in MM it detects it. only problem is that sometimes i get a fix... (while comp is loading...) and everything is cool. but when i shutdown the comp and start it again the GPS wont lock... wierd...i have to take it out of the usb, plug it in, and start the comp again.

                    P.S (the opus shuts down the usb devices ofcourse)
                    Cheers, yours, X. The link: Click below
                    XMen's CarPC Website