Announcement

Collapse
No announcement yet.

Scrolling the map

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Scrolling the map

    Is there any way to scroll along the map, either up/down/left/right as required? I know you can set the hot keys but they don't seem to work for some reason.

  • #2
    Drag it! Or do you not want to do that?!

    Comment


    • #3
      Dragging it doesnt work... it just moves the wee section currently displayed and then puts it back if you know what I mean.

      I'd like to be able to scroll using the keyboard because the mouse on the Libretto laptop isn't easy to use.

      Comment


      • #4
        Dragging actually does work on the Libretto - but is there a way to make the UP/DOWN/LEFT/RIGHT keys do it?

        Comment


        • #5
          Setting the Hotkeys will do it

          Post the lines in your Hotkeys.ini that didn't work
          Destinator 3 For PC! - http://www.map-monkey.co.uk/

          Comment


          • #6
            Hotkey43=Local,FE_SCROLLMAP_UP,{CTRL},UP-1
            Hotkey44=Local,FE_SCROLLMAP_DOWN,{CTRL},DOWN-1
            Hotkey45=Local,FE_SCROLLMAP_LEFT,{CTRL},LEFT-1
            Hotkey46=Local,FE_SCROLLMAP_RIGHT,{CTRL},RIGHT-1

            That's the lines from the hotkeys file. I wasn't really sure if the -1 had to stay or not...

            I wanted to be able to use the UP/DOWN/RIGHT/LEFT keys to scroll the map.

            Comment


            • #7
              Originally posted by bryan
              Hotkey43=Local,FE_SCROLLMAP_UP,{CTRL},UP-1
              Hotkey44=Local,FE_SCROLLMAP_DOWN,{CTRL},DOWN-1
              Hotkey45=Local,FE_SCROLLMAP_LEFT,{CTRL},LEFT-1
              Hotkey46=Local,FE_SCROLLMAP_RIGHT,{CTRL},RIGHT-1

              That's the lines from the hotkeys file. I wasn't really sure if the -1 had to stay or not...

              I wanted to be able to use the UP/DOWN/RIGHT/LEFT keys to scroll the map.
              The -1 shouldn't be there. But then even without that you are setting it to be CTRL+UP, CTRL+DOWN etc...

              try this instead

              Hotkey43=Local,FE_SCROLLMAP_UP,,UP
              Hotkey44=Local,FE_SCROLLMAP_DOWN,,DOWN
              Hotkey45=Local,FE_SCROLLMAP_LEFT,,LEFT
              Hotkey46=Local,FE_SCROLLMAP_RIGHT,,RIGHT
              Destinator 3 For PC! - http://www.map-monkey.co.uk/

              Comment


              • #8
                Cheers NM - that worked.

                What line in the hotkeys.ini do I need to modify to bring up the streetfinder window?

                Thanks,
                Bryan.

                Comment


                • #9
                  Fe_menu_item_routeto_address
                  Destinator 3 For PC! - http://www.map-monkey.co.uk/

                  Comment


                  • #10
                    I've tried setting that line to SPACEBAR or SHIFT but neither of these keys seem to work - are these not allowed?

                    Comment


                    • #11
                      try SPACE

                      You can't use shift because that's a modifier - you would only be able to use it in combination with another key
                      Destinator 3 For PC! - http://www.map-monkey.co.uk/

                      Comment


                      • #12
                        Thanks again NM - worked this time. Is there any way to use a keyboard key to jump between selecting city - street and then show or do these have to be clicked with the mouse? The mouse on the Libretto isn't that easy to use!

                        Comment


                        • #13
                          There sure is...

                          FE_CYCLE_DIALOG_FWD
                          and
                          FE_CYCLE_DIALOG_BCK

                          to cycle through City/Street etc..

                          Show would be
                          FE_CLICK_BUTTON_2
                          Destinator 3 For PC! - http://www.map-monkey.co.uk/

                          Comment


                          • #14
                            Thanks again NM - worked as usual.

                            Comment


                            • #15
                              Dragging DOES work but you need to be in "Planning" mode not "Navigation".

                              Being in "Navigation" mode will keep resetting the map to your current position.

                              Comment

                              Working...
                              X