No announcement yet.

Earthmate GPS Reciever Com Port issue in Map Monkey

  • Filter
  • Time
  • Show
Clear All
new posts

  • Earthmate GPS Reciever Com Port issue in Map Monkey

    Ninja and all....You are usual! So i did some more searching on the net and it turns out that Garmin does not use NMEA. They have some proprietary protocol that their recievers communicate with their software...So that was a nice $130 experiment that didnt fly....SO i went and bought a Delorme Earthmate GPS. People here seem to be happy with it...I installed it and it created a virtual com. When i go to device manager and look at Human Interface Device, it shows up as:
    Delorme Earthmate GPS com Device (com3)
    Then in the map monkey config screen i use Com 3 and autodetect baud rate....That doesnt work. I use the baud rate that is in the earthmate instructions, that doesnt work. When I go in the GPS settings in Map Monkey and click on find GPS, it reports GPS not found. When i use the street atlas program wich came with the earthmate, it picks up the earthmate and the satellites pretty quick. Does the GPS not found correspond to not finding satellite or not finding the USB receiver? I think its the latter because it comes up instantly....This is driving me nuts! I cant wait to get these issues resolved...Any comments or suggestions would be greatly appreciated....

  • #2
    Change the com port setting from com3 to a higher number. Not sure how you do this for your device as I don't have the earthmate, but I think this will probably work. On my system, this is done via the driver properties in device manager. Once you've done that, use the map monkey configuration to set it to the new port number you've chosen. The point of raising it to a higher number is to ensure there are no clashes with other devices. As an example, I moved mine to com9.

    EZSync -


    • #3
      Some good news and some bad news....Good news is that it is kind of working. I deleted the old drivers and installed the new drivers from the link to delorme ..Then I created the virtual port on com 9. After telling the map monkey config to look on port 9 and autodetect the baud rate, it seemed to recognize the GPS unit. The reason i know this is because my cars location came up on the map whereas before it was showing somewhere in San Francisco. So then i entered a route and started driving and nothiing happened. In the current location field, the street that I was on came up but it would not change. The MPH does not change from zero either. SO clicking on menu, then settings, and GPS status shows "GPS not Found." Then if i click on the GPS settings on the top left hand corner of that screen, it takes me to a screen that has find GPS and set GPS. When I click on find GPS, a few seconds later it says in blue "GPS found'. When i click on set GPS, it reports "Com Port is busy." And it stays in this config. It seems that every time i load map monkey / road runner and select "GPS" , it will show my current location and thats about it. It will not route, track, etc...

      SO thats where I am at now....If you have any ideas, please feel free to shoot them at me.


      • #4
        I've had this issue too but I can't remember what exactly it was that sorted it out.

        Some suggestions;

        Set the baud rate to 4800 rather than autodetect.

        Make sure you're set for NMEA protocol.

        If those have already been tried, try clicking the satellite picture at the top left, next to the figure that gives the number of satellites locked. Map monkey should say "connecting to GPS" or something similar - does it start updating?

        Use only the map monkey config to configure GPS - ignore the one inside destinator.
        EZSync -