Announcement

Collapse
No announcement yet.

Sirf Advance Gps Mode Help

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sirf Advance Gps Mode Help

    i have been using RR and mapmonkey for about 3 months now and happy with it. one thing that i was not able to accomplish is using the advance gps mode. i know this is a repeat question but i am hoping that people here will answer this question based on my situation. i am using the mouse gps reciever from navisky, it is nmea compliant and checking the specs it is sirf capable. when i try to configure mapmonkey to advance gps mode, and run mapmonkey, gps is not found, and com port busy. i tried using sirfdemo to change the nmea to sirf protocol and it changed it, still no luck. is there a different program than sirfdemo that i can try, i am guessing this is one of the problems. is there a special setting that i need to do on mapmonkey or destinator to make this work? any help is appreciated. thanks again
    7" Lilliput
    Opus 150
    mini itx 1Ghz
    1GB sdram
    97 Prelude

  • #2
    I dont really understand what you are saying...

    From what I remember, (unless this has changed, but I dont think it has) Advanced mode is only NMEA... SiRF is only non-advanced mode (no speed cameras, etc)
    Roy

    2005 Range Rover 4.4
    Any ideas for putting a PC in this? :)

    Comment


    • #3
      i think SiRF is supported by advanced mode. Have you tried to set it to "your com port", "SiRF" and "38400" in MapMonkey? I can't say I'am experienced with this, but thats the settings I run =P Works for me...
      My carputer

      Old one

      Comment


      • #4
        damn, I missed this? since what version?!?!?! YUPPIE!
        Roy

        2005 Range Rover 4.4
        Any ideas for putting a PC in this? :)

        Comment


        • #5
          dont know since when =P Thougt it had always supported SiRF? :P (As long as mapmonkey supported it)
          My carputer

          Old one

          Comment


          • #6
            Originally posted by mick0uziel
            one thing that i was not able to accomplish is using the advance gps mode.
            why can't you use advance gps mode ?
            Epia M10k 512Mb DDR - HD 2.5" 40Gb - Lilliput 7" TS - Slotinn slimline dvd - bu 303 -

            99% ready

            Comment


            • #7
              it seems that his MM isnt finding the GPS in sirf mode in advanced MM mode...

              I would say:

              make sure you have the latest MM version (just to make sure)
              try SIRF mode + NONadvanced MM mode
              then if that works you know it is MM's problem... does advanced mode work with NMEA currently?

              If it even connects with NMEA it means the GPS isnt in SiRF mode...

              It took me a while to get my GPS to SiRF mode with sirfdemo, but keep at it...
              Roy

              2005 Range Rover 4.4
              Any ideas for putting a PC in this? :)

              Comment


              • #8
                sirf is the advance gps mode as far as i know. when on nmea protocol, mm can detect my gps but if i check the advance mode on mm, tried all the com ports and baud rate, still it never finds it, i have the latest mapmonkey version. i dont think it mm gives you the option to use sirf unless you check the advance setting. Royn if you were able to make it work, can you give me steps on how you did it starting from sirfdemo? thanks again
                7" Lilliput
                Opus 150
                mini itx 1Ghz
                1GB sdram
                97 Prelude

                Comment


                • #9
                  find out what communication port your gps is using currently, say COM2 4800bps NMEA

                  - Launch sirfdemo
                  - Select COM2, NMEA, 4800bps baud (as per above THIS CHANGES FOR YOU!!!)
                  - click on the "open data stream" button (it isnt exactly this text), it is a button that has what looks like two plugs connected like this: --{}--
                  - you will see data from the GPS coming in through the "debug" window in a format similar to $XXXXX,XXXXX,XXXXX,XXXXX,XXXXX or similar (this is NMEA data from the GPS)
                  - now go into the ACTION menu, and select "Switch to SiRF Mode"
                  - Check the action menu, Switch to SiRF Mode should be greyed out and "Switch to NMEA Mode" should be enabled... (showing that you already are in sirf mode)


                  OK, you can close sirfdemo...

                  now onto Map Monkey - Configuration Tool

                  - go into the Advanced Mode tab
                  - select SiRF mode
                  - select Autodetect baud
                  - select Autodetect port

                  click OK

                  check if mapmonkey is working... if not go into GPS Settings by clicking on the satellite signal strength in the map monkey screen (lower right above View button) and click on the GPS Settings button on the status window... Then click "Find GPS" and click the home button when the "GPS Found" message comes up in blue.


                  This is roughly what I did... I had some problems but it is essentially that that got it to work...

                  Best of luck, my reception improved 10-fold in Sirf mode
                  Roy

                  2005 Range Rover 4.4
                  Any ideas for putting a PC in this? :)

                  Comment


                  • #10
                    thanks royn for the tip, i will try it right now even though its 9 pm hahha, hope it works, check back in a flash
                    7" Lilliput
                    Opus 150
                    mini itx 1Ghz
                    1GB sdram
                    97 Prelude

                    Comment


                    • #11
                      ok after 3 hours in the cold midnight, setting the sirf mode with sirfdemo works ok, when i tried using mapmonkey, it detected my gps in sirf mode com 3 baud 38400. when i go to configuration and check advanced gps, set com and baud to autodetect set it to sirf, no luck gps not found com port busy, changed the sirf to nmea click ok mapmonkey tries to reconnect and got signals even though gps settings says it cannot find gps, but i just got this twice fidling with the settings, it hits and misses, ended up missing, tried to reinstall mm 5 times, cannot get it back. also something wierd with my baud rate when i got it, it changed to 19200, should have left it there now even if i set it to 19200 it still doesnt work. is this a mapmonkey bug? bottom line still cant use advance gps but got my protocol to sirf. thanks royn, any other tips is appreciated.
                      7" Lilliput
                      Opus 150
                      mini itx 1Ghz
                      1GB sdram
                      97 Prelude

                      Comment


                      • #12
                        that happened to me too....

                        make sure your gps is still in sirf mode (sirfdemo Switch to SiRF will be greyed out)... then try adding the oprt/baud manually in the advanced gps...

                        i cant remember what made it work but i had to twinkle with it for a while too... at one point it would get my position on MM startup but not update and display GPS not found.... then it eventually worked
                        Roy

                        2005 Range Rover 4.4
                        Any ideas for putting a PC in this? :)

                        Comment


                        • #13
                          Try Leadteks Winfast Navigator, that has a function in it which changes the GPS Mouses output from SirF to NMEA and vice versa. Thats the only way I can change my BU-303's output mode.

                          HTH
                          My Nissan 200SX @ Silverstone
                          NOW SADLY WRITTEN OFF!

                          My Car's spec list + pics

                          Stealth CarPC fab'ing...

                          Comment


                          • #14
                            That is exactly what Sirfdemo does in this case.... and apparently he got it to switch...

                            MM is a bit fidgety to get to work when you switch from nmea to sirf... his description above is exactly what happened to me! but i was in traffic :ashamed: when I fixed it so it was kinda 1-click-a-block so I dont really remember!

                            I know it started working as I pulled into the garage!
                            Roy

                            2005 Range Rover 4.4
                            Any ideas for putting a PC in this? :)

                            Comment


                            • #15
                              hey, yeh i dont know why it hits and misses, now couldnt get it to work with advanced gps mode, i already tried inputting the comport and baud manually but no luck, when it worked i had to set the com and baud autodetect and protocol to nmea (even though i am using sirf), when mm got locked satellites even though it said no gps detected, i went back to configure and set my com port manually and baud to autodetect (it doesnt work when i set the baud manually), after that it still works, should have left it alone at that point, but since curiosity is a greater part of me and wanted to take down notes on how it works flawlessly so others can benefit, i fiddled with it more and ended up with nadda lol!
                              7" Lilliput
                              Opus 150
                              mini itx 1Ghz
                              1GB sdram
                              97 Prelude

                              Comment

                              Working...
                              X