Announcement

Collapse
No announcement yet.

MM font problem continues

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • MM font problem continues

    I have done my reading and tried to fix MM font problem, but with no success. Can anyone please give me the solution or send me the modified DLL for Greek support?

    Take a look at the screenshot.
    You can see: Font ArialG IS installed in windows
    ArialG opens correctly from windows font viewer
    Destdll.dll IS modified, because MM tries to use this font, but....

    Font ArialG not found. Any ideas please??

    Thank you all
    Nick
    Attached Files

  • #2
    Did you "install" the font ? Or just copied it to the fonts directory ?
    Try clicking on "file" and then "install font" ( i think it is, i'm using a dutch windows....)

    Comment


    • #3
      Tried both... No luck.
      Windows DO know abt the fonts. I wrote a stupid program that displays a text usnig this font and it runs. No complaints abt missing fonts.

      Thanx anyway for your try,
      take care
      Nick

      Comment


      • #4
        Greek font problem final solution

        I spend 3 days trying working around the greek font problem.
        I even used a tool to alter the tahoma font so to have greek characters in the proper positions.
        After altering the font, mapmonkey could not recognise the font any more.

        The Final Solution (found by ssarl from MapMonkey forum)

        Run regedit
        make 2 new string values under
        HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\FontSubstitutes
        1st
        Value Name:Tahoma,0
        Value Data:Tahoma,161
        2nd
        Value Name:Tahoma Bold,0
        Value Data:Tahoma,161

        That should do it!!
        So bloody easy

        Comment


        • #5
          Ifraq is right.
          This registry modification works.
          Here is a ready regkey:
          http://www.mp3car.com/vbulletin/atta...chmentid=12398

          Dont forget to reboot after entering the above reg key.

          Comment


          • #6
            Yes but osk doesn't work.....how can i fix that???

            Comment


            • #7
              What do you mean OSK is NOT working?
              You type and nothing appears?
              You have to apply a skin first, with Greek OSK.
              Try this
              If you have set your PC to boot with Greek keyboard enabled (default keyboard=Greek), then maybe you will have problems.... Change default keyboard to English - US and reboot.
              When you open MM, enable Greek keyboard (left alt+left shift).
              Does this work?

              Comment


              • #8
                Hi all,

                as you alll already know, the marvelous registry hack WORKS !!!!!!!
                Now,
                i think that most of us greeks have one final think to sort. How to use the OSK to toggle languages (EN<->EL).
                I have dropped the idea and hopes to have an "alternating OSK" to show either english or greek characters. But, does anyone know how to use the OSK to send the LeftALT-SHIFT key combination to windows to switch language? Or, is there an alternative to it, compatible with touchscreens ?

                Nikos

                Comment


                • #9
                  Originally posted by babisbabis
                  What do you mean OSK is NOT working?
                  You type and nothing appears?
                  You have to apply a skin first, with Greek OSK.
                  Try this
                  If you have set your PC to boot with Greek keyboard enabled (default keyboard=Greek), then maybe you will have problems.... Change default keyboard to English - US and reboot.
                  When you open MM, enable Greek keyboard (left alt+left shift).
                  Does this work?
                  No!!!
                  When i change language to Greek i can't write anything!
                  Only numbers
                  Not desktop keyboard .....it's working, but when i click with my mouse osk doesn't work!

                  Comment


                  • #10
                    It's only doing this in MM.In destinator i can write in greek with no problem from osk

                    Comment


                    • #11
                      Greek OSK

                      For OSK to work in greek you must alter the skin.ini file
                      under the OSK heading.
                      You must use the key.exe program to find the appropriate key positions for the greek aplhabet.
                      See the skin.ini attached file
                      Attached Files

                      Comment


                      • #12
                        I used key exe and the numbers are the same!!!!
                        With this skin ini is working???

                        Comment


                        • #13
                          Just installed MM on a swedish Win XP home ed. and i get the same problem.
                          Attached Files

                          Comment


                          • #14
                            Ok I got my GPS receiver the other day and I didn't have the time to dig into the problem anymore. I wanted to get the thing up and running. So I reinstalled Win XP pro SP2 SWE. And everything worked like a charm

                            Comment

                            Working...
                            X