Announcement

Collapse
No announcement yet.

GPS antenna crashes openMobile

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GPS antenna crashes openMobile

    If I have my GPS antenna (Microsoft GPS-360 P/N X1072407) plugged in when I open openMobile it will close OM in a few seconds. If I do not plug it in, it works fine. Any ideas?

    Win7 SP1, 32 bit
    Asus 1000HE netbook

  • #2
    I would toss that pharos gps-360. That was from the first editions of Streets and trips and unless you had the correct driver it gave problems. The next version of that dongle the gps-500 made by pharos as well but much more reliable and built in driver support in windows. If you were to buy a new unit now I would recommend the globalstat bu-353-s4 thats their newest model with a super fast chip and much more acurate than its earlier version Just my 2 cents SNO

    Comment


    • #3
      you think that is the problem? The antenna works with my other programs, FreeICE and Mappoint

      Comment


      • #4
        Not sure what version of OM you are using but I am not sure if I ever got the GPS provider to be perfectly stable in the old versions and right now the sensors in general need some more finishing work. Is that a standard NMEA dongle? I would say just remove the gps plugin from OM as it is not used for anything right now yet really. And send me the debug log too if you could.
        openMobile - Download
        Like what you see? Donations are always welcome

        Comment


        • #5
          I am not sure what version of Microsoft / Pharos dongle I have, but it does not crash OM. I do have the Embedded GPS plugin activated (but I dont use it as it is not ready) and this only runs an external program anyway. You mention it works with Mappoint. Is Mappoint running the same time OM is running? If more than one application tries to use the same comm port (with out a utility like xport) it could cause an issue.

          Also, if you have other devices (in OpenMobile) that need to have comm port assignments, this could be a conflict like HD Radio (or Character LCD or Arduino - both not ready yet) and they are assigned to the GPS comm port it could be an issue

          These are just things I have noticed during testing cycles.

          As Heezer7 says, post the debug.txt file to help folks in pinpointing the issue.

          John
          03 Cadillac CTS
          ZOTAC G43ITX-A-E 2.5ghz Core i3 2GB 160GB SSD
          Win7 Ultimate - OpenMobile - Directed HD - Wifi
          OMMaps + MS GPS Puck - WiFi via LTE Android phone
          2 Zones - Matrix Orbital LCD - Arduino - Build Pics

          Comment


          • #6
            Just an update:

            I found there was the occassional crash on my testing. Turns out that disabling the serialgps plugin stops the crashing. As Heezer7 mentions that and sensors in general are not finished yet.
            03 Cadillac CTS
            ZOTAC G43ITX-A-E 2.5ghz Core i3 2GB 160GB SSD
            Win7 Ultimate - OpenMobile - Directed HD - Wifi
            OMMaps + MS GPS Puck - WiFi via LTE Android phone
            2 Zones - Matrix Orbital LCD - Arduino - Build Pics

            Comment


            • #7
              I have been out of the country and have not made time to mess with it. I will try it again next week.

              Comment

              Working...
              X