Announcement

Collapse
No announcement yet.

Strange RR problem with auto day/night switching

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Strange RR problem with auto day/night switching

    I have auto skin and gamma switching enabled in RR, setup using an alternative config program posted on this forum. Settings in RR.ini are like this -

    gammamode=2
    autogammamode=1
    autoskinmode=1
    gpsgammamodeoffset=0
    gammadaytime=08:00
    gammanighttime=18:00
    gammaday=0:0:0
    gammanight=-50:-50:-50

    The auto switching is setup to change between day and night settings at the set times. However, whenever RR changes between the day and night skins and gamma, the screen becomes corrupted, and a large grey rectangle appears in the top left of the screen (see screenshot below). This disappears if you change the RR screen (e.g. to music), but when you minimize RR it's still there, and comes back to the top every time the day/night change is activated. When you close RR, the rectangle disappears, otherwise no amount of minimizing RR or refreshing the desktop will get rid of it. The letters "RAN" appear in the middle of the rectangle, in yellow text.

    Any ideas how to get rid of this window? It seems as if the VB code is opening up a form it shouldn't be.

    See the attached screenshot for a picture of what I mean.
    Attached Files

  • #2
    Having had a brief look at the RR source code, the form called "frmSkin" looks like the most likely culprit - it's grey, and the correct size.

    Any ideas why this would randomly appear?

    Screenshot -
    Attached Files

    Comment


    • #3
      got the same prob also. good so it just wasnt me.
      The MC of Florida Car PC Meets
      CAR:2001 Ford Crown Victoria
      PC: Acer EEE 900HA with Win7 with CF 2.0.
      Memory:1G
      Drives:160gig
      WI-FI:Cingular
      GPS:IG2k9
      Screen:Xenarc 700TSV
      The Florida Meets Thread

      Comment


      • #5
        Originally posted by Enforcer View Post
        This may be way of base, but check to see if you have a wait.skin.
        Yup - I'm using BAV2 as my day skin and BMV2 as my night skin - both have a wait.skin

        Comment


        • #6
          Originally posted by hellodave View Post
          Yup - I'm using BAV2 as my day skin and BMV2 as my night skin - both have a wait.skin
          Are you sure you have set the Config up correctly ? Are you using the Skippy config, and are you trying to change the Gamma or the Day/Night skin ?
          See this thread and in particular my post #22
          http://www.mp3car.com/vbulletin/road...ing-skins.html
          Car : Ford Focus Zetec S 1800cc
          Carpc :Galaxy GT-P1000 Original 7in Tab
          Mounted in "On Dash" Custom Install

          Comment


          • #7
            Originally posted by wizz View Post
            Are you sure you have set the Config up correctly ? Are you using the Skippy config, and are you trying to change the Gamma or the Day/Night skin ?
            See this thread and in particular my post #22
            http://www.mp3car.com/vbulletin/road...ing-skins.html
            I'm using the same config as you show in that thread (I assume it's Skippy's?). I've got it set to change both Gamma and skin fully automatically, currently via GPS.

            Comment


            • #8
              Originally posted by hellodave View Post
              I'm using the same config as you show in that thread (I assume it's Skippy's?). I've got it set to change both Gamma and skin fully automatically, currently via GPS.
              Yes it is Skippy's. Why don't you try just one, say changing the skin and not the gamma because that's the most important function, and see if that stops the problem.
              I'm using BMV2 and do just that, and I have no problems with it. I use the same BMV2 skin for both day and night, one being re-coloured for day use.
              Car : Ford Focus Zetec S 1800cc
              Carpc :Galaxy GT-P1000 Original 7in Tab
              Mounted in "On Dash" Custom Install

              Comment


              • #9
                I do need to change both skin and gamma, otherwise everything is too bright at night!

                I'm trying a different workaround at the moment - I'm not sure what frmSkin.skin is used for, but I've resized it to nearly nothing in VB and recompiled RR. The resulting program seems to run OK so I might try it out over the next few days and see what happens. It's not exactly a brilliant solution, but it might suffice until someone finds out what (if anything) is wrong with the day/night switching code.

                Comment


                • #10
                  i had the same issue..

                  i ended up tunrning it off and going back to gammacontrol. which also does freedrive.
                  View My Blog


                  Click for 2GB FREE on-line storage!

                  Comment


                  • #11
                    I had the same exact box happen to me at 4:30 am.
                    The strange thing about it is I made my own day night change for my internal skins and it uses an autoit script to change the skin.
                    So it cannot have anything to do with Skippy’s stuff in my skin.

                    The only thing I can think of in my case coming out of hibernating then switching skins right away is causing this.
                    And the only RR command I use for this is reloadskin.

                    Code:
                    EDIT Added my RR code
                    
                    the autoit will send DAYSKIN or NIGHTSKIN 
                    
                    
                    "DAYSKIN","BYVAR;VOICESAY;<<SAY; day time||SAVETOSKIN;WHATSKIN;0||BYVAR;SDAY;SAYDNSETUP<<SKIN1<<SKIN2<<SKIN3<<SKIN4<<SKIN5<<SKIN6<<"
                    
                    
                    "RUNSKIN1","CLOSECHUCKSTOP||CLOSETOPCLOCK||SETVARBYCODE;LASTSCREEN;RRSCREEN||BYVAR;SKIN1COLOR;SAVETOSKIN;COLORPICK;0<<SAVETOSKIN;COLORPICK;1<<SAVETOSKIN;COLORPICK;2||SAVETOSKIN;THISSKIN;1||RUNQW;$SKINPATH$DAYNIGHT.BAT|0||RELOADSKIN||STARTTOPCLOCK||STARTCHUCKSTOP||SETCOLOR||LOAD;$LASTSCREEN$"
                    2001 S10 ZR2

                    Chucks Skin - to old

                    Comment


                    • #12
                      After changing the size of frmskin.frm to 6px*6px in VB and recompiling RR, the size of the evil grey rectangle has changed accordingly - it's now a tiny square in the top left of the screen, which I can live with. No problems yet; possibly this form is used by part of RR I don't have enabled, e.g. Phoco.

                      Comment


                      • #13
                        frmskin is the main skin form, it's where any screen you see in RR is painted.

                        if you see the box you are seeing it means that for some reason RR has not been able to load the graphics onto the screen it is trying to load.

                        Comment


                        • #14
                          The only reason that would show up is if the skin path is wrong or the requested skin is damaged/missing. RR has a prevention to warn of the problem when FIRST loading but not on skin changes cause it assumes the skin and path are correctly setup.
                          Ride Runner RR's Myspace

                          "Being happy is not about having what you want, it's about wanting what you have."
                          "The best things in life are always free - but that doesn't mean money can't buy you good things."

                          Comment


                          • #15
                            Originally posted by guino View Post
                            The only reason that would show up is if the skin path is wrong or the requested skin is damaged/missing. RR has a prevention to warn of the problem when FIRST loading but not on skin changes cause it assumes the skin and path are correctly setup.
                            Strange - I can switch day/night skins manually with no problem. The night skin does load when switched automatically, but the grey box appears on top of it.

                            Comment

                            Working...
                            X