No announcement yet.

Another MapPoint 2006 not working thread

  • Filter
  • Time
  • Show
Clear All
new posts

  • Another MapPoint 2006 not working thread

    Hello, I am running the latest update to RR, have xport3 running. My bluetooth GPS receiver is on com port 6 and xport runs 10 and 11. RR is set to use MapPoint North America, com port 10. Externally MapPoint uses com port 11. All labels are working correctly as I can see lat and lon etc. I have registered mappointcontrol.ocx in the program directory and also tried making a copy and placing it in the RR directory and then registering it there as well.

    I have GPS Mode set to MENU and when I click on MapPoint I get the to come up and behind it is a greyish screen with a black bar up top. No labels or anything show up on the background skin. All buttons on the MAPPOINT_GPS skin work though. It seems like MapPoint isnt even loading. Any Ideas on what I should do? Thanks -MG

  • #2
    Anyone have any ideas on this. Id really appreciate it. Also does anyone know where the call for Mappoint resides in the source. I can try to take a look at it at some point this week. Thanks -MG


    • #3
      I dont know if this helps at all, but I was looking at the source code and in the frmMPT.frm it shows the object = "{51C0A9CA-F7B7-4F5A-96F4-43927C6FA50F}#1.0#0"; "MappointControl.ocx". I looked into my registry and it shows a subdirectory at win32. Could this be the reason why mappoint isnt loading. -MG


      • #4
        Well, since no one had any ideas on this, I decided to try and make a control in visual basic. Once I started to try and use the control i would get a pop up that said Mappoint North America is not registered on the system. I have Mappoint NA installed and have tried regsvr32 on mapppointcontrol.ocx. It ssays that it registers the control ok. It seems like 2006 just wont register on the system. I have installed and reinstalled. Any ideas on what I can do? Thanks -MG


        • #5
          Well after MUCH Research I have found the solution and now have it working no problem. The Problem is Mappoint 2006 is not installing the registry values or not installing them correctly. DONT WORRY ABOUT REINSTALLING. The following is how I was able to resolve it thanks to someone over at Google Groups. First off this has to do with the registry so i take no responsibility if you mess up something. Also back up your registry so you have a restore point. I added the registry values to my registry according to this website. It took a while but now it all works well.